0
hojnikb

A couple of issues

Recommended Posts

So i'm using Orange Pi PC with the latest armbian desktop image. I've noticed this issues:

 

-Booting takes a long time with wifi adapter (realtek 8188etv), stucks at "lsb raise network interfaces" for 2 minutes, than continues

-Browsing shares via thunar results in this error

Failed to open "/ on".
Operation not supported.

 

 

-No chrome/midori in repos ?

Share this post


Link to post
Share on other sites
realtek 8188etv

 

But is it recognized? Do you use wireless net? 

 

Failed to open "/ on".

 

Correct.

Regarding desktop. We provide minimal, everything else is on user.

 

Please do a:

armbianmonitor -u

Share this post


Link to post
Share on other sites

 

But is it recognized? Do you use wireless net? 

 

 

 

Yes, Wifi card is detected and works flawlessly when system boots to desktop. It just takes a lot of time for lsb to wake it up i suppose.

 

 

Also for samba browsing, what do i have to install/configure so that thunar will browse samba shares ? I

Share this post


Link to post
Share on other sites

It just takes a lot of time for lsb to wake it up i suppose.

 

If you define network interfaces as 'auto' and these aren't ready at startup you run into this typical delay. Changing this to 'allow-hotplug' might solve the 'problem':

sed -i 's/auto\ eth0/allow-hotplug eth0/' /etc/network/interfaces

But you better read through Debian documentation regarding these settings first.

Share this post


Link to post
Share on other sites
Failed to open "/ on".

Operation not supported.

This is not an Armbian related Problem. Install the following Packages: cifs-utils, samba, gvfs-backends and it should work.

 

In case if not : fuse, gvfs, sambaclient,smbnetfs, too.

 

Regards

 

PS: Why is it necessary to have a blinking green Led? (I hate the blue one on my Odroid -C2, too)

Share this post


Link to post
Share on other sites

PS: Why is it necessary to have a blinking green Led? (I hate the blue one on my Odroid -C2, too)

 

This shouldn't happen. The green LED should blink 120 seconds when the board is ready on 2nd boot and just 10 seconds on every later reboot and it switches to 'heartbeat' blinking again when shutting down (since otherwise the green led would stay on even when the board is already powered off):

 

https://github.com/igorpecovnik/lib/blob/master/scripts/armhwinfo#L125

https://github.com/igorpecovnik/lib/blob/master/scripts/armhwinfo#L323

 

Please report back whether that's the culprit and keep in mind that /etc/rc.local is the place to change led behaviour through sysfs -- see link above.

Share this post


Link to post
Share on other sites

So mine green Led shows  "heartbeat" the whole time. (It is not so bright as the Odroids blue one, i can live with it ;) ) Apart  from this 5.10 is fantastic work. The OPiPC is working better than the Odroid C2 (got my system on an USB_Flash drive and it is really "Desktop -near"( i think i will return the C2)

 

Regards

Share this post


Link to post
Share on other sites

So mine green Led shows  "heartbeat" the whole time. (It is not so bright as the Odroids blue one, i can live with it ;) )

 

Did you upgrade using apt-get upgrade/update or started with a new 5.1 image? Anyway to change blinking add one of the two lines to /etc/rc.local prior to the "exit 0" line:

echo default-on >/sys/class/leds/*green*/trigger
echo none >/sys/class/leds/*green*/trigger

Share this post


Link to post
Share on other sites

And you disconnected your Ethernet without changing the config?

 

Didn't even have ethernet cable plugged in from the get go. Always via wifi.

Share this post


Link to post
Share on other sites

So mine green Led shows  "heartbeat" the whole time. (It is not so bright as the Odroids blue one, i can live with it ;) ) Apart  from this 5.10 is fantastic work. The OPiPC is working better than the Odroid C2 (got my system on an USB_Flash drive and it is really "Desktop -near"( i think i will return the C2)

 

Regards

 

Would be possible to configure the led as an sd card activity ?

Share this post


Link to post
Share on other sites

OK, if you don't want to wait at boot, you need to disable eth0 in /etc/network/interfaces

This helped me cut from 2.5minutes to just 1 minute of wait time with lsb. It still waits at network interfaces and ttySAC2.device.

Share this post


Link to post
Share on other sites

This is not an Armbian related Problem. Install the following Packages: cifs-utils, samba, gvfs-backends and it should work.

 

In case if not : fuse, gvfs, sambaclient,smbnetfs, too.

 

Regards

 

PS: Why is it necessary to have a blinking green Led? (I hate the blue one on my Odroid -C2, too)

Great stuff, got it working  :beer:  :beer:

Share this post


Link to post
Share on other sites

 

Did you upgrade using apt-get upgrade/update or started with a new 5.1 image? Anyway to change blinking add one of the two lines to /etc/rc.local prior to the "exit 0" line:

echo default-on >/sys/class/leds/*green*/trigger
echo none >/sys/class/leds/*green*/trigger

I started with a new clean 5.10 Version noupgrade, i have tried both of the lines , but none of them worked. But this is not an Issue, the cheap OPipc is working better than i ever expected.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
0