1 1
cman122887

wifi adapter not persistent across boots

Recommended Posts

Armbianmonitor:

Hello!

First post so apologies for any naivete. I have a USB wifi adapter connected to my la frite (it was the only distro that supported it out the box so thank you). On each boot it seems like the USB is getting a different device address and therefore I have to open nmtui and connect to my wifi all over again, to the point where I have 10+ stored connections to the same wifi in my network managers saved connections.

 

At first I thought I could solve the problem by reversing the Persistent Interface Names settings on boot so that it would be wlan0 and I could automate the connection on startup but that hasn't worked for me either. I've run out of ideas and would appreciate any advice that anyone has.

Thanks!

Share this post


Link to post
Share on other sites
Want Armbian t-shirt or a cup?

I guess you mean this part:

[    8.045636] rtl8192cu 1-2.4:1.0 wlx00e04c8192d7: renamed from wlan0

https://wiki.debian.org/NetworkInterfaceNames

 

Quote

that hasn't worked for me either

It basically did not rename as it should?

 

 

What I also found by a quick search:

Quote
  • You disable the assignment of fixed names, so that the unpredictable kernel names are used again. For this, simply mask udev's .link file for the default policy: ln -s /dev/null /etc/systemd/network/99-default.link
  • You create your own manual naming scheme, for example by naming your interfaces "internet0", "dmz0" or "lan0". For that create your own .link files in /etc/systemd/network/, that choose an explicit name or a better naming scheme for one, some, or all of your interfaces. See systemd.link(5) for more information.
  • You pass the net.ifnames=0 on the kernel command line

 

Share this post


Link to post
Share on other sites
1 hour ago, cman122887 said:

At first I thought I could solve the problem by reversing the Persistent Interface Names settings on boot so that it would be wlan0 and I could automate the connection on startup but that hasn't worked for me either. I've run out of ideas and would appreciate any advice that anyone has.


The problem is (probably - log too short) in MAC address changing. Try to find out hot to fix MAC with the driver and check if our fixes are present:

/etc/NetworkManager/conf.d/10-override-wifi-random-mac-disable.conf

[connection]
wifi.mac-address-randomization=1

[device]
wifi.scan-rand-mac-address=no

They are effective with many (probably all) on-board wireless chips. We don't try to fix problems in 3rd party hardware so you are on your own - worst case = talk to driver maintainer, check different driver, get different WiFi dongle. 

 

Also delete stuff in /etc/NetworkManager/system-connections

Share this post


Link to post
Share on other sites

Hey Igor and Werner,

 

Thanks for taking the time to give your thoughts, I appreciate it as this has been racking my brain.

Igor - I'll look into seeing if I can fix the MAC in the driver as I do have that .conf fix file you were referring to. I also may just end up getting a new dongle cuz yeah this thing is old and was cheap.

Werner - Sorry for not being clear on that, I had got the name to change to wlan0 but trying to use wpa_supplicant did not seem to trigger my device to connect to the network.

 

Cheers

Share this post


Link to post
Share on other sites

So I'm a bit of a dummy.

I did not know I could put in the interface name (wlan0) into the device portion of the network manager connections list.

When it made the entry for me it had <Mac address>(<ifname>) 

00:e0:4c:81:92:5a (wlan0) for instance..

I just removed the Mac address and the parentheses around wlan0 and now network manager is connecting my wifi on boot. I know this not the correct way to do this but this is all I needed.

Thanks for giving me a sounding board to reach this conclusion!

Cheers

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
1 1