Jump to content
  • 0

Nanopi m4v2, SD reader dead, forgotten eMMC password - can I reset?



Hi - trust this is the right forum.


I have forgotten the login password to my Arbian installation on the nanopi m4 V2. It boots from the eMMC just fine, but I am stuck at the prompt.


I had only just installed it a few weeks ago (then things got hectic), so nothing really invested - I could just install again via the SD card, right?


Unfortunately, it looks like the SD slot is no longer working. In the last 2-3 days nothing seems to boot from it.


Which leaves me with an eMMC module loaded up with an Armbian - I think its bionic, because it does have wifi (buster never worked with wifi).

In other 'vanilla' flavours of of linux, I could recover via grub or mounting on a liveUSB, but here I don't know what to do. Is there an Armbian equivalent. I read somewhere that hitting 'space' during boot up would get a menu, but can't find it and it doesn't seem to work, anyway.




1. SD reader has died, apparently. (not happy...)


2. eMMC module is loaded with an Armbian (?bionic?) and I don't have passwords anymore


3. Should I just wait (a Covid-19 wait!) on a eMMC reader to reflash directly from my computer. Has anyone actually done that?


Further question: does anyone have a recommendation for eMMC-USB reader/writer? The Friendly module seems to have a special socket? Not sure if it fits in standard readers.

Board: Not on the list
Link to comment
Share on other sites

5 answers to this question

Recommended Posts

Donate your old hardware to community. Start a giveaway Raffle!

  • 0
2 hours ago, bad_img said:

Unfortunately, it looks like the SD slot is no longer working.

On all Rockchip SoCs, eMMC has boot priority over SDCard.

If you wish to boot from SDCard, you need to stop U-Boot from eMMC by pressing <spacebar> multiple during early boot process, then you get into U-Boot command prompt.

You can then tell U-Boot you wish to boot from SDCard by giving the "setenv devnum 1" command followed by "run mmc_boot" ...

Link to comment
Share on other sites

  • 0

Hi guys, thanks for quick response. I had a forced 24h wait before I could post a reply.


@martinayotte Thanks, but the space-bar trick simply Does Not Work. I notice orangepower had similar problems.


@werner Tried two different SD cards (one brand new), a couple of different .img files (buster, bionic). Copied to the SD cards with dd and Fedora's built-in disc writer. Just not working.


Update - SD cards now booting. Somehow. However, still stuck.


1. got a boot from Bionic on SD (Armbian_20.02.1_Nanopim4_bionic_legacy_4.4.213_desktop.img, shasum double checked), but its got troubles. 

Every keystroke elicits an error message, e.g. typing "r" for "root" default login (retyped here by hand):


Armbian 20.02.1 Bionic tty1
nanopim4 login: r[  43.559332] rockchip-dmc dmc: Get wrong frequency, Request 800000000, Current 856000000
r[  43.667278] rockchip-dmc dmc: Get wrong frequency, Request 800000000, Current 856000000


This (or similar) pops up throughout shutdown dialogue, too. 


2. Buster now boot from SD, but 


a) wifi connection performs only sometimes, and 


b) does not seem to recognize the eMMC module when I plug it in, so `nand-sata-install` only offers reinstalling U-boot on (what seems to be) the SD card - I only have menu option 5. The eMMC does not show up with `lsblk`, `fdisk -l` or in `~/proc/partitions`. I don't know how to force it to find the module.

Link to comment
Share on other sites

  • 0
5 hours ago, bad_img said:

got a boot from Bionic on SD (Armbian_20.02.1_Nanopim4_bionic_legacy_4.4.213_desktop.img...

[  43.667278] rockchip-dmc dmc: Get wrong frequency, Request 800000000, Current 856000000

Try using M4V2 image (instead of the M4 one). It should configure the DMC with correct RAM frequencies.


5 hours ago, bad_img said:

does not seem to recognize the eMMC module when I plug it in... I don't know how to force it to find the module.

eMMC modules are not automatically recognised when inserted. Try issuing following commands as root to discover it after inserting:

echo fe330000.sdhci > /sys/bus/platform/drivers/sdhci-arasan/unbind
echo fe330000.sdhci > /sys/bus/platform/drivers/sdhci-arasan/bind


Link to comment
Share on other sites

  • 0

I can't post more than once per 24 hours, so its 1am and I am struggling to account for everything i did ~14h and (one restart) ago. Basically my terminal went nuts trying to verify a file, and I'm wondering if its corruption or malware.


Downloaded the images for V2, as per /u/piter75's advice.

Tried to `gpg --verify` with Focal. First, it was this:


[user@d-nanopi-m4 Armbian_20.05.1_Nanopim4v2_focal_current_5.4.43_desktop]$ gpg --verify Focal_current_desktop.asc Armbian_20.05.1_Nanopim4v2_focal_current_5.4.43_desktop.img
gpg: Signature made Sun May 31 06:59:23 2020 AEST
gpg:                using RSA key DF00FAF1C577104B50BF1D0093D6889F9F0E78D5
gpg: BAD signature from "Igor Pecovnik <igor@armbian.com>" [unknown]


I futzed around zipping and moved some files (can't remember). I think I unzipped Buster package and verified it no problems.


Came back to the focal package and tried to verify again.


My terminal output went beserk. Just screens and screen of symbols and code - I think there is some English text blocks in there, but I can't be sure what because of the scrolling. 


I was fortunate enough to do it in a separate virtual machine, so I paused the VM. (I've had to restart the host. Haven't opened the VM again). I don't know what to think. Malware? A stray "verbose" command?


My last 2 commands were (as close as I can remember it exactly):


gpg --verify F*asc A*img


I truncated it because I was trying to save typing effort. It threw an error (couldn't find file or something?)

gpg --verify Focal_current_desktop.asc Armbian_20.05.1_Nanopim4v2_focal_current_5.4.43_desktop.img

and that's when things went crazy. 


Some points: I had to newly import the public key on this VM for this exercise, using the instructions on the Armbian website: 

gpg --keyserver ha.pool.sks-keyservers.net --recv-key DF00FAF1C577104B50BF1D0093D6889F9F0E78D5

This is probably down to my confusion about which file to verify and where to keep files, but I got a lot of BAD signature from "Igor Pecovnik..." messages and I didn't understand why. 


I unzipped the Focal .xz to give a 3.7GB file, and moved the .asc and .sha files (both apparently modified yesterday) into that folder.


The .asc and .sha files were downloaded from the website with wget. The image files were direct downloads from the V2 webpage through the browser.


I note many of the integrity check files were very recently modified. I also note that gpg malfunctioned only after I unzipped the focal download.


I really don't have the knowledge to understand what's going on, but I'd be grateful if someone could look into this and provide insight. I am always suspicious of malware, (but I really thought if it was any good it would be better hidden). 

Link to comment
Share on other sites

This topic is now closed to further replies.
  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines