NanoPi R2S USB in u-boot

Recommended Posts

I have recently started working with a NanoPi R2S. I have it booting from the built-in microSD. However, I would like to be able to boot off of USB. When I interrupt u-boot and start USB on the board, it finds the hub but does not seem to find *any* device. I have tried various USB sticks of different sizes and brands, and a few ordinary devices such as a mouse. Nothing.


Is this a known problem? Should it be able to work?



Link to post
Share on other sites
Armbian is a community driven open source project. Do you like to contribute your code?

Thanks for the replies. The link to the Rockchip boot sequence is definitely helpful.


On running the split boot, that is kind of what I was trying. I have an SD card (with the official Armbian distro for the R2S) in the slot, and it starts the boot from that. I then interrupt it at the u-boot prompt, and then do "usb start". It loads the driver, sees the onboard USB hub, but never finds any device attached to the USB port. I know the NanoPi R2S is a recent board, so maybe there is some missing or not supported?


I also tried this with the official distro from FriendlyARM, but that version of u-boot is really old (2014 according to the version number) and does not seem to really support USB.


I would be happy to test things if anyone has a suggestion. Thanks for any help.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.