Jump to content

Looses HDMI on boot when linux kernel loads


Recommended Posts




I've a olimex lime2 rev.K board and i installed Armbian 20.08.0-trunk (Bionic-minimal) which is having ...

  • Kernel Version : 5.4.51-sunxi (branch -> next )
  • u-boot : v2020.04


I've serial console on which I can see that board boot correctly.


I want the board to show information and login prompt on HDMI output...but HDMI losses on boot when  kernel loads, Part way through Kernel load looses monitor sync signal and monitor goes blank.  Can sometimes get back for short period (5-10 seconds) if unplug/plug HDMI cable but still looses sync and monitor doesn’t detect that anything is connected.


I spent a lot of time on forums, my board is powered with power adapter and My monitor is a TV. Board is booted via emmc memory.


I've also seen on posts that resolution could be the problem, I've change in /boot/armbianEnv.txt:



disp_mode=1920*1080p60 to 1280*1024p60


save it and reboot


not working...


Sorry for my question if it has already been solved or if it is a silly question too.


May me some one point me to the related docs or some pointer to move further. 


I appreciate any support here !






Link to comment
Share on other sites

The latest release is 20.08 but you do have some either user-built or 3rd party debs for kernel etc. installed (notice the -trunk suffix)

You can get officially supported images here: https://www.armbian.com/olimex-lime-2-emmc/

Also you can use armbian-config to install a kernel package from Armbian repositories.

Link to comment
Share on other sites

Thank You !, will use official image but how can i made some changes in root file system ?

As of now, i pulled the source from armbian git repo and built it manually and made the required changes "https://docs.armbian.com/Developer-Guide_Build-Preparation"


Is there a way to make these file system changes in the official image ?


Appreciate your support !


Warm Regards,



Link to comment
Share on other sites

You cannot because any modifications will break their digital signatures. However in general there is no issue with running a customized image. Furthermore Armbian is designed to be customized by its users.


However if they come up with issues running a custom image we cannot help because we dont know what has changed and how these changes could impact or break other things.

Therefore we must ask to verify that the mentioned issue is present in official images too. That is why I was asking you trying to reproduce your issue with an actual Armbian kernel package :)


Link to comment
Share on other sites

Thank You again !, I got your point here and its really very informative.


Now i will change my approach and first i try to reproduce the same issue with the official image if its worked fine then dip and dive to the customization one :) 




Link to comment
Share on other sites

I checked and found HDMI Driver having some issue in kernel version 5.4.51(trunk), which got resolved in the later release.

Now, i migrated to the latest one and having working HDMI.

Thank You @Werner for your support !


Sorry for bothering you guys again -

I have one more query, related to root file system, I am using ubuntu bionic (18.04) root file system.

  • Installed quagga version 1.2.4_1, It has some bug in this release later they fix this bug and release a latest version i.e 1.2.4_8.
  • Here my question is, how i update this package to the latest one in Ubuntu Bionic root file system.
  • Older version of quagga is installed during image creation by putting package name in lib.config file under userpatch dir.

Please guide me or point me to the docs, how i update this during image build.


I appreciate you support here :)



  1. https://redmine.pfsense.org/issues/8339
  2. https://savannah.nongnu.org/forum/forum.php?forum_id=9099


Thanks & Regards,



Link to comment
Share on other sites

  • Igor locked this topic
This topic is now closed to further replies.
  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines