No sound with expansion board Orange PI Zero H2


Medapayne
 Share

2 2
Go to solution Solved by guidol,

Recommended Posts

Good morning all

I have an OPi Zero H2 with the official expansion card.
My goal is to make an Airport module to connect a speaker to it.
The installation of Shairport in APT all is ok I can see the sharing on my iPhone.
But the problem is that I have no sound when I plug a speaker into the 3.5mm jack port on the expansion card.
I have correctly installed the "analog-codecs" and made a reboot.
In Alsamixer I put "Line-Out" and "DAC" to the maximum (red).
But still no sound ...
When in doubt, I did all these operations on Armbian Focal / Buster / Bionic but it didn't change anything.
Can you help me please?
believe me I have tried everything for 4 days but without success.

thank you in advance for your help

Link to post
Share on other sites

Donate and support the project!

Your support topic is lacking of important debugging information. Please edit and fix!

 

Please describe your setup as best as possible so we know what your operating environment is like.

 

  • Name of your board with all details, version number, take a picture if you are not sure what you have
  • Name of the image you installed or logs if you can boot the board: armbianmonitor -u (paste URL to your forum post)
  • If your board does not boot, provide a log from serial console (UART) or at least make and attach a picture, where it stops.
  • Describe the problem the best you can and provide all necessary info that we can reproduce the problem.
  • If anything is attached to the board, supply all details

 

Tips:

 

  • use spoiler image.png when adding a long text,
  • use image.png when adding a code,
  • be concise.
Link to post
Share on other sites

  • Solution

@Medapayne

create a /etc/asound.conf to get the analog audio card as default.

whats the output of

aplay -l

 

Mine:
 

  ___  ____  _   _____
 / _ \|  _ \(_) |__  /___ _ __ ___
| | | | |_) | |   / // _ \ '__/ _ \
| |_| |  __/| |  / /|  __/ | | (_) |
 \___/|_|   |_| /____\___|_|  \___/

Welcome to Armbian 20.08.9 Buster with Linux 5.9.1-sunxi

root@opi-zero(192.168.6.99):~# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Codec [H3 Audio Codec], device 0: CDC PCM Codec-0 [CDC PCM Codec-0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

root@opi-zero(192.168.6.99):~# more /etc/asound.conf
pcm.!default {
    type hw
    card 0
    device 0
}

ctl.!default {
    type hw
    card 0
}


and enable [*] analog-codec
in armbian-config -> system -> hardware

 

Link to post
Share on other sites

[mention=16514]Medapayne[/mention]
create a /etc/asound.conf to get the analog audio card as default.
whats the output of
aplay -l
 
Mine:
 
  ___  ____  _   _____/ _ \|  _ \(_) |__  /___ _ __ ___| | | | |_) | |   / // _ \ '__/ _ \| |_| |  __/| |  / /|  __/ | | (_) |\___/|_|   |_| /____\___|_|  \___/Welcome to Armbian 20.08.9 Buster with Linux 5.9.1-sunxiroot@opi-zero(192.168.6.99):~# aplay -l**** List of PLAYBACK Hardware Devices ****card 0: Codec [H3 Audio Codec], device 0: CDC PCM Codec-0 [CDC PCM Codec-0] Subdevices: 1/1 Subdevice #0: subdevice #0root@opi-zero(192.168.6.99):~# more /etc/asound.confpcm.!default {   type hw   card 0   device 0}ctl.!default {   type hw   card 0}and enable [*] analog-codecin armbian-config -> system -> hardware

 


It works great ... THX


Envoyé de mon iPhone en utilisant Tapatalk
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

2 2