Can not find image to download for TX3 mini

Recommended Posts

Donate and support the project!

Adding to this, I have a TX3 mini with an S905W currently running 5.7.0 off an sd card. Is there any way to upgrade? I don't mind losing data and wiping everything but I don't know where to find the appropriate builds after the fallout in the main thread. From what I understand, Balbes made it mandatory to have a uboot which is available for only a few specific models. Is this wrong or is there a way to get the newer builds running, like some sort of clean install method?

Edited by Zazazas
Link to post
Share on other sites

Hi SteeMan

I'm newbie, it's quite difficult for me to clearly understand the fisrt post of that thread, there are also so much comments in that thread. I don't know which image file should I download and how to do with uboot file. Could you please share your experience.


Thanks and best reagds


Link to post
Share on other sites
17 hours ago, Ngo Thang said:

I don't know which image file should I download

To answer this, you need to tell us what you are planning to do with your tx3 mini box.  Also if you could let us know your experience level with linux and different linux distributions that would be helpful as well.

Link to post
Share on other sites

Given that you do have general linux knowledge and rpi familiarity, here are my comments on your requests.

I have 4 TX3 mini's three of which I run armbian on and one that I use the original android on.  I will mention that just because a box is labeled TX3 mini, doesn't mean the internals are the same.  The manufactures put identical external branding on boards that may be significantly different.  For example all TX3 minis claim they have emmc storage in them.  But only two of my TX3 minis have emmc storage, the other two come with nand storage (cheaper to manufacture that way).  Since mainline linux doesn't support nand I can only install armbian on internal storage on two of my boxes.


From the above linked post you need to download an image file from any of the download locations.  The file you are looking for is the arm-64 version from October 14th 2020.  These are the last versions from balbes150 to support Amlogic cpus.  So be warned that when and if you get this running on your TX3 mini box, there is currently no path to get anything newer than this Oct 14 build with 5.9.0 kernel.  You will get updates from your chosen distribution (debian or ubuntu) just no kernel updates, unless someone else in the community picks up the ball and begins building/maintaining amlogic kernels.


In the downloads directory you will find builds for debian (buster and bullseye) and ubuntu (bionic and focal), along with both a desktop and non-desktop version of each.


Once you download your chosen build (for example - ubuntu focal non-desktop build)

You need to burn the image to an SD card.  Generally balenaEtcher is recommended (however I have only ever used dd on linux to create my sd cards, so I have no familiarity with that tool)


Once you have the SD card with your chosen build, then you need to edit the boot configuration file on the SD card.  In the BOOT partition of the SD card there will be a file /boot/extlinux/extlinux.conf, that you need to edit. (In earlier builds this was done in the /boot/uEnv.txt file, so a lot of comments in these threads talk about that file, but in the latest builds it was changed to the extlinux.conf file)


Your extlinux.conf file should look like:

LABEL Armbian
LINUX /zImage
INITRD /uInitrd

# aml s9xxx
#FDT /dtb/amlogic/meson-gxbb-p200.dtb
FDT /dtb/amlogic/meson-gxl-s905w-tx3-mini.dtb
#FDT /dtb/amlogic/meson-gxm-q200.dtb
#FDT /dtb/amlogic/meson-g12a-x96-max.dtb
#FDT /dtb/amlogic/meson-g12b-odroid-n2.dtb
APPEND root=LABEL=ROOTFS rootflags=data=writeback rw console=ttyAML0,115200n8 console=tty0 no_console_suspend consoleblank=0 fsck.fix=yes net.ifnames=0

Basically you need to have the correct dtb for your box and the correct boot command for your box, along with the top three environment variables set.  *Everything* else needs to either be deleted or commented out.  This is a common mistake where people uncomment out what they need, but leave other lines in the file not uncommented and thus they fail to boot.  The extlinux.conf file above is directly from my TX3 mini box.  Note that if you were using a different box than a TX3 mini, you would attempt to use different dtb files until you found the one that works the best for you boxes hardware (there are a bunch of dtb files in /boot/dtb/... to try depending on your cpu architecture and hardward).


Next you need to copy the correct uboot for your box.  This is needed for amlogic cpus (other cpus have different uboot stuff to do).  For your TX3mini you need to copy u-boot-s905x-s912 to u-boot.ext (note I say copy not move).


Once you have your SD card prepared, on an Amlogic box you need to enable multiboot.  There are different ways documented to do this, but for your TX3 mini box, you should use the toothpick method.  At the back of the audio/video jack connector is a hidden reset button.  By pressing that button with a toothpick or other such pointed device you can enable multiboot.  What you need to do is have the box unpluged, have your prepared sd card inserted, then press and hold the button while inserting the power connector.  Then after a bit of time you can release the button.  (I don't know exactly how long you need to hold the button after power is applied, but if it doesn't work the first time try again holding for longer or shorter times).


You should now be booting into armbian/linux.


If you want at this point, you can copy the installation to emmc (assuming your box has emmc).  You do this by running the appropriate shell script in /root, which for your case is /root/  Note that it is recommended that you make a backup of emmc first (use the ddbr tool that should be installed on your sd card).  Also be prepared if anything goes horribly wrong with your emmc install to reinstall the armbian firmware using the Amlogic USB Burning Tool to unbrick your device.  It is pretty easy to find TX3mini android firmwares on the internet and you can generally recover a bricked box using the Amlogic tool and an original firmware file.


Finally, I have written this from memory and haven't been actually doing these steps as I am writing, so there might be something I forgot to say, so I make no promises that this is completely accurate, but I think it is.


Also, don't expect that all parts of your TX3mini box will work.  You should have a working boot, working wired ethernet and working hdmi.  Don't expect things like wifi, bluetooth, infrared remote, box display to work.  The experimental armbian for these boxes is enough to get a basic server running and a light graphical display, but don't expect full functionality.


Link to post
Share on other sites

Hi SteeMan

Thank you for your very detail guideline. I follow but still get a problem

I download image, flash to SDCard via balenaEtcher,  edit /boot/extlinux/extlinux.conf with correct DTB parameter

I push SDCard into, hold reset and power on, but my TX3 mini always shows the screen as in picture, as far as I understand it is recovery screen

It can't boot into armbian in SDCard


Best regards




Edited by Ngo Thang
Link to post
Share on other sites