• 0

Random reboots


axeleroy
 Share

2 2

Question

Hi,

 

I'm very pleased with my Helios 64, but since I updated to Armbian 20.11.6 (from 20.08.11 or 21, not really sure) it reboots at random times: it can run fine for over two weeks and reboot twice in 36 hours, always when idling.

It's running OMV as well a multiple Docker containers: PiHole, Wireguard, Nginx, Transmission, restic-server and n8n.

 

Is it a common issue? What fixes do you recommend? What should I look for to diagnose the issue?

 

Thank you.

 

Edit: forgot to mention that I'm using SnapRAID and mergerFS, as well as NFS shares.

Edited by axeleroy
Link to post
Share on other sites

9 answers to this question

Recommended Posts

Donate and support the project!

  • 0

It happened again.

Should I try updating to the Armbian version that jiust came out?
When should I run armbianmonitor (whenever I can or just after a reboot?) and what should I be looking for (because nothing seems odd to me, but I'm not that of an advanced user)

 

Thanks !

Link to post
Share on other sites

  • 0
Am 8.2.2021 um 04:25 schrieb gprovost:

@axeleroy

Hi, could try to the following tweak and then report to us if it helps stabilizing your system.

 

Run armbian-config, go to -> System -> CPU

 

And set:

Minimum CPU speed = 1200000

Maximum CPU speed = 1200000

CPU governor = performance

 

 

 

Does it make a difference which minimum Speed is used? I would prefer to set the lowest CPU Speed as minimum to save energy use when there is low CPU usage.

 

Link to post
Share on other sites

  • 0
Am 8.2.2021 um 04:25 schrieb gprovost:

@axeleroy

Hi, could try to the following tweak and then report to us if it helps stabilizing your system.

 

Run armbian-config, go to -> System -> CPU

 

And set:

Minimum CPU speed = 1200000

Maximum CPU speed = 1200000

CPU governor = performance

 

 

I had a similar issue with random reboots. Did DM @axelroy directly and also "tweaked" the system.

 

I am running the helios now for almost 2 weeks without issues with the following settings:

Min CPU speed = 400 MHz

Max CPU speed = 1400 MHz

CPU governor = on demand

 

So it seems that the helios was rebooting when having to deal with intensive tasks - in my case: performing a SnapRAID scrub. Anyhow: Now I am at maximum speed of 1400MHz whereas the helios could perform even on 1800MHz. The question is if this is a problem by design? Or is there a way to fix it in order to let the machine run full CPU speed and performance governor? I am happy with the machine, no doubt, at the end this is rather a question of how I can achieve the maximum speed if needed.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

2 2