[SOLVED] [OPi Lite] Wifi cannot connect to WPA


Recommended Posts

Hey everyone,

 

First off, I don't use Linux often so please bear with me if I miss out on obvious things.  I have a few Orange Pi Lite boards, and after booting up Armbian 5.14 I was excited to give the Wifi a try after only having ethernet on my Orange Pi One boards.  My OPi Lite sees my network just fine, but when I put in my credentials and go to connect to it, it fails returning "Bad Password".  For what it's worth, I've checked the password probably 25+ times, I promise it's right.  The wifi WILL connect to open networks, however.  Is there some obvious solution that I'm missing here?

 

Any help or direction would be appreciated.  Thanks!

Link to post
Share on other sites
Armbian is a community driven open source project. Do you like to contribute your code?

Hey everyone,

 

First off, I don't use Linux often so please bear with me if I miss out on obvious things.  I have a few Orange Pi Lite boards, and after booting up Armbian 5.14 I was excited to give the Wifi a try after only having ethernet on my Orange Pi One boards.  My OPi Lite sees my network just fine, but when I put in my credentials and go to connect to it, it fails returning "Bad Password".  For what it's worth, I've checked the password probably 25+ times, I promise it's right.  The wifi WILL connect to open networks, however.  Is there some obvious solution that I'm missing here?

 

Any help or direction would be appreciated.  Thanks!

 

We are having similar problems with Beelink X2 here http://forum.armbian.com/index.php/topic/872-beelink-x2-with-armbian-possible/page-4

Link to post
Share on other sites

@Kagami

Did you generate your password entry (wpa-psk) in /etc/network/interfaces with wpa_passphrase?

 

I did, to no avail unfortunately.  Exact same issue as before.  Thanks though!

 

Hi, I had the same problem, and I resolved it by changing WPA driver in Wicd preferences to "nl80211". Now it works with normally. I use Jessie Desktop on O-Pi Lite.

 

Thanks for your response!  I'm happy you found a solution for your issue, unfortunately it didn't work for mine.

 

I just tested wireless on Opi Lite with connecting to WPA2 router and it works without a problem. Using image from download or self built from sources, Ubuntu Xenial server.

 

Desktop users might need to play around wicd settings.

 

Thank you, I should have mentioned that I am using Jessie Desktop, I forgot to mention that in my main post.  Initially it didn't work for my situation, however I noticed that under wpa_supplicant there are two options called 'none'.  I chose the first one, rebooted, and nothing happened.  However, choosing the second one and rebooting got my OPi Lite to connect to my network!  I don't know why they would be different, maybe it was just a fluke, but it connected for the first time ever.  Thank you very much for the help to you and everyone who responded, I'm so relieved to have a solution to this after about a week of playing with it.

Link to post
Share on other sites

Same problem, but this did not help.

Tried two Opi PC pluses on two different networks, two different sd cards.

It seems to be related to the password.

 

Both networks are set to WEP (Passphrase), but have different passwords, each only 8 characters.

 One password is too simple, all characters could be either hex or text.

the other network's password is also 8 characters but random alpha.

 

We altered the simple password network password by adding a 'z' to the end of its password and now it works fine.

 

It seems as if the wireless code is having difficulty between HEX ans Passphrase.

Link to post
Share on other sites

It seems as if the wireless code is having difficulty between HEX ans Passphrase.

 

What do you refer to when talking about 'wireless code'? Do you configure the stuff directly or use any GUI tool for that?

 

Apart from that in case Armbian ships with GUI tools that still allow WEP (encryption can be considered broken since almost a decade!) we should check whether we can disable this to prevent users from fooling theirselves. WEP in 2016 is like an unecrypted connection and should not be used.

Link to post
Share on other sites

Sorry I was not complete and accurate.

Debian Jessie desktop 5.14 apt-get upgraded to 5.16 as of 36 hours ago.

 

The gui in the upper right of the default X interface autologed in as the user defined during install

The Wicd Network Manager GUI, properties of the wireless AP,

selected "WPA 1/2 (Passphrase) preshared key"

The first key was "bbbbbbbb" which could be interpreted as HEX or as ascii.

The second key was "katielee" unmistakably ascii.

The bbbbbbbb was changed to bbbbbbbbz and then it worked.(did not get "Bad Password" and succeeded in connecting to network.)

 

As for code I meant the probable C code that the gui is using to evaluate the key.

 

The log of my install is here:

https://www.facebook.com/groups/1483270805309190/permalink/1573610346275235/

Link to post
Share on other sites

I wanted to share that i was having the same issues and i was able to solve them with everyone's help.

 

 

My fix involved:

1) Go to Wicd preferences

2) Go to advanced settings

3) Select nl80211 driver

4) Selecting the Properties of my Wifi

5) Select Use Encryption

6) Select WPA 1/2 (Passphrase)

7) Type in the password, then connect. 

 

It worked for me but may not work for everyone. It should be a decent start though.

Thank you to every one that posted here and elsewhere.  

 

 

Link to post
Share on other sites
Guest
This topic is now closed to further replies.