Jump to content

BananaPiZeroM2 usbIp support


Recommended Posts

Hello!

 

I've searched for it in topics and have found that it is very popular question-) But I'll ask it more specific. Is there any armbian or any other sd image with usbIp support builtin to download? I know that I can build it from source, but I have no idea how to do it-) Please provide me with a link if it is one.

Link to comment
Share on other sites

Check forum guidelines to use maximum potential!

Pretty complicated for me. I've understood hoe to compile it on my board, but I can't understand how to add usbip support.. Now trying something like that on my local machine: ./compile.sh BOARD_NAME="Banana Pi M2 Zero" BOARDFAMILY="sun8i" BOOTCONFIG="bananapi_m2_zero_defconfig" MODULES_LEGACY="g_serial" MODULES_CURRENT="g_serial" SERIALCON="ttyS0,ttyGS0" KERNEL_TARGET="legacy,current,edge" CONFIG_USBIP_CORE=m CONFIG_USBIP_VHCI_HCD=m CONFIG_USBIP_HOST=m CONFIG_USBIP_DEBUG=n

 

But getting this:

 

[ error ] ERROR in function interactive_config_ask_kernel_only [ functions/cli/cli-entrypoint.sh:105 -> functions/main/config-prepare.sh:89 -> functions/configuration/interactive.sh:15 -> functions/configuration/interactive.sh:27 -> functions/logging/traps.sh:0 ]
[ error ] No option selected
[ o.k. ] Process terminated

 

Okay-) I've installed dialog package and some text menu appeared. I've selected my board, but getting an error:

 

[ error ] ERROR in function download_and_verify [ functions/cli/cli-entrypoint.sh:108 -> functions/main/default-build.sh:7 -> functions/host/prepare-host.sh:203 -> functions/general/downloads.sh:156 -> functions/logging/traps.sh:0 ]
[ error ] Failed to recieve key [ 8F427EAF ]
[ o.k. ] Process terminated

 

tried remove cache and USE_TORRENT="no" but still no success.

 

Here is the log. If it helps:

 

[ .... ] Extension being added [ sunxi-tools :: added by functions/cli/cli-entrypoint.sh:105 -> functions/main/config-prepare.sh:135 -> functions/configuration/main-config.sh:174 -> config/sources/families/sun8i.conf:1 -> config/sources/families/include/sunxi_common.inc:1 ]
[ o.k. ] Extension manager [ processed 3 Extension Methods calls and 3 Extension Method implementations ]
[ o.k. ] Preparing [ host ]
[ o.k. ] Build host OS release [ jammy ]
[ .... ] Installing build dependencies
[ o.k. ] Syncing clock [ host ]
[ o.k. ] Checking for external GCC compilers
[ .... ] downloading using http(s) network [ gcc-linaro-aarch64-none-elf-4.8-2013.11_linux.tar.xz ]

11/14 23:41:47 [ERROR] Failed to open ServerStat file /home/kamensky/Armbian/build/cache/.aria2/server_stats for read.
[#02da23 3.4MiB/24MiB(13%) CN:1 DL:361KiB ETA:1m]                                                       
11/14 23:41:58 [ERROR] CUID#6 - Download aborted. URI=https://armbian.site-meganet.com/dl//_toolchain/gcc-linaro-aarch64-none-elf-4.8-2013.11_linux.tar.xz
Exception: [AbstractCommand.cc:351] errorCode=5 URI=https://armbian.site-meganet.com/dl//_toolchain/gcc-linaro-aarch64-none-elf-4.8-2013.11_linux.tar.xz
  -> [DownloadCommand.cc:309] errorCode=5 Too slow Downloading speed: 371370 <= 512000(B/s), host:armbian.site-meganet.com
[#02da23 3.5MiB/24MiB(14%) CN:1 DL:0B]                                                                  
11/14 23:42:48 [ERROR] CUID#11 - Download aborted. URI=https://armbian.astra.in.ua//_toolchain/gcc-linaro-aarch64-none-elf-4.8-2013.11_linux.tar.xz
Exception: [AbstractCommand.cc:340] errorCode=2 Timeout.
[#02da23 8.0MiB/24MiB(32%) CN:1 DL:487KiB ETA:35s]                                                      
11/14 23:42:58 [ERROR] CUID#13 - Download aborted. URI=https://mirror-eu-de1.armbian.airframes.io/dl//_toolchain/gcc-linaro-aarch64-none-elf-4.8-2013.11_linux.tar.xz
Exception: [AbstractCommand.cc:351] errorCode=5 URI=https://mirror-eu-de1.armbian.airframes.io/dl//_toolchain/gcc-linaro-aarch64-none-elf-4.8-2013.11_linux.tar.xz
  -> [DownloadCommand.cc:309] errorCode=5 Too slow Downloading speed: 472685 <= 512000(B/s), host:mirror-eu-de1.armbian.airframes.io
[#02da23 10MiB/24MiB(42%) CN:1 DL:287KiB ETA:50s]                                                       
11/14 23:43:09 [ERROR] CUID#14 - Download aborted. URI=https://stpete-mirror.armbian.com/dl//_toolchain/gcc-linaro-aarch64-none-elf-4.8-2013.11_linux.tar.xz
Exception: [AbstractCommand.cc:351] errorCode=5 URI=https://stpete-mirror.armbian.com/dl//_toolchain/gcc-linaro-aarch64-none-elf-4.8-2013.11_linux.tar.xz
  -> [DownloadCommand.cc:309] errorCode=5 Too slow Downloading speed: 343834 <= 512000(B/s), host:stpete-mirror.armbian.com
[#02da23 15MiB/24MiB(63%) CN:1 DL:484KiB ETA:19s]                                                       
11/14 23:43:19 [ERROR] CUID#15 - Download aborted. URI=https://es-mirror.bret.dk/armbian/dl//_toolchain/gcc-linaro-aarch64-none-elf-4.8-2013.11_linux.tar.xz
Exception: [AbstractCommand.cc:351] errorCode=5 URI=https://es-mirror.bret.dk/armbian/dl//_toolchain/gcc-linaro-aarch64-none-elf-4.8-2013.11_linux.tar.xz
  -> [DownloadCommand.cc:309] errorCode=5 Too slow Downloading speed: 495656 <= 512000(B/s), host:es-mirror.bret.dk
[#02da23 18MiB/24MiB(72%) CN:1 DL:222KiB ETA:31s]                                                       
11/14 23:43:30 [ERROR] CUID#16 - Download aborted. URI=https://mirrors.dotsrc.org/armbian-dl//_toolchain/gcc-linaro-aarch64-none-elf-4.8-2013.11_linux.tar.xz
Exception: [AbstractCommand.cc:351] errorCode=5 URI=https://mirrors.dotsrc.org/armbian-dl//_toolchain/gcc-linaro-aarch64-none-elf-4.8-2013.11_linux.tar.xz
  -> [DownloadCommand.cc:309] errorCode=5 Too slow Downloading speed: 229529 <= 512000(B/s), host:mirrors.dotsrc.org
[#02da23 19MiB/24MiB(78%) CN:1 DL:156KiB ETA:35s]                                                       
11/14 23:43:41 [ERROR] CUID#17 - Download aborted. URI=https://mirrors.netix.net/armbian/dl//_toolchain/gcc-linaro-aarch64-none-elf-4.8-2013.11_linux.tar.xz
Exception: [AbstractCommand.cc:351] errorCode=5 URI=https://mirrors.netix.net/armbian/dl//_toolchain/gcc-linaro-aarch64-none-elf-4.8-2013.11_linux.tar.xz
  -> [DownloadCommand.cc:309] errorCode=5 Too slow Downloading speed: 170513 <= 512000(B/s), host:mirrors.netix.net
[#02da23 22MiB/24MiB(91%) CN:1 DL:289KiB ETA:7s]                                                        
11/14 23:43:52 [ERROR] CUID#18 - Download aborted. URI=https://imola.armbian.com/dl//_toolchain/gcc-linaro-aarch64-none-elf-4.8-2013.11_linux.tar.xz
Exception: [AbstractCommand.cc:351] errorCode=5 URI=https://imola.armbian.com/dl//_toolchain/gcc-linaro-aarch64-none-elf-4.8-2013.11_linux.tar.xz
  -> [DownloadCommand.cc:309] errorCode=5 Too slow Downloading speed: 296856 <= 512000(B/s), host:imola.armbian.com
[#02da23 24MiB/24MiB(96%) CN:1 DL:142KiB ETA:6s]                                                        
11/14 23:44:03 [ERROR] CUID#19 - Download aborted. URI=https://armbian.hosthatch.com/dl//_toolchain/gcc-linaro-aarch64-none-elf-4.8-2013.11_linux.tar.xz
Exception: [AbstractCommand.cc:351] errorCode=5 URI=https://armbian.hosthatch.com/dl//_toolchain/gcc-linaro-aarch64-none-elf-4.8-2013.11_linux.tar.xz
  -> [DownloadCommand.cc:309] errorCode=5 Too slow Downloading speed: 128936 <= 512000(B/s), host:armbian.hosthatch.com
[#02da23 24MiB/24MiB(99%) CN:1 DL:101KiB]                                                               
[ error ] ERROR in function download_and_verify [ functions/cli/cli-entrypoint.sh:108 -> functions/main/default-build.sh:7 -> functions/host/prepare-host.sh:203 -> functions/general/downloads.sh:156 -> functions/logging/traps.sh:0 ]
[ error ] Failed to recieve key [ 8F427EAF ]
[ o.k. ] Process terminated

Edited by maxim221
Link to comment
Share on other sites

well ok! I've managed to reprogram slave device to use uart instead of USB. But I can't enable it!-)) Can you please help. I've managed to find info about changing armbianEnv.txt but I don't know how to add uart support there. I'm using banana pi zero and Armbian_22.11.0-trunk_Bananapim2zero_kinetic_edge_6.0.7_xfce_desktop.img.xz can You please help?

 

I have no device configuration option in armbian config. Is there any way to add it or how to configure armbianEnv.txt?

Edited by maxim221
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...