Jump to content

Unable to complete bootloader bypass method


Recommended Posts

I'm trying to complete the installation of Armbian onto the HC4 (HC4-P if that changes anything).


With a fresh SD card I run


sudo dd if=Armbian_22.11.1_Odroidhc4_bullseye_current_5.19.17.img of=/dev/sdb status=progress


plug in the card to the board, plug in the ethernet cable, hold down the boot switch, and plug it into power. It all seems to run correctly: I can SSH into the board and I complete the initial steps to set-up the installation (root pass, default shell, username, real name, and locale). However it does not seem as I can access the SPI FLASH device. Running the following commands from the HC4 page do not work as there are no mtd devices.


root@odroidhc4:~# ls -ltr /dev/mtd*
ls: cannot access '/dev/mtd*': No such file or directory


Here's a paste of the files available under /dev: https://paste.tildeverse.org/?aa94ecb514ce9e50#E5qD2kbTFiQzaHRrgnBLfMw8PMfspfVsCFrxhPATYDyi

Link to comment
Share on other sites

1 hour ago, savoy said:

Running the following commands from the HC4 page do not work as there are no mtd devices.

It seems that support for SPI got lost when upgrading kernel. Nothing unusual for software where maintaining is sponsored by its developers in their free time.


Workaround (thank you) - previous 5.10.y kernel images from archive works well ... use it and don't upgrade (apt-mark hold linux-image* and linux-dtb*)

Link to comment
Share on other sites

I received my new Odroid HC4 today and ran into the same problem. I used the recent armbian, but I booted into petitboot (with an attached display and keyboard), and erased the flash storage from there. This worked just fine! As far as I can tell, this has no downside when compared disabling petitboot via ssh, other than having to have a display and a keyboard.


@Igor: Thank you for providing armbian!!!

Link to comment
Share on other sites

Hi all,


i also encountered a problem getting rid of pertitboot. The button variant also works to boot into the armbian linux, but the mtd-devices are also not visible.

Therefore, I tried the petitboot variant with connected monitor and keyboard, but there is nothing showing up on the screen after applying power.


Fortunately, I had the official USB-serial-cable from ODROID available and could plug in it easily after opening the HC4 case. On the serial console (115200,8N1) I could execute the flash_eraseall commands. This took a few minutes especially for the /dev/mtd3.


After erasing them, the board booted seamlessly into armbian.




Link to comment
Share on other sites

I just set up my new HC-4 with Armbian 23.02.2 Bullseye following the instructions at https://www.armbian.com/odroid-hc4/

Unfortunately, I have exactly the same problem as themole.


On the installed kernel 6.1.11-meson64, I don't see the mtd-devices.

I downgraded to 5.10.16-meson64. Still no mtd-devices.


I started the HC-4 without pressing the button, in the hope to apply the method "Petitboot Console Method" from the instructions. But then, nothing happens. The screen stays dark.


Unlike themole, I don't have the USB-serial-cable around that I could use. So please, could you give me a hint how I can get rid of petitboot. Is there a specific kernel version I should boot? Or a specific image for the SD-card that I should use?


Here is the output of armbianmonitor -u (on 6.1.11-meson64 kernel):


Edited by eacton
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines