Jump to content
  • 0

ZFS to old (2.1.4) in Armbian_22.11.1_Odroidhc4_jammy_current_5.19.17


ChrisO
 Share

Question

The zfs-dkms included in Armbian_22.11.1_Odroidhc4_jammy in version 2.1.4 is to old for 5.19.17 kernel.

It should be 2.1.6 like in Armbian_22.08.7.

 

Loading new zfs-2.1.4 DKMS files...
Building for 5.19.17-meson64
Building initial module for 5.19.17-meson64
configure: error: 
    *** None of the expected "blk_queue_discard" interfaces were detected.
    *** This may be because your kernel version is newer than what is
    *** supported, or you are using a patched custom kernel with
    *** incompatible modifications.
    ***
    *** ZFS Version: zfs-2.1.4-0ubuntu0.1
    *** Compatible Kernels: 3.10 - 5.17
 

http://paste.debian.net/1267188/
 

Link to comment
Share on other sites

4 answers to this question

Recommended Posts

Search Before Posting!

  • 0

require zfs as well.

bulsseye minimal pulls even older zfs

 

Building for 5.19.17-meson64
Building initial module for 5.19.17-meson64
configure: error:
    *** None of the expected "PDE_DATA" interfaces were detected.
    *** This may be because your kernel version is newer than what is
    *** supported, or you are using a patched custom kernel with
    *** incompatible modifications.
    ***
    *** ZFS Version: zfs-2.0.3-9
    *** Compatible Kernels: 3.10 - 5.10

 

Therefore on yammy route then still same error

 

Loading new zfs-2.1.4 DKMS files...
Building for 5.19.17-meson64
Building initial module for 5.19.17-meson64
configure: error:
    *** None of the expected "blk_queue_discard" interfaces were detected.
    *** This may be because your kernel version is newer than what is
    *** supported, or you are using a patched custom kernel with
    *** incompatible modifications.
    ***
    *** ZFS Version: zfs-2.1.4-0ubuntu0.1
    *** Compatible Kernels: 3.10 - 5.17

 

What does

Quote

Update has been initiated. 24 - 48h until it shows up in CDN.

Actually mean and how to build zfs 2.16 then ?

Link to comment
Share on other sites

  • 0

Was unable to pull zfs-dkms 2.1.6 being available on cdn https://armbian.hosthatch.com/apt/pool/jammy-utils/z/zfs-linux/

After armbian-config and apt reconfigure mirrors and apt update && apt upgrade i could pull the zfs 2.1.6 goods (dkms and zfs-utils)

 

These values are and where fine

cat /etc/apt/sources.list
deb http://ports.ubuntu.com/ jammy main restricted universe multiverse
#deb-src http://ports.ubuntu.com/ jammy main restricted universe multiverse

deb http://ports.ubuntu.com/ jammy-security main restricted universe multiverse
#deb-src http://ports.ubuntu.com/ jammy-security main restricted universe multiverse

deb http://ports.ubuntu.com/ jammy-updates main restricted universe multiverse
#deb-src http://ports.ubuntu.com/ jammy-updates main restricted universe multiverse

deb http://ports.ubuntu.com/ jammy-backports main restricted universe multiverse
#deb-src http://ports.ubuntu.com/ jammy-backports main restricted universe multiverse

 

cat /etc/apt/sources.list.d/armbian.list
deb http://apt.armbian.com jammy main jammy-utils jammy-desktop

 

Not sure why apt reconfigure mirrors solved this.. but never the less, happy eyes with the zfs goods to play with.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...