Jump to content

CSC Armbian for RK322x TV box boards


Recommended Posts

@SteeMan hi. 

I installed the headers and tried to compile the driver but it gives an error. Looking for a second driver repository? I am new to linux so forgive me if my questions are very simple.



i change arm7l to arm and have this:


i run make oldconfig && make prepare


Edited by Andr1k
Link to comment
Share on other sites



If I understand correctly the rtl8188 driver is compatible with your rtl8189, so you may try this



Compile and install with (the script expects this way)



I am running in my unit with success

Link to comment
Share on other sites

 @BLFC i fix problem. Reinstall linux-headers.

My solution:

sudo apt update 
sudo apt upgrade
sudo apt install linux-headers-current-rockchip
sudo apt install git
sudo git clone https://github.com/jwrdegoede/rtl8189ES_linux/
cd rtl81*
sudo make ARCH=arm KSRC=/lib/modules/$(uname -r)/build CONFIG_POWER_SAVING=n
sudo cp 8189es.ko /usr/lib/modules/$(uname -r)/kernel/drivers/net/wireless/realtek/
sudo depmod -a
sudo modprobe 8189es

Thx for helping. Have a good day!

Edited by Andr1k
Link to comment
Share on other sites

On 6/24/2023 at 11:15 AM, mydeardiary said:

No hdmi output with hdmi-to-usb device. Didn't test other hdmi devices.

Overlays applied: emmc, led-conf2. Leds are working, with blue led shining when the device boots with Armbian.


Update: this box is now running Linux 6.6.17-current-rockchip


Dtb applied: overlays=emmc led-conf7


The cpu speed is now capped at 1 GHz with better stability and hdmi output works (via usb to hdmi viewed on another laptop using ffplay). Excelent.


Installed sway and lima gpu is being utilized. But before I can access the lima gpu, I have to add my login to render group.


`sudo usermod -a -G render $LOGNAME`


Well done!

Link to comment
Share on other sites

mxq pro rt3229 sv6256p wifi


Hi there all, have a nice day/evening.


Because I am not such a advanced digital person I do ask you guys what I has to do

with multitool who get,s stuck on license massage open source etc, it will not go further

and bleu led blinks. I have the box in maskrom mode, maybe that is the issue and need

to switch it back.


Want use multitool te get tv kodi on internal, I have eMc no nand. I want to use it for

movies, I also be busy building a dac with tube outputs for drive the hybride amp

I did designing years ago.


Here included the log.


THis message is coming from linux, had a worm in firefox no one antivirus did detect.

even not malwarebytes.


I am suprised how well linux do, but needs to get more suitable for people like easy install

and using windows software. I rub from a usb stick now, need that for the file system and

copy things, experiment.


Oke I go offtopic, can someone look at it, I can run libreelec kodi normally, but have a strange

usb adapter for sd cards, do see two sd cards in windows.


I have now also a usb to serial adapter, so I can use putty for example to log in. did read

can be used fo internal install, but adres is maybe a guess. How smart are these chinese boxes.


Thanks for help.







Edited by SteeMan
moved to correct location
Link to comment
Share on other sites

  • SteeMan changed the title to CSC Armbian for RK322x TV box boards
  • SteeMan pinned this topic
1 hour ago, audio kees said:

Because I am not such a advanced digital person I do ask you guys what I has to do

with multitool who get,s stuck on license massage open source etc, it will not go further

and bleu led blinks. I have the box in maskrom mode, maybe that is the issue and need

to switch it back.

Hello; I'm not exactly sure I understand... you say you're stuck at the license disclaimer but you managed to get a dmesg log?

Link to comment
Share on other sites

Yes, I have also check, the log is present only after use the sd once.


it stuck by license disclaimer and and see 17% but first it does someting

like partition resise or semething like that what go very quick, just some

seconds and go to license disclaimer.


I can start a libreelec for example just fine, but after a restart things are mess up, and need

repairs,  wait 120 seconds, and just start and work. I need to install this on the internal.


I do not now if ssh is possible for this.


Here it stuck, I go start now again, and let it for some hours, I need to go somewhere, and see what

is happened when I am back.



Edited by audio kees
Link to comment
Share on other sites

vor 12 Minuten schrieb audio kees:

do not now if ssh is possible for this.

yes when LAN port work for you and the box get a ip adress its now possible to ssh


do you have a usb cale keyboard attached to the tv box , you have to hit enter/space to except the license

( some wired and some wireless keyboard dont work under linux because they need some usb driver but that rare )


Edited by RaptorSDS
Link to comment
Share on other sites

Ahhhh I shame myself, I did not now I have to push a key.


A keyboard, I have a normal pc keyboard, do these work?


I can get a little keybord for action, that one is wireless, the mouse I have from them did work

on the librelec one.




Do not work with usb pc keybaord or usb mouse. So need a special keybord for this? I think the

keybord I have is a type that needs driver because this sweet one has alot of tweaks and bells.


Thank you guys for this tip.



Edited by audio kees
Link to comment
Share on other sites

Hi Fabio



I have buy a new keyboard, simple and this do work fine..

Feel me so stupid to not think about this, maybe the age of 67 do work here.


I did zip the system img and multitool did install on eMc.


But it does not boot from it, so I think that have to learn some more. I did read

to use only img, not the compressed one, but zip it and put on sd do work fine

multitool can unzip if fine.


Reading ahead will work. so I can get it bootable also, and edit in the files, need

maybe putty for that.



thanks all.



Link to comment
Share on other sites

@audio kees
don't blame on age , 61 here ...lololol

anyway the system is booting from sd ..and it will work from internal emmc , too !!

just grab the gz one from the server and do all again, first erase the emmc and then burn in internal storage
did you remember, or can you test by inserting again the multitool SD , how the internal storage was identified ? usuallycould be mmc2 or something like that

Link to comment
Share on other sites

Mine was mmc2, did install arbian first, take a while, but did not boot. I did read totry that.

but I a  noob with linux, never use that, but try yesterday, I am suprised how well this works

windows like, but much more save,


I have backup the system on emmc first, you never now.


Now I can not boot again, the SD card in the usb reader does strange, I get two multitool

F:\ drives whoith bow the same files.  that is not possible.


Now I have downloaded a sd card formatter, seems good for this cards. I did work in windows.

did format it, but still I get two cards, I can write to both of them, but ends in one, what strange.


Go try in linux.


I need a reader who do better, I have more, all where bad chinese stuff.





ScreenHunter 53.jpg

Link to comment
Share on other sites



The partions are oke, I just see two cards in windows both has F, with files on them, 

I have a double multitool SD but it is not. the cardreader does make this trouble because

it needs to use not same drive letters.


I go start in lunix through a usb stick and see what happens there.


THanks for response.





Edited by audio kees
Link to comment
Share on other sites

Hi all



I have proberly brick mine mxq pro rt2329 box.


It has a eMc with balls solder so I can not find the clock pin, I can measure with the scope to find

it as there is a outside pin, this clock is synced with something I presume.


I have the kingston type of memory, with solder balls on the chip itself, so is more difficult, or even

impossible, the pcb is then unusable.


It did was in maskrom mode but something is happen. unexperience from me is possible.







Link to comment
Share on other sites

HI @audio kees


first of all do you have also Ram chips at underside of the board , else i would say that you have a eMCP ( emmc + ram combination) , eMCP are now possible with multitool and armbian but sometimes instable outside android


for the brick , you dont need the clock under the chip , also possible to GND the clock at a resistor or test point , sometimes also at the pad for NAND  on right side of your picture is possible

but self with brick memory a boot from SD-Card or USB should always possible

Link to comment
Share on other sites

Can you making one hi rec photo of both sides of the PCB its likely have pads for MASKROM but you can using the pads for MMC / NAND but need looking for the pining of then for getting the right one.

Also if being in MASKROM it shall booting DC-card with bootloader on it.

Then having (updated not factory Android) bootloader on the EMMC it shall also booting USB-flach sticks without problem.

Link to comment
Share on other sites

@audio kees I definetly agree with @RaptorSDS

on the right side you have pins for a nand that isn't soldered .you can spot ecmp clock even there. usually pin 6 or 7 starting from the dot, but check with oscilloscope

or try to boot pressing the little switch just at the end of eraphones hole at while still pressing it plug power.
also try to find uart

Link to comment
Share on other sites

Hi All




Thanks for the help.


I am now searching for the clock, but mine scope is max 100 Mhz so maybe it do not see or just noise.

The pins you mention 6 and 7 just has voltage on it, no clock signal.


The idea of the use of the empty nand place I did also has idea of, because these boards are made for mucho 

chips so yes it can be there. Mine board has a eMc/ram indeed. I can reball a new one if fake or a bad one.


On the back of the board is no pads, there some below the rt3229 cpu.


Are there more pins to short on emmc on free space on board, can I go with other menas to get into the system,

ssh or so.






Link to comment
Share on other sites

vor 11 Minuten schrieb audio kees:

Maybe this link is interesting. I can desolder the memory chip, make a connection

to clock and resolder it, (balling) I have the materials for that like solderstation and


but thats tooo much


too much thermal stress for chip and so on ....


also the maskrom mode is more to get into SD/USB boot when you have a close bootloader or when you need to flash from pc , there you short that pin shortly only to say cpu internal loader use alternate drive , you have to release the short direct after boot to use the emmc and format it


please look if you can boot still from usb/sd card , please dont use usb sdcard reader only direkt sd card



Link to comment
Share on other sites

2 hours ago, audio kees said:

Maybe this link is interesting. I can desolder the memory chip, make a connection

to clock and resolder it, (balling) I have the materials for that like solderstation and


For God's sake, don't!

You just need to find the eMMC clock pin, gate it to ground when turning on the board and then restore the normal condition right after the board has power. You don't need to do such an invasive procedure!


You said you have an oscilloscope, so then it would be a joke finding the clock pin. AFAIK, the eMMC default clock is 400khz.

More informations are in the first page of this thread, including how to find the clock pin on the NAND/eMMC pads.


I also wonder how did you brick the board. As @fabiobassasuggested, you can also try powering up the board keeping the reset button behind the audio jack pushed for 4/5 seconds and see if you get in maskrom mode.

Link to comment
Share on other sites

Hi Jock


I do not remove that chip. But can I have tools,  and masks. I did reball some phillips cpus of the tv whp did desolder themselfs.


Your tip to push the button in the audio jack do not work anymore, it did fine when try to install arbian or libreelec, it was on

maskmode, I just did wipe out the flash in devtools and it jumps automatically in maskrom. I have to say I had see on multitool

the 1T or 2T, I can maybe change that because it did push on that, but cancel it, is this a reason to not work? 2T is not that bad

1T is more a overclock? sorry but need to learn some about this. I do understand 1T or 2t clock pulse to memory settings.


I am electronicus and design also, so I do now what I am doing.


The board did nice and suddenly died. I have now measure with the scope, I have a single chip memory combination as I 

some mention, here, it is a kingston  08emcp08 el3bt227 who is ball soldered, so clock pin is not reachable but can measure 

on the through hole points.


The frquency is not 400 Khz  was this a type error? the chip works on Mhz frequencion, but that is dynamic, so maybe when bricket

it is low.


The signal is this a clock pulse type? because I measure also more of them.


Oke I go measure  further, is the pcb really broken I remove the chip and measure the clockpin where it go, but first try to blow

live again in it.


Today I did get a new box, who is 64 bit, because the box I have is only 32 bit. box is H96 max rockchip 3318. unfortanely no

digital out so I did not look well enough. oke maybe this box with linux is a very good security camera mini pc.

Link to comment
Share on other sites

@audio kees the eMMC when the board is turned on is 400 KHz (no typo), then when it gets initialized (immediately, in practice) runs at 50 MHz.


The best thing you can do right now is find the TX/RX pins of the debug uart, attach an USB to TTL serial adapter and see what the board is saying during boot and understand why the board is bricked posting here the logs. Bitrate is 115000bps.


About 1T or 2T, it is the DDR Command Rate parameter. If you don't change that, current images have it set to 2T which is more compatible, but some board still don't like it and want 1T. That's exactly the reason I strongly suggest (in the first page tutorials) to first try and boot armbian from sdcard before installing it in eMCP/eMMC.




Link to comment
Share on other sites

Hi jock



I have managed find the clock, but it did not give a good clear signal on the scope, more rubbish, I think a digital

analyzer is needed for clear signal reading.


Oke I had found that pin, and was 7 on the open emmc place where no chip is, so people here has the right guess, 

and I was the lucky one.


I have solder a wire on that pin, a very supple one and gleu it there because these boards are very very tiny traces and

quickly damaged, also poor made boards. But oke, these are also cheap.


I have now download a android in it because otherwise  it brick again. so start from the begin. THat wire soldered on it

will do make mine live a lot more easy. the android did start again, so I go on with armbian, nu I need a suitable image 

for testing, I have a libreelec image who do install fine on sd and do work, also the remote control, but I was trying set

it on the inside flash what did not boot then.


By the way I have tryed to measure if that clock pin did go somewhere, it didnt, it is only from the inside oscilator on

kingston or the samsung emc chips. I am lucky I guess that the board is prepared for all kind of chips, making it more

complicated also and not so good because of long traces and such making system unstable.  So it is not always the

cpu memory the armbian software but just the pcb, that is why runnig 1T did work better sometimes.


thanks for help all.






Edited by audio kees
Link to comment
Share on other sites

Some update.



I have clear again the device so wipe android.


Now I can just with dvtools switch to maskrom or normal loader.


and after dicsconnect it, it stays in maskrom, so it works again as it did

on first hand. What is happened I do not now, but me as agreen behind

the ears linux user, it keeps me busy with all that free time now I have

pension age.

ScreenHunter 49.jpg

Link to comment
Share on other sites




The reason of brick the box was libreelec image, I did it again.


Now installed armbian 23 bookworm and this just boot fine from emmc.


question now is how to get a media system on it, libreelec kodi is such one,

and I read that multitool is used for that, but brick the box everytime

is always install the adroid before we can go on because boot is damaged.


Oke we are done, the wire is soldered and I can go maskrom at will for experimenting.


thanks all.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines