Jump to content

Armbian 24.2 is broken on Orange PI PC2


Recommended Posts

Armbian 24.2 is broken on Orange PI PC2 (Debian Bookworm CLI)


Latest stable community release:



With update 23.11 -> 24.2 the orange pi pc2 no longer starts.

I tried a new sd installation and it too does not appear on the network. Right now I don't have a serial cable to check but it is possible that the network driver is missing or not working.


SD, SBC and PSU are 100% working: a revert to 23.11.2 makes it work perfectly.


Edited by Moklev
Link to comment
Share on other sites

  • Moklev changed the title to Armbian 24.2 is broken on Orange PI PC2

same issue after upgrading to latest kernel (not sure if is the 6.6.20, but most probably is)


no time to debug now, but the fresh installation stuck after

Started systemd-udevd.service


guess is a kernel issue 



i can confirm my installation was broken after installing kernel 6.6.16 

reverted to 6.1.77-legacy-sunxi64 and im back

Edited by Giulio Cervera
Link to comment
Share on other sites



I am new here, so I do not know if I am using the correct topic.

I tried to upgrade my orange pi pc2 following the steps above, but no success. The devices tries to boot, but does not get any IP address and no HDMI output. The yellow led of the ethernet port blinks with a constant frequency (ca every 2 secs) and the device does not go any further.

I tried installation from the scratch, with the same result, using Rufus and balenaEtcher-Portable-1.18.11 and the following images:



Then I tried installing again Armbian_23.02.1_Orangepipc2_bullseye_current_5.15.93.img, using Rufus, without any problems. The device booted and I could log in.

The problem is, my network infrastructure relies on 3 (and 1/2) different orange pi devices, so I am afraid, the upgrade could crash my network structure.

Last try: jammy desktop (see boot.log and bootstrap.log)


Any idea what I am doing wrong?





jammy-boot.log jammy-bootstrap.log

Link to comment
Share on other sites

@718aba Install the 23.11.2 on sd and block the kernel update in armbian-config, as recommended by Giulio. Configure everything and then make a full compressed backup of the whole SD with usbimager (gitlab).

Link to comment
Share on other sites

No, it's not 🙂
If you need something stable and safe, don't waste money on these crappy chinese sbc.

Buy a LP Intel like a Dell Wise 5070 on ebay (~80/90€ with a Celeron J, 4/8GB RAM and a SSD) and install Debian o CentOS. is rock-solid and requires only 5/8 Watt.

Link to comment
Share on other sites

Thanks, @Moklev, you are right. I am already replacing my orangepi intranet nodes (piece by piece) with raspberry, using the orangepis mainly for entertainment or fall-back purposes.

And I will follow your advise and look for a thin client to run my NAS and a reliable backup server.

Anyway, I need to upgrade all.


Link to comment
Share on other sites

Pardon me for asking here. I need to re-install OPi PC 2 -which I use as a firewall/router- because the old Ubuntu from 2020 is EOL.


- Is the kernel problem stated here still an issue? Latest DL is Armbian_community_24.5.0-trunk.667_Orangepipc2_jammy_current_6.6.31_gnome_desktop.img.xz

- I also have Armbian_23.8.1_Orangepipc2_jammy_current_6.1.47_xfce_desktop.img.xz from the archives.


Which one is to go? When I start, I'll probably lose my Internet connection...


Link to comment
Share on other sites

3 hours ago, Moklev said:

Yes, still broken

It is community maintained. You are a community member. Feel free to go ahead and fix whatever the issue is ¯\_(ツ)_/¯

If there even is an issue since nobody managed to provide full proper debug logs.


Anyway I'd start at the place you suggested and check the code. Maybe there is an (easy) fix that could be ported. This is how open source works.


3 hours ago, Moklev said:

after six months, it's almost a record XD

Not really. There are issues existing way longer but we neither have enough funding nor enough man power to deal with all of them :( That's the reason why we have to give back support for certain boards into community hands to get some weight off of our shoulders.

Link to comment
Share on other sites

Posted (edited)

In my case, I have 10+ of OPi boards in the drawer, which I wanted to put to some good use. I started with the single one in use.


I said "23.8.1" worked, but with a single apt update/upgrade it gets stuck on boot. I spent a day debugging the issue to no avail, so I put that away.

I'm with no firewall and PiHole now, ads really suck. I'll revisit the issue when my current project is over. ... or just put an RPi 3 there...


@Moklev, thank you for the pointers.


I wonder: If the kernel is broken, why does the community create new image versions?


Edited by bozden
Link to comment
Share on other sites

Posted (edited)
23 минуты назад, bozden сказал:

No, I just had that impression, it might be the toolset, settings etc.

Try to make a "knight move".

Boot from the old image that works for you.
Download and install the kernel and dtb packages using the dpkg -i command.


P.S. In fact, this is harmful advice. Try it if there's nothing else left.

Edited by going
Add P.S.
Link to comment
Share on other sites

Posted (edited)

trying to find a working linux image, i have just installed Lakka and it is running kernel 6.6.30 (maybe the armbian issue is not completly kernel related?) ... but i have no network :( 

still searching a working image ...



just found older image:


Edited by Giulio Cervera
Link to comment
Share on other sites

02.06.2024 в 10:34, Giulio Cervera сказал:

... but i have no network :( 

still searching a working image ...

All Armbian images require the user to have an internet connection.
Before the first start, your device must be connected to the router using a cable and the router must distribute IP addresses via DHCP.

Almost all devices do not have a watch with a battery. Therefore, after the kernel boot stage, the OS service tries to configure the system clock by sending a request to the NTP server. If there is no response, then the system waits for it and kind of stops. The user sees a blank screen.


31.05.2024 в 21:44, NoSpam сказал:

Here is a serial log from the Bookworm 6.6.31 minimal release.  Verbosity=7 this time.



This line says that the system turned out to be in the past.

[    6.026051] systemd[1]: System time before build time, advancing clock.

At the same time, it cannot properly process the file system that is in the future.



Possible solutions to the problem:

1) Purchase a watch with a battery and connect it to the 40 pin connector.

Add a dtbo overlay file for this type of watch. Set the system clock to the current time.


2) Connect the device to a local network in which there is another device with a watch with a battery.

Configure and run an NTP server on this device.


On a device without a watch, specify the NTP address on the local network.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines