• Announcements

    • 1. Check power supply, check SD card and check other people experiences

      Power supply issues are one of the three biggest issues you'll face when starting with Single Board Computers (SBCs). SD card issues, whether fake or faulty, are another and issues resulting from poor board design is the other common issues you can encounter.   Power supply issues can be tricky. You might have a noisy power supply that works with one board because it has extra filtering, but won't work with another. Or you're using that cheap phone charger because your board has a microUSB connector, and it is either erratic, or doesn't start up, or even becomes the cause of some SD card issues.    Some tips to avoid the most common causes of problems reported:   Don't power via micro USB  - unless you have optimised your setup for low power requirements. Micro USB is great for mobile phones because they are simply charging a battery. It's bad for SBCs. Yes, it does work for a lot of people, but it also causes more problems and headaches over time than it is worth, unless you know exactly what you are doing. If you have a barrel jack power connector on your SBC, use it instead! If there is an option for powering via header connections, use that option!
        Don't use mobile phone chargers. They might be convenient and cheap, but this is because they are meant for charging phones, not powering your SBC which has particular power requirements.
        When you are evaluating a power supply, make sure you run some stress tests on your system to ensure that it will not cause issues down the path.   (Micro) SD card issues can be sneaky. They might appear right at the start causing strange boot and login errors, or they might cause problems over time. It is best to run a test on any new SD card you use, to ensure that it really is what it is, and to ensure that isn't faulty. Armbian provides you a simple way to do this   --   armbianmonitor -c /path/to/device/to/test  
    • 2. Make sure to collect and provide all necessary information

      We can only help if you provide quality information for us to work with. All stable images from the download section are tested, most stable upgrades are tested and we have tens of thousands of users. Even with regular and extensive testings, bugs sometimes do slip through. This is a voluntary support service and is unrelated to board makers, and is not obligated to provide you any answers. Repeated asking the same questions because you're not happy with the answers will result in you being ignored.

      Before you post a question, use the forum search as someone else might have already had the same problem and resolved it. And make sure you've read the Armbian documentation. If you still haven't found an answer, make sure you include the following in your post:   1. Logs when you can boot the board: armbianmonitor -u (paste URL to your forum post)   2. If your board does not boot, provide a log from serial console or at least make a picture, where it stops.   3. Describe the problem the best you can and provide all necessary info that we can reproduce the problem. We are not clairvoyant or mind readers. Please describe your setup as best as possible so we know what your operating environment is like.     We will not help in cases you are not using stable official Armbian builds, you have a problem with 3rd party hardware or reported problem would not be able to reproduced.

hostapd on orange pi light realtek driver
2 2

21 posts in this topic

Recommended Posts


Sorry my english and my ignorance in linux


I'm trying to activate hostapd on orange pi light.

I think realtek driver.


Nework appairs, but i cannot associate, it says wrong password (12345678)


iwconfig has not password item:


lo        no wireless extensions.

br0       no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:"ARMBIAN"  Nickname:"<WIFI@REALTEK>"
          Mode:Master  Frequency:2.432 GHz  Access Point: 2E:98:51:56:D5:65   
          Bit Rate:72.2 Mb/s   Sensitivity:0/0  
          Retry:off   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=1/100  Signal level=6/100  Noise level=0/100
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

enx00e04c3603a7  no wireless extensions.


Onnline documentation talks about realtek




Default binary and configuration location:


Realtek binary and configuration location:



I do not have these files -rt

How can I do ? And how are they used?

Share this post

Link to post
Share on other sites


I have same problem with PC+ with  Armbian5.25 Ubuntu xenial 3.4.113 and even i downgrade hostapd to 2.1 and still it doesn't accept password and I can't connect with PC and mobile    .

Share this post

Link to post
Share on other sites

In bridge mode you need a dhcp running on network. That's all. I also solve problems in NAT mode so both are (will be) working.

Wrote on mobile

Share this post

Link to post
Share on other sites

I have a orange pi light, with usb ethernet adapter, connecter on my network with dhcp.
ping google work, but my smartphone cannot associate to wifi networc created, it show password error.

Share this post

Link to post
Share on other sites

If the error I get from the phone is "wrong password", there is nothing to do with DHCP.

I also tried to assign the static ip at the phone but it does not change anything.

Share this post

Link to post
Share on other sites

What OS is the phone? Android? Windows? ios? I know for  fact the image posted above works as it should on the PC Plus, I have it running right here.


My Android phone  / tablet works fine, my 10 windows box does not connect (well "connects" but authentication fails) , but it is flaky about wpa some times.


Share this post

Link to post
Share on other sites

I received Orange Pi Zero

Loaded its own firmware.  Armbian_5.30_Orangepizero_Ubuntu_xenial_default_3.4.113

When I launch armbian-config, and i enable hotspot WiFi, I receive tis error message:

Wireless adapter: wlan0

No compatible hostapd driver found.

Share this post

Link to post
Share on other sites

Yes, it looks armbian-config is not completely resilient to other changes ... it used to work but now it doesn't anymore. 

Now you have to proceed manual way. temporally workaround:


apt install hostapd
cd /etc/network
ln -sf interfaces.hostapd interfaces
systemctl disable network-manager
sed -i "s/^DAEMON_CONF=.*/DAEMON_CONF=\/etc\/hostapd.conf/" /etc/init.d/hostapd 

You will see: ARMBIAN / 12345678 ... Configure /etc/hostapd.conf


Edit: it looks like this problem is affected only to Orange Pi Zero.

Piv Klit likes this

Share this post

Link to post
Share on other sites
Ok, work.
But i Need Two class of ip, one on eth0 and one on wlan0
On eth0 on DCP, on wlan on static ip.
I don't have necessity that the wifi go on internet, it doesn't serve me of it bridge, of it nat.
Me enough that the CPU reaches internet and the objects in the wifi
I have written so, but I have lost the board, it doesn't take ip from the DHCP anymore server.

auto eth0
iface eth0 inet dhcp

auto wlan0
iface wlan0 inet static


Share this post

Link to post
Share on other sites

A easy way to set a lan and wlan ip's on 2 different networks can be done with armbian / openwrt. ..OK so I am fat and lazy....

I have not run the last version but the older ver works very well.



not sure what you are after, but it is easy to setup and test / AP mode / client mode / AD-Hoc mode

I have logs of Iperf3 between a ver 1.1 and ver 1.4 going both ways ...with both as AP and both as client if you want to some numbers.

@30 feet with two walls, on a some what clear channel.

Edited by Bubba

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

2 2

  • Support the project

    We need your help to stay focused on the project.

    Choose the amount and currency you would like to donate in below.