Can you install Armbian to NanoPi Neo Core eMMC?


Recommended Posts

Hi.

 

I have received my new Neo Core and would like to flash my image to eMMC.

I tried nand-sata-install but it says there is no target.

On the Friendly Arm site they have a utility called eflasher, but I think this does not support Armbian.

 

Is there a way to do it or a guide that I have missed?

 

Thanks.

J.

Link to post
Share on other sites
Armbian is a community driven open source project. Do you like to contribute your code?

1 hour ago, Johhny Blue said:

I have received my new Neo Core and would like to flash my image to eMMC

 

Which image? Did you realize that Armbian currently neither supports Core nor Core2?

 

If you use an image with eMMC support (eg. those for NEO Air) it should just work, if you use any image without eMMC support (eg. those for NanoPi NEO) it can't work.

Link to post
Share on other sites
2 hours ago, mondalex said:

Will Nanopi Neo armbian image work with Nanopi Neo Core?


To some degree, it should. None of us has this board yet so we can't be 100% sure, but if it doesn't ... it can be quickly adjusted. I would suggest trying Nanopi Air image instead.

Link to post
Share on other sites
18 minutes ago, Igor said:

I would suggest trying Nanopi Air image instead.

NanoPi Air for the Neo Core.... any suggestion for the Neo Core2?

My first idea would be a NanoPi Neo2 image... because Friendly did wrote in their Wiki

Quote

The NanoPi NEO Core2 as its name tells is an alternative NanoPi NEO2 that works like a CPU board with male pin-headers. It has the same form facotor as the NanoPi NEO2, same pin descriptions and works with all the OS images the NanoPi NEO2 supports. 

But the Neo2 hasnt eMMC....maybe this is add-able as an option in the Neo2 image for the future?

I could test such an option if I do receive my Core2 in near future ;)

Link to post
Share on other sites
On 03/01/2018 at 11:49 AM, Igor said:


To some degree, it should. None of us has this board yet so we can't be 100% sure, but if it doesn't ... it can be quickly adjusted. I would suggest trying Nanopi Air image instead.

I'm actually going to use the one without eMMC. Won't be the Nanopi Neo image be more suitable then?

Link to post
Share on other sites
On 3.1.2018 at 10:50 AM, Igor said:

Neo Plus2 has enabled eMMC in u-boot config ... so rather that one.

@Igor as information: today I did receive my NanoPi Neo Core2 and it didnt boot the image for the Neo Plus2 :( 
but it did boot the NanoPi Neo2 image:
root@nanopi-core2:~# armbianmonitor -u
System diagnosis information will now be uploaded to http://ix.io/DJn
So - do you see a chance to enable eMMC on the Neo2 image?

Link to post
Share on other sites
On 6.1.2018 at 6:46 PM, guidol said:

@Igor as information: today I did receive my NanoPi Neo Core2 and it didnt boot the image for the Neo Plus2 :( 
but it did boot the NanoPi Neo2 image
So - do you see a chance to enable eMMC on the Neo2 image?

@Igor I dont know why the Neo Plus2 image didnt boot - for me - at the 06.01.2018 on the Neo Core2, but today I did give it another try with the actual nightly Armbian_5.38.180128_Nanopineoplus2_Debian_stretch_next_4.14.15
and now it does boot and do see the eMMC of the Core2 :)

Actual I do boot from uSD-Card and do get:

root@nanopi-core2:~# ls /dev/mmc*
/dev/mmcblk0  /dev/mmcblk0p1  /dev/mmcblk2  /dev/mmcblk2boot0  /dev/mmcblk2boot1  /dev/mmcblk2p1  /dev/mmcblk2p2

root@nanopi-core2:~# mount
/dev/mmcblk0p1 on / type ext4 (rw,noatime,nodiratime,errors=remount-ro,commit=600)
/dev/mmcblk0p1 on /var/log.hdd type ext4 (rw,noatime,nodiratime,errors=remount-ro,commit=600)

/dev/sda seems to be the missing PCI-E SSD (here in dmesg):
[    2.826327] sd 0:0:0:0: [sda] Read Capacity(16) failed: Result: hostbyte=0x00 driverbyte=0x08
[    2.832655] sd 0:0:0:0: [sda] Read Capacity(10) failed: Result: hostbyte=0x00 driverbyte=0x08

 

Link to post
Share on other sites

Those boards are more or less identical. I forgot to mention FA to send me one of those. I guess we could simply change a name on download page https://www.armbian.com/nanopi-neo-2/  -> Nano pi Neo2 / Core

 

What do you think? 

And there are testing images out - well, they should be now the same. https://dl.armbian.com/nanopineo2/archive/

 

43 minutes ago, guidol said:

/dev/sda seems to be the missing PCI-E SSD (here in dmesg):


Have you enable all USB ports in armbian-config? I assume you have some SSD there?

Link to post
Share on other sites
53 minutes ago, Igor said:

Those boards are more or less identical. I forgot to mention FA to send me one of those. I guess we could simply change a name on download page https://www.armbian.com/nanopi-neo-2/  -> Nano pi Neo2 / Core

What do you think? 
And there are testing images out - well, they should be now the same. https://dl.armbian.com/nanopineo2/archive/


Have you enable all USB ports in armbian-config? I assume you have some SSD there?

I dont think you could name it Nano pi Neo2 / Core, but you could name

Nano Pi Neo Air     -> Nano Pi Neo Core/Air (H3)

Nano Pi Neo Plus2 -> Nano Pi Neo Core2/Plus2 (H5)

because

Nano Pi Neo Core   is a Nano Pi Neo  (H3)  with eMMC = like a NanoPi Neo Air without BT/WiFi  and

Nano Pi Neo Core2 is a Nano Pi Neo2 (H5) with eMMC = like a NanoPi Neo Plus2 without BT/WiFi

 

Nano Pi Neo (H3) (without extension) and Neo2 (H5) (without extension) are without eMMC/BT/WiFi

 

PS: I didnt got a SSD on the Core2 - so armbian could read the size - I think

Link to post
Share on other sites
57 minutes ago, Igor said:

What do you think?

LED config seems to be a bit differnt to the Neo2 (image)

with the Neo2 image the

    RED Led was useable with echo "mmc0" > /sys/class/leds/nanopi\:green\:pwr/trigger    and the

GREEN Led was useable with echo "heartbeat" > /sys/class/leds/nanopi:blue:status/trigger

 

On the Nano Pi Neo Plus2 image only the RED Led does work with

    RED Led was useable with echo "mmc0" > /sys/class/leds/nanopi\:green\:pwr/trigger    BUT

GREEN Led was useable with echo "heartbeat" > /sys/class/leds/nanopi:blue:status/trigger DOESNT WORK

 

ls -l /sys/class/leds show only the 2 LEDs:

root@nanopi-core2:/sys/class/leds# ls -l
total 0
lrwxrwxrwx 1 root root 0 Jan 29 18:03 nanopi:blue:status -> ../../devices/platform/leds/leds/nanopi:blue:status
lrwxrwxrwx 1 root root 0 Jan 29 18:03 nanopi:green:pwr -> ../../devices/platform/leds/leds/nanopi:green:pwr

Link to post
Share on other sites

Hi, all. I have the same question ("Can you install Armbian to NanoPi Neo Core eMMC?") but on legacy kernel. I was able to install Armbian to NanoPi Neo Core eMMC on mainline, following this topic, but cannot find anyone who made it work on legacy.

 

(I really want to use legacy because I need I2S microphones, and was not able to make them work on mainline.)

 

(Another option was to use NanoPi Neo Air legacy image, which supports eMMC out of the box, but I also need Ethernet, which isn't supported by Neo Air!)

Link to post
Share on other sites
Guest
This topic is now closed to further replies.