Jump to content
  • 0

Which method to setup WiFi hotspot on OPiPC?





Got Debian (8) legacy 3.4.113 server/console and would like to setup a WiFi hotspot. (latest Armbian build 5.51)


Seen two methods in Armbian docs

1. -> https://docs.armbian.com/User-Guide_Advanced-Features/#how-to-set-wireless-access-point

and via armbian_config in https://docs.armbian.com/User-Guide_Armbian-Config/

2. -> https://www.youtube.com/watch?v=__BJtInOQFY


So I'm a bit buffled about it.


Got some questions

Got a RTL8188CUS is it suported nowadays? or should I get a specific other one?

Do I need to have internet/ethernet/lan connection active during the hotspot creation via armbian_config?

After I execute the armbian config method, there are a few screens as in the video, probing various methods, and then the system without reporting any error returns to its menu selection but do not show the "Manage..access point".

After that what do I need to do have the WiFi hotspot up?

How can I give it the required parameters eg ip, passphrase key for users to connect, SSID etc, is there any guide for it ?





Also tried with a OPiPCPlus that has onboard wlan and armbian config result is the same, did not give the "Manage .. access point" menu after run. It also not support WiFi access point creation?

Link to comment
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Did a bit of googling


More or less just google setup wifi hotspot on debian since armbian mimics debian/ubuntu architecture nicely ;)


You will need a compatible USB wifi card since the OPiPC doesn't have onboard wifi



here is a PDF...for rasbian...you can skip the OS install since Armbian is for Orange Pi...but the commands and more than likely the interfaces will be the same


To make a hotspot and route traffic from one interface to another is a little bit more intensive than just setting up the interfaces
The above PDF should walk you thru easy enough even if it is written for a specific device...it's pretty universal



Link to comment
Share on other sites

Armbian Linux community supported weekly builds download

  • 0

Thanks @WarHawk_AVG


Unfortunately could not setup a hotspot in OPiPC using the armbian-config.


Tried to use various usb/wifi dongles and with none that I used got any results.


Also, I bought one of the specified in the download page as supported, the Comfast with RTL8811AU chipset.

OPiPC runnning latest 5.51 Debian (8) legacy kernel 3.4.113 simply does not even recognizes it for use as client.

Not creating the wlan0 device at all.

  ___                               ____  _   ____   ____
 / _ \ _ __ __ _ _ __   __ _  ___  |  _ \(_) |  _ \ / ___|    _
| | | | '__/ _` | '_ \ / _` |/ _ \ | |_) | | | |_) | |      _| |_
| |_| | | | (_| | | | | (_| |  __/ |  __/| | |  __/| |___  |_   _|
 \___/|_|  \__,_|_| |_|\__, |\___| |_|   |_| |_|    \____|   |_|

Welcome to ARMBIAN 5.51 user-built Debian GNU/Linux 8 (jessie) 3.4.113-rt143-sun8i
System load:   0.00 0.03 0.05   Up time:       22 min
Memory usage:  16 % of 997MB    IP:  
CPU temp:      51°C
Usage of /:    11% of 15G


[  826.660215] ehci_irq: highspeed device connect
[  826.910179] usb 4-1: new high-speed USB device number 5 using sunxi-ehci
[  827.062370] usb 4-1: New USB device found, idVendor=0bda, idProduct=a811
[  827.062406] usb 4-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  827.062437] usb 4-1: Product: 802.11ac WLAN Adapter
[  827.062460] usb 4-1: Manufacturer: Realtek
[  827.062483] usb 4-1: SerialNumber: 00e04c000001

root@orangepipcplus:~# ifconfig
eth0      Link encap:Ethernet  HWaddr e2:bd:ab:0f:e9:b7
          inet addr:  Bcast:  Mask:
          inet6 addr: 2a02:582:d0e:e00:e0bd:abff:fe0f:e9b7/64 Scope:Global
          inet6 addr: fe80::e0bd:abff:fe0f:e9b7/64 Scope:Link
          RX packets:567 errors:0 dropped:0 overruns:0 frame:0
          TX packets:855 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:45453 (44.3 KiB)  TX bytes:138041 (134.8 KiB)

lo        Link encap:Local Loopback
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)





So, am I missing something? Do I need to do something in order for the device to be identified?

Is the download page with supported/tested interfaces valid ?



Can I use the Comfast RTL8811AU dongle?


Link to comment
Share on other sites

  • 0

Might be able to download the source code and the kernel stuff and build a driver for it




It takes a bit of fiddle futzing...


Googled this


and this




I also wonder if using the nl80211 driver might not work
similar to this https://www.instructables.com/id/The-OrangePi-Lite/ <-remember to keep the ethernet port stuff..don't get rid of that


nl80211 is the new 802.11 netlink interface public header,  I think it's already on built from the stock build, correct Igor?


Link to comment
Share on other sites

This topic is now closed to further replies.

  • Create New...