blinking red led - 2 times then pause


peter12
 Share

1 1

Recommended Posts

Hello, 

I currently installed Opi0 plus2 h3_Debian_stretch_next_4.14.78 but when I boot up my device, red led blinks 2times then pause and repeating again.
What does it mean? 
I have never seen this blinking red led behaviour in previous Armbian releases.

 

 

Link to post
Share on other sites

Donate and support the project!

22 hours ago, peter12 said:

What does it mean? 
I have never seen this blinking red led behaviour in previous Armbian releases.

I have more than 10 differnt devices with armbian running - and this is the normal "Hearbeat" blinking code for a running Operating System.
Maybe they swapped the green for the red led ;)

 

You could check this (maybe with a different LED-name) - here from a NanoPi Neo Core2:
 

more /sys/class/leds/nanopi:red:pwr/trigger

 

none kbd-scrolllock kbd-numlock kbd-capslock kbd-kanalock kbd-shiftlock kbd-altgrlock kbd-ctrllock kbd-altlock kbd
-shiftllock kbd-shiftrlock kbd-ctrlllock kbd-ctrlrlock usbport usb-gadget usb-host mmc0 mmc1 mmc2 [heartbeat] cpu
cpu0 cpu1 cpu2 cpu3 0.2:07:1Gbps 0.2:07:100Mbps 0.2:07:10Mbps
 

You could switch that LED off with:

echo 'none' > /sys/class/leds/nanopi:red:pwr/trigger

 

[none] kbd-scrolllock kbd-numlock kbd-capslock kbd-kanalock kbd-shiftlock kbd-altgrlock kbd-ctrllock kbd-altlock k
bd-shiftllock kbd-shiftrlock kbd-ctrlllock kbd-ctrlrlock usbport usb-gadget usb-host mmc0 mmc1 mmc2 heartbeat cpu
cpu0 cpu1 cpu2 cpu3 0.2:07:1Gbps 0.2:07:100Mbps 0.2:07:10Mbps
 

 

 

Link to post
Share on other sites

7 hours ago, Igor said:

 

That default LED behaviour was changed. Most likely upstream. But board works, right?

yes, it seems board works. 

 

6 hours ago, guidol said:

I have more than 10 differnt devices with armbian running - and this is the normal "Hearbeat" blinking code for a running Operating System.

thank you! I thought it is an error :)

Link to post
Share on other sites

Guest
This topic is now closed to further replies.
 Share

1 1