0
f8n

No sound on nanopc t4

Recommended Posts

Trying to get sound working on my t4.  Looks like pulseaudio detects the realtek rt5651-codec but I can't get any sound out of it.  The software mixer seems to be showing audio, I just can't hear anything

nanopct4 4.4.161-rk3399 SMP

 

aplay-l shoulws realtekrt5651co as device0.

 

Any help debugging this would be great.

 

Regards,

Cam

Share this post


Link to post
Share on other sites
12 hours ago, f8n said:

Trying to get sound working on my t4.  Looks like pulseaudio detects the realtek rt5651-codec but I can't get any sound out of it.  The software mixer seems to be showing audio, I just can't hear anything

nanopct4 4.4.161-rk3399 SMP

 

aplay-l shoulws realtekrt5651co as device0.

If it helps. USB audio adapters work.
It`s the same with the M4. I mostly use hdmi sound so no big problem for me.
I think it`s the same in FriendlyElecs Lubuntu. Many people have asked about it.

Share this post


Link to post
Share on other sites
16 hours ago, f8n said:

aplay-l shoulws realtekrt5651co as device0.

Any help debugging this would be great.

 

 

Does your /etc/asounf.conf include the  following lines?:
 

pcm.!default {
    type hw
    card 0
    device 0
}

ctl.!default {
    type hw
    card 0
}

Whats the complete output from aplay -l ?

 

Share this post


Link to post
Share on other sites

 

nanopct4:/etc$ aplay -l 
**** List of PLAYBACK Hardware Devices ****
card 0: realtekrt5651co [realtek,rt5651-codec], device 0: ff880000.i2s-rt5651-aif1 rt5651-aif1-0 []
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 1: rockchiphdmi [rockchip,hdmi], device 0: ff8a0000.i2s-i2s-hifi i2s-hifi-0 []
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 2: ROCKCHIPSPDIF [ROCKCHIP,SPDIF], device 0: ff870000.spdif-dit-hifi dit-hifi-0 []
  Subdevices: 0/1
  Subdevice #0: subdevice #0
nanopct4:/etc$ 

 

nanopct4:/etc$ cat asounf.conf
pcm.!default {
    type hw
    card 0
    device 0
}

ctl.!default {
    type hw
    card 0
}

 

In the pulseaudio UI I do see multiple default servers and multiple sinks, no combinations produce sound.  I have {GUID}unix:/run/user/1000/pulse/native and nanopct4 as server options.

the native option hoverover says 'detected in X properties' and the nanopct4 server option has:

user: myusername

hostname: nanopct4

server name: pulseaudio

server version 11.1

default  sample spec: s16le 2ch 44100Hz

default channel map: front-left, front-right

default sink: alsa_output.platform-rt5651-sound.stereo-fallback

default source: alsa_output.platform-rt5651-sound.stereo-fallback.monitor
cookie: some:id

which would make me think that this is the option to use as its bound to the alsa config?

Share this post


Link to post
Share on other sites

Also is there a quick and easy way to export the pulse audio sink information?
Learning some of the pulse basics from https://gavv.github.io/blog/pulseaudio-under-the-hood/ and https://wiki.archlinux.org/index.php/PulseAudio/Examples to get caught up on how pulse actually manages the end to end flow.

 

Regards,

Cam

Share this post


Link to post
Share on other sites

Shoot, noticed I had a typo /etc/asounf.conf vs /etc/asound.conf .  One sec, going to rename and restart to see if that fixes it.

Share this post


Link to post
Share on other sites

Ran an alsa-info to try to get more insight into what the audio chip is doing.  Not sure what to make of the unknown pin headphones messages.  Perhaps someone could compare my result to their working setup:

!!ALSA/HDA dmesg
!!--------------

[    1.829446] rockchip-saradc ff100000.saradc: Looking up vref-supply from device tree
[    1.830173] usbcore: registered new interface driver snd-usb-audio
[    1.834781] u32 classifier
--
[    1.979831] rockchip-drm display-subsystem: bound ff8f0000.vop (ops 0xffffff8008d45a28)
[    1.980583] dwhdmi-rockchip ff940000.hdmi: Detected HDMI TX controller v2.11a with HDCP (DWC HDMI 2.0 TX PHY)
[    1.983345] rockchip-drm display-subsystem: bound ff940000.hdmi (ops 0xffffff8008d3ab40)
--
[    2.667230] rockchip-dmc dmc: could not find power_model node
[    2.673873] of_get_named_gpiod_flags: parsed 'simple-audio-card,hp-det-gpio' property of node '/rt5651-sound[0]' - status (0)
[    2.673888] of_get_named_gpiod_flags: can't parse 'simple-audio-card,mic-det-gpio' property of node '/rt5651-sound[0]'
[    2.692154] asoc-simple-card rt5651-sound: ASoC: DAPM unknown pin Headphones
[    2.693891] asoc-simple-card rt5651-sound: rt5651-aif1 <-> ff880000.i2s mapping ok
[    2.693959] asoc-simple-card rt5651-sound: ASoC: no source widget found for MICBIAS1
[    2.693972] asoc-simple-card rt5651-sound: ASoC: Failed to add route MICBIAS1 -> direct -> Mic Jack
[    2.694322] rt5651 1-001a: ASoC: mux INL1 Mux has no paths
--
[    2.694420] rt5651 1-001a: ASoC: mux INR2 Mux has no paths
[    2.698559] input: realtek,rt5651-codec Headphones as /devices/platform/rt5651-sound/sound/card0/input4
[    2.699560] of_get_named_gpiod_flags: can't parse 'simple-audio-card,hp-det-gpio' property of node '/hdmi-sound[0]'
[    2.699569] of_get_named_gpiod_flags: can't parse 'simple-audio-card,mic-det-gpio' property of node '/hdmi-sound[0]'
[    2.700408] asoc-simple-card hdmi-sound: i2s-hifi <-> ff8a0000.i2s mapping ok
[    2.706177] of_get_named_gpiod_flags: can't parse 'simple-audio-card,hp-det-gpio' property of node '/spdif-sound[0]'
[    2.706203] of_get_named_gpiod_flags: can't parse 'simple-audio-card,mic-det-gpio' property of node '/spdif-sound[0]'
[    2.707313] asoc-simple-card spdif-sound: dit-hifi <-> ff870000.spdif mapping ok

--
[    2.735835] vcc_lcd: disabling
[    2.737442] ALSA device list:
[    2.737448]   #0: realtek,rt5651-codec
--
[    2.774218] mmc_host mmc2: Bus speed (slot 0) = 150000000Hz (slot req 150000000Hz, actual 150000000HZ div = 0)
[    2.842491] asoc-simple-card rt5651-sound: ASoC: DAPM unknown pin Headphones
[    3.011496] wifi_platform_bus_enumerate device present 1
--
[18640.323785] [UFW BLOCK] IN=eth0 OUT= SRC=192.168.2.107 DST=224.0.0.251 LEN=32 TOS=0x00 PREC=0x00 TTL=1 ID=56020 PROTO=2 
[18688.338071] asoc-simple-card rt5651-sound: ASoC: DAPM unknown pin Headphones
[18695.449217] asoc-simple-card rt5651-sound: ASoC: DAPM unknown pin Headphones
[18696.131221] asoc-simple-card rt5651-sound: ASoC: DAPM unknown pin Headphones
[18699.250179] asoc-simple-card rt5651-sound: ASoC: DAPM unknown pin Headphones

 

Share this post


Link to post
Share on other sites
12 hours ago, f8n said:

Shoot, noticed I had a typo /etc/sounf.conf vs /etc/sound.conf .  One sec, going to rename and restart to see if that fixes it.

next typo ;) its /etc/asound.conf

 

Did you check that not a volume-slider which belongs to the analog-audio is muted (unmute with the m-key)

Something like master-slider or DAC

 

Maybe you could also check if analog-audio is enabled in armbian-config -> system - > hardware

Share this post


Link to post
Share on other sites

Positive I'm good on the spelling.  It was below freezing yesterday and my typing suffered significantly.
 

cbosnic@nanopct4:/$ ls -la /etc/asoun*
-rw-r--r-- 1 root root 94 Nov  9 23:38 /etc/asound.conf
cbosnic@nanopct4:/$ cat /etc/asound.conf
pcm.!default {
    type hw
    card 0
    device 0
}

ctl.!default {
    type hw
    card 0
}

 

Volume sliders are up at 100%

 

I don't seem to have hardware as an option to verify the board settings...
 

aconfig.png

Share this post


Link to post
Share on other sites

Here are my mixer settings, its multiple pages of images so if there is a specific target I should be looking at let me know.  For now everything is unmuted OO state.

mixers.png

mix2.png

Share this post


Link to post
Share on other sites

Managed to get a massive ear bleeding screech out of the audio jack after flipping bits around to enable/disable the microphone inputs folled by toggling rt5651 asrc enable/disable in the alsa mixer.  Trying to hone in now on how to get audio without mic feedback.  On the right track at least.

Share this post


Link to post
Share on other sites

Confirming - Same on M4. I initially had nothing, them distorted sounds after playing with alsa. I still haven't bottomed it, but turning things on an off using m key makes it work.

 

After bootup, occasionally I have to do this again. I can't identify which channel and it all feels a bit buggy - like a wrong address. Something fundamental and not just a configuration setting error.

 

Watching with interest.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
0