apt-get update pointing to "404 Not Found [IP: 80]"

Recommended Posts



I'm using Armbian v5.71 on Orange Pi Plus 2E with kernel: version 3.4.113-sun8i. I didn't touch the



This is ~third day that I can not do the apt-get update without error. The output is:

root@orangepiplus2e:~# apt-get update         
Hit http://security.debian.org jessie/updates InRelease                    
Hit http://apt.armbian.com jessie InRelease                                   
Get:1 http://security.debian.org jessie/updates/main armhf Packages [636 kB]                      
Get:2 http://apt.armbian.com jessie/main armhf Packages [413 kB]                                                                   
Hit http://security.debian.org jessie/updates/contrib armhf Packages                                                              
Hit http://security.debian.org jessie/updates/non-free armhf Packages                                                                              
Get:3 http://apt.armbian.com jessie/jessie-utils armhf Packages [8,513 B]                                                           
Get:4 http://apt.armbian.com jessie/jessie-desktop armhf Packages [21.9 kB]                                     
Ign http://httpredir.debian.org jessie InRelease                                                                                                                  
Ign http://httpredir.debian.org jessie-updates InRelease                                                                                                          
Ign http://httpredir.debian.org jessie-backports InRelease                                                                                                        
Hit http://httpredir.debian.org jessie Release.gpg                                                                                                                
Ign http://httpredir.debian.org jessie-updates Release.gpg                                                                                                        
Ign http://httpredir.debian.org jessie-backports Release.gpg                                                                                                      
Hit http://httpredir.debian.org jessie Release                                                                                                                    
Ign http://httpredir.debian.org jessie-updates Release                                                                                                            
Ign http://httpredir.debian.org jessie-backports Release                                                                                                          
Ign http://httpredir.debian.org jessie-updates/main armhf Packages/DiffIndex                                                                                      
Ign http://httpredir.debian.org jessie-updates/contrib armhf Packages/DiffIndex                                                                                   
Ign http://httpredir.debian.org jessie-updates/non-free armhf Packages/DiffIndex                                                                                  
Ign http://httpredir.debian.org jessie-backports/main armhf Packages/DiffIndex                                                                                    
Ign http://httpredir.debian.org jessie-backports/contrib armhf Packages/DiffIndex                                                                                 
Ign http://httpredir.debian.org jessie-backports/non-free armhf Packages/DiffIndex                                                                                
Hit http://httpredir.debian.org jessie/main armhf Packages                                                                                                        
Hit http://httpredir.debian.org jessie/contrib armhf Packages                                                                                                     
Hit http://httpredir.debian.org jessie/non-free armhf Packages                                                                                                    
Err http://httpredir.debian.org jessie-updates/main armhf Packages                                                                                                
  404  Not Found [IP: 80]
Err http://httpredir.debian.org jessie-updates/contrib armhf Packages                                                                                             
  404  Not Found [IP: 80]
Err http://httpredir.debian.org jessie-updates/non-free armhf Packages                                                                                            
  404  Not Found [IP: 80]
Err http://httpredir.debian.org jessie-backports/main armhf Packages                                                                                              
  404  Not Found [IP: 80]
Err http://httpredir.debian.org jessie-backports/contrib armhf Packages                                                                                           
  404  Not Found [IP: 80]
Err http://httpredir.debian.org jessie-backports/non-free armhf Packages                                                                                          
  404  Not Found [IP: 80]
Fetched 443 kB in 15s (28.4 kB/s)                                                                                                                                 
W: Failed to fetch http://httpredir.debian.org/debian/dists/jessie-updates/main/binary-armhf/Packages  404  Not Found [IP: 80]

W: Failed to fetch http://httpredir.debian.org/debian/dists/jessie-updates/contrib/binary-armhf/Packages  404  Not Found [IP: 80]

W: Failed to fetch http://httpredir.debian.org/debian/dists/jessie-updates/non-free/binary-armhf/Packages  404  Not Found [IP: 80]

W: Failed to fetch http://httpredir.debian.org/debian/dists/jessie-backports/main/binary-armhf/Packages  404  Not Found [IP: 80]

W: Failed to fetch http://httpredir.debian.org/debian/dists/jessie-backports/contrib/binary-armhf/Packages  404  Not Found [IP: 80]

W: Failed to fetch http://httpredir.debian.org/debian/dists/jessie-backports/non-free/binary-armhf/Packages  404  Not Found [IP: 80]

E: Some index files failed to download. They have been ignored, or old ones used instead.

I tried even on my Orange PI PC with same 3.4.xxx from another country and the result is same.

If I put in web browser the mentioned IP address I got:

Fastly error: unknown domain: Please check that this domain has been added to a service.

Details: cache-mxp19830-MXP

Fastly error: unknown domain: Please check that this domain has been added to a service.

Details: cache-mxp19830-MXP

This is clean install of armbian, so my question is how can I solve it.


Link to post
Share on other sites
Donate and support the project!



I believe I'm having an issue, similar to this fellow here.



I am using an Orange Pi and I get the impression, that the release I'm using is no longer supported.

(That's fine, I'm not complaining!!)


However,  I would like to at least grab all the 'final' releases for that version so it's as up to date as it can be?

This is a very simple OrangePi, running off an SD Card, which handles the PiHole application.


I have attempted several goes at modifying the sources.list file, however I'm uncertain of the *exact* changes required to make the device update to the latest build (for that release)

I'm not much of a linux guy, but here's the best info I can provide with my skills.


uname -r 



It appears to be:

Description:    Debian GNU/Linux 8.10 (jessie)
Release:        8.10

Linux version 3.4.113-sun8i (root@xeon) (gcc version 5.5.0 (Linaro GCC 5.5-2017.10) ) #18 SMP PREEMPT Wed Jan 24 22:10:49 CET 2018


I've also tried this command which didn't solve my issues sadly.

sudo apt-get -o Acquire::Check-Valid-Until=false upgrade


Does anyone have an suggestions? The system is working, I'm reluctant to reboot it until I know it's ok.

I would also consider updating to the latest supported version for this little machine that is supported, although it's quite a weak system (I think 256 or 512MB of memory)  I do have 13GB free on the SDcard though.



My apologies if this isn't the right place or this isn't the right way to fix this.  Put yourself in a newbies shoes though, if you attempted an update and it was no longer supported, one would expect it would grab all relevant files for your release, update it and spit back a notification :NOTE: system no longer supported, latest updates applied.


P.S Trying to update, because pihole seems to insist an update is required and recommends performing the apt-update

Edited by GilGonGan
Link to post
Share on other sites

Hello GilGonGan,


I've quite struggled on this (on several successive topics) (more than it should have been), due to this poor support of online sources over time, that have lead on my side to a lot of experiments trying to repair / correct the Jessie archive URL (hence a lot of waste of time).


Indeed, i've in the end upgraded my previous Jessie armbian to Stretch without reinstalling.

Sadly i haven't taken any notes about it ...


Basically i did, as far as i can remember (after the unsuccessful experiments while still being on Jessie) :

- upgraded what i could while still being on jessie + removed a few packages to clean up the system

- changed my /etc/apt/sources.list to :


deb http://httpredir.debian.org/debian stretch main contrib non-free
deb http://httpredir.debian.org/debian stretch-updates main contrib non-free
deb http://httpredir.debian.org/debian stretch-backports main contrib non-free
deb http://security.debian.org stretch/updates main contrib non-free

- put in comment the content of /etc/apt/sources.list.d/armbian.list and hypriot.list, as it seems they are not available anymore (it's the only two additional sources files i had)

- upgraded the whole system with


# upgrade

apt-get update

apt upgrade

apt dist-upgrade


# clean up
apt-get autoremove
apt-get autoclean
apt-get clean

- resolve several issues, i don't remember all of them (and maybe there are not only related to the upgrade process, but rather to the pine64 support for Stretch). For example i had a lot of issues about the wlan (with debug messages that were printed all the time due to two wlan cards being now discovered ... took some time to figure), now  i have (i think it's the most relevant part but i did a lot of other things like disabling IPv6) :


iface wlan1 inet manual

to be added in /etc/network/interfaces in order to disable the second wlan1 interface (and i'm using wlan0 in auto/dhcp mode) (as seen here : https://github.com/ayufan-pine64/linux-build/blob/master/package/root/etc/network/interfaces.d/wlan1)

And for IPv6, in /etc/sysctl.conf :


net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.lo.disable_ipv6 = 1


In the end i still have a running armbian Stretch on my PINE64 box (with octoprint).


Fore reference, my PINE64 board has been bought during the kickstarted and is a PINE A64 model (with mem 2GB).


Good luck in your upgrade process.

Link to post
Share on other sites
On 4/30/2019 at 9:49 PM, SR-G said:

Is there a complete and working /etc/apt/sources.list file for ARMBIAN / jessie somewhere ?

you can use:

deb http://archive.debian.org/debian/ jessie main contrib non-free
deb-src http://archive.debian.org/debian/ jessie main contrib non-free

deb http://security.debian.org jessie/updates main contrib non-free
deb-src http://security.debian.org jessie/updates main contrib non-free

Link to post
Share on other sites
8 hours ago, GilGonGan said:

Thanks for the reply.

I had some progress but broke elsewhere.  I think some major files may be damaged.


I may need something called busybox installed, which I do not have unfortunately.



I had also some issues about dpkg not being able to complete the upgrade ... sadly for this one i don't remember at all what was the exact problem and how i solded it ...

Link to post
Share on other sites

Hello all,


I had the same problem that you guys have on my Olimex A10-Lime, but I found this page:



If you edit your /etc/apt/source.list:

deb http://deb.debian.org/debian/ jessie main
#deb-src http://deb.debian.org/debian/ jessie main

deb http://security.debian.org/ jessie/updates main
#deb-src http://security.debian.org/ jessie/updates main

deb http://archive.debian.org/debian/ jessie-backports main
#deb-src http://archive.debian.org/debian/ jessie-backports main


and edit your /etc/apt/apt.config and add the next line(Make the file if it doesn't exist):

Acquire::Check-Valid-Until false;


And do:

apt-get update && apt-get upgrade && apt-get dist-upgrade 

Apt should work again. Please be aware that after this you will no longer get 'out of date' warnings from apt-get, but that is the whole idea ;)








DON'T UPDATE 2.4.y VIA ARMBIAN-CONFIG! this corrupts you system :(

Link to post
Share on other sites
On 11/5/2019 at 6:41 PM, Igor said:

Jessie is not supported any more. Not by Debian, not by us.

Hi Igor, I know Jessie is not supported but my board only works correctly with Jessie (cubieboard1 only works with mmc on the sunxi legacy 3.4 kernel. Stretch and higher don't work on on the 3.4 kernel as systems depends on >= 3.13).


There is no jessie images on armbian so I decided to build my own (using he amazing armbian-tools!) from a historical version on git that still supports jessie. The problem is that tools like mmc-utils, u-boot-tools, etc are in the apt.armbian jessie repository which is gone.


Is there an archive somewhere of the armbian jessie repo, and if not do you have a hint how I can build it? Thanks!

Link to post
Share on other sites
31 minutes ago, Tamás Faragó said:

The problem is that tools like mmc-utils, u-boot-tools, etc are in the apt.armbian jessie repository which is gone.


Once support is dropped it become extremely expensive to do anything about. Sorry.

Rather explore how to move to new kernel. I am sure it can be done.

Link to post
Share on other sites
On 12/11/2019 at 10:40 AM, Igor said:

Rather explore how to move to new kernel. I am sure it can be done.


Hi Igor, that is going to be quite difficult. If it was easy the people over at the sunxi kernel would have updated the kernel already. Unfortunately I am stuck with this kernel. It is really unfortunate that the legacy images for jessie cubieboard were removed from the repo which made things a lot more difficult to figure out.


Please find attached my diff that was needed to get it to work along with some comments. I realise that jessie support is dropped so most of these changes will not be merged but I think it's still good to have a look through.

  • aptly-temp.conf is missing configuration setting '"gpgProvider": "gpg2"' which is required if you build your own packages instead of relying on the armbian binary.
  • the local aptly repository server doesn't work, the gpg-key has been changed to 2E676174EEF176857052DE5392B90DE1925644A6 (is in packages/extras-buildpkgs/buildpkg.gpg)
  • mmc-utils no longer exists in the jessie repository. It is there in stretch and up, but might be worthwhile removing anyways as it is in the armbian repo
  • if you are using an older apt (e.g. jessie) it cannot install local packages. They should be installed through "rpm -i". I think this change is good as the apt command skips all dependencies, etc. in essence only doing an RPM install
  • libvdpau build no longer works off of master as the build system has changed to meson. So either the debian control files need to be updated, or we need to stick to the libvdpau-1.2 branch.


For anybody else wanting to build jessie themselves the following needs to be done:

  1. checkout armbian build from git
  2. reset back to 14ecc52 which is the last good build I found working with jessie (b3bb934 is the last version of cubieboard but that already has some jessie support removed)
    1. command: git reset --hard 14ecc52
  3. don't allow armbian to update by doing the below in the root build directory
    1. command: touch .ignore_changes
  4. apply attached patches
  5. import the gpg secret key to run the local aptly - passphrase is testkey1234
    1. command: gpg --allow-secret-key-import --import packages/extras-buildpkgs/buildpkg.gpg
  6. run compilation outside of docker to build all the extra packages (docker doesn't allow building them for some reason; not sure I get the rationale). You need to set EXTERNAL_NEW="compile".
  7. from now on you can run your builds in docker, or do anything else as long as you don't clean debs. It seems that this version has a bug and doesn't use your config file in userpatches/. It does use the custom kernel file (attached for interested parties). For example I did
    1. command: ./compile.sh docker BOARD="cubieboard" BRANCH="default" RELEASE="jessie" BUILD_MINIMAL="yes" BUILD_DESKTOP="no" KERNEL_CONFIGURE="no" KERNEL_ONLY="no" INSTALL_HEADERS="yes" COMPRESS_OUTPUTIMAGE="7z" SEVENZIP="yes" PROGRESS_LOG_TO_FILE="yes" BSPFREEZE="yes" CLEAN_LEVEL="images"
  8. or just clone https://github.com/Darkvater/build;)

changes.diff linux-sun4i-default.config

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.