All Activity

This stream auto-updates     

  1. Past hour
  2. Feedback from VIM3: HDMI problems with Armbian_5.94_Aml-g12_Debian_buster_default_5.2.1_20190821.img as the screen is white and blurry... Armbian_5.94_Aml-g12_Debian_buster_dev_5.3.0-rc5_20190823.img on the other hand is working good so far. The only issue I've encountered is RAM available, which is 3354MB - far from ≈3700MB which is normal for 4GB RAM. VIM3_Ubuntu-server-bionic_Linux-4.9_arm64_EMMC_V20190813 is showing a little more with 3451MB available RAM, but it's still much lower than what's normal (≈3700MB). What's your take on this @balbes150? I can see from Khadas uboot (Github) that there have been some RAM allocation commits for uboot, but I'm not sure if they fixes the issue
  3. Thanks. So S812 is EOL with 5.77 version (Desktop)?
  4. Today
  5. As you can see in this commit, it was originally introduced during v5.1-rc1 in January. It is exactly the same patch that Armbian is using since months ...
  6. This hint is quite old, though I do not know about its current status. On the bottomline H6 is still under development and not come with any official support.
  7. Thanks for answering, I guess I'll buy the board and do some testing first (it will become more stable as time goes on anyways). The Orange Pi 3 has an onboard eMMC so I'll use that instead of Micro SD card (I know Armbian has an utility to install to eMMC, SATA, or USB). Regarding the USB 3 stuff, I would also like to know if an USB 3 hard drive has normal uptime with H6 based boards since I'm going to run an USB 3 HDD enclosure 24/7. EDIT: I'm worried about USB 3 because in the Armbian download page there is a warning for H6 devices not detecting USB 3 devices sometimes.
  8. If after install 5.94 in ki pro, reinstall by recovery stock rom, stay en bootloop, sorry, bad image flashed.
  9. Thank you @hexdump, the machine is now stable Now I can stream 4k and have my hard disk on the usb 3.0 without power issues. I am using rk3328-t9.dtb the version from hexdump
  10. To clarify, there only an emmc and not an sd card equipped. I've tried to physiclly reinstall the emmc but that did not solve the problem. When I try to mount the EMMC using an EMMC to SD converter the mounted card cannot be opened because it's read-only. Is this a sign of a failing emmc ?
  11. Hi everyone, I'm new to this forum. I'm trying to boot this armbian in a MXQ Pro 4k (S905W 1G variant. wifi chip is SV6051P). Mine board has a little problem, it lacks emmc because the old owner of the board desoldered it ( don't know why). Anyway, I burned an sdcard, I put the right dtb into the config and tried to boot. Uboot starts and tries to boot the kernel, but after a bit the kernel panics and the image won't boot. I tried to change dtb's but the kernel still panics. Any suggestion? This is the bootlog: https://drive.google.com/open?id=141wLqc9daBeW0JjPvSTotXrvfqP8mmik
  12. Also UHS-I speed will be possible after patch integration also check results (upto 69MB/s and 90MB/s (with overclock (UHS-I standard clock) to 200MHz) read from sdcard).
  13. PuTTY supports 1500000 bps but the PL2303 does not. The data sheet for the PL2303 shows that it works up to 3 Mbps but it only supports certain discrete baud rates. You need to use a USB serial adapter with an FT232R chip to support 1500000 bps. I've heard that CH340 also works but I have only tested and confirmed with FT232R.
  14. You can find it on the wiki page. http://wiki.friendlyarm.com/wiki/index.php/NanoPC-T4 They use their own order. Seems every maker uses other uart pinout/voltage. I think Putty should work. Be sure it's set to serial.
  15. Yesterday
  16. Hi, A quick update to all who have Helios4 boxes freeze up. After board replacement and switching PSUs, the box still froze from time to time. After the last freeze, I decided to move the rootfs to a USB stick, to rule out anything related to the SDcard. The SDcard is a SanDisk Ultra. 32GB class 10 A1 UHS-I HC1 type of card, picture below. After using the SDcard for booting kernel + initrd only, the box has been going strong for quite a while, when under load and when idling around: 07:39:29 up 21 days, 29 min, 6 users, load average: 0.14, 0.14, 0.10 Note that the uptime is actually more than shown, but the box has been rebooted due to unrelated issues and some planned downtime. Hope this will help any of you. Groetjes,
  17. Greetings, I have scoured every source I could find, but could only find images that hinted at it. I need 1) to know the pinout of the 4-pin debug usart port on the NanoPC T4, and possibly 2) to find a good alternative to PuTTY that can handle the high(?) bit-rate I see in dmesg output (under Armbian debian Stretch). I've tried those implied by the images, and though my Windows 7 PC sees a new COM port (and the driver installed clean) for my new DTECH USB to TTL Serial 3.3V Adapter Cable (TX RX Signal with 4 Pin 0.1 inch Pitch Female Socket PL2303 Prolific Chip for Windows 10 8 7 XP Vista (6ft, Black)), I'm unable to access it via PuTTY. This may have to do with the high base_baud value of 1500000 bps that dmesg reports for tty devices, while Putty only supports up to 128000 bps. If I can't use PuTTY, does there exist an alternative "serial" emulator which CAN handle this (rather high) bit rate? Thanks in advance. I know someone here can point me in the right direction. Regards, CJS
  18. Spent some time to sort out things... not a kernel issue... ended up being that systemctl rc.local.service was exiting based on a bad entry in rc.local that was calling dnsmasq as a systemd resource, and it failed. Since the rc.local.service fails, oled-start doesn't run Don't ask me how dnsmasq service ever got into my rc.local, along with an iptables-restore entry - as I don't recall... Might have been when I was trying to help one of our forum members out with AP mode stuff... I've never been the biggest fan of systemd - it is things like this where one can get nested items that make it hard to troubleshoot.
  19. Hi all. I've made a new video about how to build your own Armbian image with the Armbian build script. I also show how to set up virtualbox with a Ubuntu 18.04 image. Here's the video. Greetings, NicoD
  20. Received new odroid HC1 today and having issues mounting a seagate 2tb hdd. armbian odroidxu4/Debian_buster_next Seagate HDD 2TB sudo fdisk /dev/sda created new primary partition sudo mkfs.ext4 /dev/sda1 mounted drive ( this works and the drive is mounted ) sudo mount /dev/sda1 /mnt/hdd but if i try to mount as user it fails pi@HC1:~$ sudo mount -t uid=pi,gid=pi /dev/sda1 /mnt/hdd mount: /mnt/hdd: unknown filesystem type. sudo mount -o uid=pi,gid=pi /dev/sda1 /mnt/hdd mount: /mnt/hdd: wrong fs type, bad option, bad superblock on /dev/sda1, missing codepage or helper program, or other error. sudo mount -t ext4 -o gid=pi,uid=pi /dev/sda1 /mnt/hdd mount: /mnt/hdd: wrong fs type, bad option, bad superblock on /dev/sda1, missing codepage or helper program, or other error. output from fdisk -l Disk /dev/sda: 1.8 TiB, 2000398934016 bytes, 3907029168 sectors Disk model: 001-1RG174 Units: sectors of 1 * 512 = 512 bytes Sector size (logical/physical): 512 bytes / 512 bytes I/O size (minimum/optimal): 512 bytes / 512 bytes Disklabel type: dos Disk identifier: 0xeea250e5 Device Boot Start End Sectors Size Id Type /dev/sda1 2048 3907029167 3907027120 1.8T 83 Linux If I put the drive on usb/adapter with win7 laptop and format partition with ntfs all works perfectly Why all the issues when formated ext4 and is there a way to solve?
  21. So, finally today I am getting around to pulling trigger on (2x) ODROID-XU4, I go to AmeriDroid (US supplier), put 2 of them in cart and go off looking for emmc modules, only to come across: https://ameridroid.com/collections/storage-emmc-and-microsd/products/emmc-5-1-module-blank Has anyone seen / tested these? My internet search says no, but I thought I would ask anyway. If not, I guess it's my turn now to be the guinea pig. I think I will maybe get one of these and one "regular" emmc...
  22. Ameridroid have ODROID-XU4 back in stock, even though their page for them still says out of stock. I have been corresponding with them via email, they shipped all back orders last week and said they should have (at that time) like 70 more left after all orders were filled.
  23. There are graphical backgrounds? This is my favorite, and the only one I ever saw, prior to opening this thread: ____ _ _ _ _ / ___| _| |__ (_) ___| |_ _ __ _ _ ___| | __ | | | | | | '_ \| |/ _ \ __| '__| | | |/ __| |/ / | |__| |_| | |_) | | __/ |_| | | |_| | (__| < \____\__,_|_.__/|_|\___|\__|_| \__,_|\___|_|\_\ Welcome to Debian Jessie with Armbian Linux 4.19.62-sunxi System load: 1.06 0.64 0.58 Up time: 19:01 hours Memory usage: 28 % of 2010MB IP: 192.168.1.5 10.0.1.5 CPU temp: 35°C Usage of /: 6% of 59G storage/: 9% of 3.6T Last login: Fri Aug 23 01:51:43 2019 from 10.0.1.12 All jokes aside, I probably like the last one (rounded with plain grey background), and also the terra cotta army one mane me smile.
  24. @lanefu, I would add, that a lot of those features (on board video shipping, motion detection) actually seem to be supported in the Dafang hacks software. I think I read somewhere that the dev who wrote it actually worked on their firmware at some point (not sure if true)? Anyway, check out the links for more info. And I'll try and remember to report back how it all goes (although it will likely be some months from now at the rate my work schedule is going).
  25. Thanks for the input, but proprietary software is a non-starter for me. So much so in fact, that I purchase hardware nowadays based on how free/open the driver support (and company/community around it in general) are. In fact, I never even considered purchasing any IP cameras until I came across those ones with the Dafang hacks. I did hear the Zoneminder guy on some Linux podcast a few months back, and it sounded like some more development has been going on of late. Well, I certainly hope, anyway. I have yet to touch it, but I will be knee deep in it here soon enough! :D So, I've got (2x) the fixed (Xiaofang) ones and (1x) PTZ (Dafang) on the way from AliExpress as we speak. The former were only lke $20 something each, and the latter ~$30(!). I can remember what seems like only a few short years ago PTZ cameras being like $500! Anyway, back to topic, I came across this post which nicely summarizes sort of where we are today with regard to SBCs and particularly how open they are which leads directly to how well they are supported by community / Linux which means a good, long term, and stable experience for end users. For now I am going to pull trigger on (1-2) ODROID-XU4, one for dedicated ZoneMinder instance, and the other one for a spare / development / testing platform. I've also ordered a 16 port (8 PoE) gigabit switch, 1000' box of Cat5e (only $38 shipped on eBay, surprisingly!) and some ends, crimping tool, etc... so yeah we will see how it goes!
  26. WG works, thanks! Yesterday I noticed that at least on 4.14 GPIOs doesn't work for me (exports, sets direction without errors, but real output on pins won't change) , but that's story for another thread. I used oldstable (with kernel 3.14.79-cubox) until yesterday so I just found that - need to investigate first.
  1. Load more activity