Orange Pi 4 Kernel 5.x.x rt5651 sound and bluetooth fixed


iamdrq
 Share

4 4

Recommended Posts

Armbian is a community driven open source project. Do you like to contribute your code?

4 hours ago, haajee said:

Is it possible to add the bluetooth and sound fix to the armbian kernel/firmware? After every kernel update  sound and bluetooth stops working and it´s clear this fix works. :) Should be really nice!

It is fixed for some time already. It's just that there were no releases built for the board in the meantime.

It is however part of v20.05.1 - after you upgrade you should not see it disappearing again.

Link to post
Share on other sites

On 6/2/2020 at 9:42 PM, piter75 said:

It is fixed for some time already. It's just that there were no releases built for the board in the meantime.

It is however part of v20.05.1 - after you upgrade you should not see it disappearing again.

 

I has upgraded and even with a clean image Focal Desktop from here doesn´t Bluetooth works... Bleutoothctl list doesn´t show the bluetooth module also. hciconfig shows the adapter but with status down. When i try to start with hciconfig hci0 up i got the error messge: Can't init device hci0: Operation not supported (95).

Link to post
Share on other sites

Hmm this week i thought i has restored the driver HCD file with the other mac adress. Restored again and it´s ok, But better: i have bluetooth now working i wanted. I stream from my orangepi music to a bluetooth device and it works like a charm. I have used this 2 site for reference:

https://wiki.archlinux.org/index.php/Bluetooth_headset

http://mygeeks014.blogspot.com/2017/05/audio-streaming-to-bluetooth-speaker.html

 

Very very nice! Thank you all.

 

Link to post
Share on other sites

Oh and btw i got contineusly the error

 

bluetoothd[808]: a2dp-sink profile connect failed for F2:BF:67:4E:E2:A6: Protocol not available

The solution therefore is to run manually bluetooth-modules-discover.

 

pactl load-module module-bluetooth-discover

 

Link to post
Share on other sites

Hi everyone, My orangepi4 3.5mm jack isn't sound suddenly. I think isn't driver problem, because I flashed orange pi official image(include Linux and Android). I guess the sound ic rt5651 was broke (I send my board to orange pi, but was told me the repair cost up to 50% the product price and excluded ic rt5651 cost, finally I give up). so, I have reservations about my rt5651 sound patch and I hope armbian think whether remove that patch.@piter75

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

4 4