0
jmviper

Orrange Pi PC is restarting and losing wifi connection

Recommended Posts

My Orange Pi PC is restarting without apparent reason at random times and wifi and buses are disabled. The last lines of log always say the same:

 

[ 25.644949] IPv6: ADDRCONF(NETDEV_CHANGE): wlxf4f26d1c6002: link becomes ready

[ 33.781109] vcc3v0: disabling

[ 33.781136] vcc5v0: disabling

[ 33.781146] usb0-vbus: disabling

 

armbianmonitor link:

 

http://ix.io/2mTA

 

Thanks in advanced

Share this post


Link to post
Share on other sites

Thanks for answering Igor but I don't know exactly what you mean.... what power scheme setup? Sorry if I don't understand but I have only basic knowledge 

 

Anyway why after rebooting wifi and bus are disabled and syslog stops logging ?

Share this post


Link to post
Share on other sites
6 hours ago, Werner said:

How do you power your board? What kind of PSU? What kind of connector?

An old tablet charger, 5,15 V (real)  2,5 A output connected to a UPS through DC jack plug.

 

Do you think it may be the problem ?

 

Seems to be working fine since 2 years ago.

Share this post


Link to post
Share on other sites
50 minutes ago, jmviper said:

2,5 A

 

And you have two devices than can easily pull 500mA each on USB port. This way board only gets 1.5A if those 2.5A are real at all. And you are quickly on the edge ... where weird problems starts to happen. But also a wifi driver is suspicious - those realtek's are not the best quality. 

Share this post


Link to post
Share on other sites

additionally to the 2 USB-devices

- WLAN/WiFi Realtek 
Bus 004 Device 002: ID 0bda:8179 Realtek Semiconductor Corp. RTL8188EUS 802.11n Wireless Network Adapter

- USB Stick sda Kingston DataTraveler 3.0
Bus 003 Device 002: ID 0930:6545 Toshiba Corp. Kingston DataTraveler 102/2.0 / HEMA Flash Drive 2 GB / PNY Attache 4GB Stick

 

you do use more than 1008Mhz on the OPi PC (H3-CPU):

Time CPU load %cpu %sys %usr %nice %io %irq CPU C.St.

13:43:55: 1368MHz 1.20 44% 18% 12% 0% 13% 0% 72.8°C 0/8

13:43:56: 1368MHz 1.20 75% 27% 31% 1% 12% 2% 71.2°C 0/8 13:43:56:

 

which is often unstable and does heat up the cpu (too much).

 

Try to set the max. Mhz to 1008 in armbian.config -> system -> cpu

(around 500 Mhz for min.) and governor ondemand.

 

Maybe then it will be more stable ;)

 

 

Share this post


Link to post
Share on other sites
9 hours ago, jmviper said:

An old tablet charger, 5,15 V (real)  2,5 A output connected to a UPS through DC jack plug.

 

Do you think it may be the problem ?

 

Seems to be working fine since 2 years ago.

It is good that it outputs slightly over 5V. Most people, especially if they do not have slight background in electronics underestimate voltage drop accross both connector sides, the cable itself and across the board.

 

A while ago I learned that the hard way as well while using a 2,5'' harddrive on the us port of a board. The issues was that it did not spin up properly. I measured the voltage at the USB port where the harddrive was plugged and while spinning up (or trying) it dropped close to 4v which definitely was not enough. I fixed it by adding redundancy to the wiring and connected both microUSB and DC jack. The harddrive could spin up now even though there still was a slight voltage drop but I guess the harddrive manufacturers know that this could happen and make sure that to a certain grade their products work properly anways.

As the harddrive span up I disconnected the microUSB redundancy and it kept obviously running.

Altering load is also sometimes an issue for an improper PSU, especially cellphone chargers as they expect a constant load as the phone charges. But the needed current of a board changes rapidly with its load.

Share this post


Link to post
Share on other sites

Thanks to you all for answering

 

I've a power consumption meter and I'll be monitoring the different parameters today. At the moment after 20 minutes the max intensity (including boot) is 40 mA (25 mA currently), 4 W max potency (during boot I supposed) 2.5 - 3 W currently.

Theoretically the PSU must give 5V x 2.5A around 12.5 W (nominal power output). I think is far away from the limits, but nothing is discarded.

 

7 hours ago, guidol said:

additionally to the 2 USB-devices

- WLAN/WiFi Realtek 
Bus 004 Device 002: ID 0bda:8179 Realtek Semiconductor Corp. RTL8188EUS 802.11n Wireless Network Adapter

- USB Stick sda Kingston DataTraveler 3.0
Bus 003 Device 002: ID 0930:6545 Toshiba Corp. Kingston DataTraveler 102/2.0 / HEMA Flash Drive 2 GB / PNY Attache 4GB Stick

 

you do use more than 1008Mhz on the OPi PC (H3-CPU):

Time CPU load %cpu %sys %usr %nice %io %irq CPU C.St.

13:43:55: 1368MHz 1.20 44% 18% 12% 0% 13% 0% 72.8°C 0/8

13:43:56: 1368MHz 1.20 75% 27% 31% 1% 12% 2% 71.2°C 0/8 13:43:56:

 

which is often unstable and does heat up the cpu (too much).

 

Try to set the max. Mhz to 1008 in armbian.config -> system -> cpu

(around 500 Mhz for min.) and governor ondemand.

 

Maybe then it will be more stable ;)

 

 

 

OpiPC nominal CPU frequency is 1.6 GHz (1600 MHz), I think is not reaching that top value and anyway I have not overclocked it, just with the standard configuration. Sorry but I don't find it that frequency CPU option in armbian-config 

Share this post


Link to post
Share on other sites
Quote

Theoretically the PSU must give 5V x 2.5A around 12.5 W (nominal power output). I think is far away from the limits, but nothing is discarded.

Might be far from its limits but that is worth nothing if it is not capable to output a stable voltage at variable load ;)

 

Quote

OpiPC nominal CPU frequency is 1.6 GHz (1600 MHz), I think is not reaching that top value and anyway I have not overclocked it, just with the standard configuration. Sorry but I don't find it that frequency CPU option in armbian-config 

Where did you get this information? The OrangePi PC is built around the Allwinner H3 SoC which is meant to be run at 1,3 GHz. Interesting enough that your board is running at this level while the OrangePi One is capped to 1GHz due to stability issues.

 

https://linux-sunxi.org/H3

Share this post


Link to post
Share on other sites
2 hours ago, Werner said:

 

Where did you get this information? The OrangePi PC is built around the Allwinner H3 SoC which is meant to be run at 1,3 GHz. Interesting enough that your board is running at this level while the OrangePi One is capped to 1GHz due to stability issues.

 

 

http://www.orangepi.org/orangepipc/images/orangepipc_info.jpg

 

Surely I saw mistaken info

 

I have /etc/default/cpufrequtils.dpkg-old instead of /etc/default/cpufrequtils so no CPU frequency from this file is loaded at boot.

Defaults for max frequency is:

 

root@orangepipc:~# cat /sys/devices/system/cpu/cpufreq/policy0/cpuinfo_max_freq
1368000
 

So I guess if it's not loaded /etc/default/cpufrequtils because it has been rename (after kernel upgrade maybe??) to /etc/default/cpufrequtils.dpkg-old is taking the default max frequency ... am I right ?

 

Anyway I've renamed that file and reboot and now in htop CPU cores are reaching 1.3 GHz maximum instead 1.4 GHz

 

If kernel is upgraded one day this file will be renamed again I guess...

 

P.D. After renaming /etc/default/cpufrequtils.dpkg-old to /etc/default/cpufrequtils CPU frequency option is available again in armbian-config

Share this post


Link to post
Share on other sites
6 hours ago, Werner said:

The OrangePi PC is built around the Allwinner H3 SoC which is meant to be run at 1,3 GHz.

Interesting enough that your board is running at this level while the OrangePi One is capped to 1GHz

due to stability issues.

Speed above 1.08GHz mostly need another voltage for the CPU, but the most H3 Board doesnt have the parts to switch the voltage. So after a short time the CPU will get "not enough" power for the high speed and will reset - like my NanoPi A64 :(

 

He do run some time with more than 1.08GHz but then I hear him reset (and he has a A64-CPU but reacts like a H3 :) )

Share this post


Link to post
Share on other sites
7 hours ago, jmviper said:

 

Sorry but I don't find it that frequency CPU option in armbian-config 

In normal armbian images you will find it with ->

armbian-config [ENTER]

select System [ENTER]

select CPU [ENTER]

mark min. Speed (480Mhz?) [ENTER]

mark max. Speed (1008MHz) [ENTER]

mark CPU-Governor (conservative) [ENTER]

Back [Tab] [ENTER]

Exit [Tab] [ENTER]

Share this post


Link to post
Share on other sites
1 hour ago, guidol said:

In normal armbian images you will find it with ->

armbian-config [ENTER]

select System [ENTER]

select CPU [ENTER]

mark min. Speed (480Mhz?) [ENTER]

mark max. Speed (1008MHz) [ENTER]

mark CPU-Governor (conservative) [ENTER]

Back [Tab] [ENTER]

Exit [Tab] [ENTER]

 

Thanks guidol

 

As I said before if /etc/default/cpufrequtils is renamed that CPU option in armbian-config is unavailable 

 

I don't know exactly why that file was renamed in my case.

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
0