Ethernet on OPi3 went dead after system update


1 1
Go to solution Solved by Igor,

Recommended Posts

Hi there,

2 days ago I did apt update + apt upgrade on my OPi3, everything fine.

Yesterday I did a system reboot (as suggested "kernel changed"), then Eth port went dead. No even ARP works (ARPING).

Have tried:

- ifconfig shows correct values,

- ethtool shows 1Gbps FDX connection, also same on router (OpenWRT TL-WR1043ND w 18.06 software),

- changed eth cable,

- on other OPi connected to same switch / router (also went dead) depowering device helped, but not on OPi3,

- ARP shows MAC/IP not resolved,

- WiFi (configured as AP) looks working.

- also changed port on router and did power cycle device, nothing helps.

- on reboot OPi3 NOTHING was changed in the network (apart update software on OPi3).

- iptables clear, every policy is ACCEPT


How to diagnose problem? How to repair?



Link to post
Share on other sites

Donate and support the project!

1 hour ago, laurentppol said:

How to diagnose problem?

Debug console as the bug reporting guide would have told you if you would have followed it. Therefore the issue report is invalid.


Besides of that broken ethernet on OPi3 is a known issue (search function....) and a fix has been merged. Make sure you are on 5.10.y kernel.

You can either WiFi of the board or a different machine to grab debs and put the to a stick for example.

Link to post
Share on other sites

Easy way: link WiFi and apt update


moderate way: get on a computer and grab image and dtb packages (headers are optional, depending if you need them) containing current in name from the link  @Igor mentioned and put them to an USB stick.

Plug into your SBC, mount and install all of them using sudo dpkg -i *.deb

reboot, verify ethernet working again.

Link to post
Share on other sites

Great thanks Igor, "manual way" worked - downloaded  -current- debs, put it on USB stick, mounted on OPi3, then issue dpkg --install *.deb.

In time of installation there was a message about "kernel configuration invalid", but after a reset it looks to work normally.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


1 1