1 1
gewoonmaarten

Clearfog Pro: How to use switched 6 port ethernet?

Recommended Posts

Hi everyone,

 

So I am a real beginner with networking so I though I would buy this board for learning and messing about. But I cant get the switched 6 port Ethernet to work. It shows up with ip link:

root@armada:~#ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: bond0: <BROADCAST,MULTICAST,MASTER> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
    link/ether 0a:b2:e1:6c:82:2e brd ff:ff:ff:ff:ff:ff
3: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DEFAULT group default qlen 532
    link/ether 00:50:43:25:fb:84 brd ff:ff:ff:ff:ff:ff
4: eth1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 532
    link/ether 00:50:43:84:25:2f brd ff:ff:ff:ff:ff:ff
5: eth2: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 532
    link/ether 00:50:43:0d:19:18 brd ff:ff:ff:ff:ff:ff
6: tunl0@NONE: <NOARP> mtu 1480 qdisc noop state DOWN mode DEFAULT group default qlen 1
    link/ipip 0.0.0.0 brd 0.0.0.0
7: lan1@eth1: <BROADCAST,MULTICAST,M-DOWN> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
    link/ether 00:50:43:84:25:2f brd ff:ff:ff:ff:ff:ff
8: lan2@eth1: <BROADCAST,MULTICAST,M-DOWN> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
    link/ether 00:50:43:84:25:2f brd ff:ff:ff:ff:ff:ff
9: lan3@eth1: <BROADCAST,MULTICAST,M-DOWN> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
    link/ether 00:50:43:84:25:2f brd ff:ff:ff:ff:ff:ff
10: lan4@eth1: <BROADCAST,MULTICAST,M-DOWN> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
    link/ether 00:50:43:84:25:2f brd ff:ff:ff:ff:ff:ff
11: lan5@eth1: <BROADCAST,MULTICAST,M-DOWN> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
    link/ether 00:50:43:84:25:2f brd ff:ff:ff:ff:ff:ff
12: lan6@eth1: <BROADCAST,MULTICAST,M-DOWN> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
    link/ether 00:50:43:84:25:2f brd ff:ff:ff:ff:ff:ff

I also can a assign an IP to eth1 and ping it, but i cant ping any thing connected with eth1.

I am running the latest vanilla version of armbian for the Clearfog Pro.

Help would be much appreciated.

Share this post


Link to post
Share on other sites

There are some problems with ports and I am not sure all this is fixed by now but we are releasing an update later today. There will be one new kernel (4.4.20, when released: apt-get install linux-image-dev-marvell linux-dtb-dev-marvell ) which is supported by a SolidRun and needs to be tested if it's any better. Based on my tests all three kernels needs extra fixing and I thought to include more fixes into this release but their lead developer is having vacations at this moment and I could not retrieve any valuable data. After this update, it comes another and another ... :)

Share this post


Link to post
Share on other sites

Please just confirm which kernels have you try: 3.10., 4.7 and 4.4.20 (yesterday build?) There are no other kernels, official / any other builds are only older that this.

Share this post


Link to post
Share on other sites

I tried it on:

root@armada:~# ping 192.168.177.2
PING 192.168.177.2 (192.168.177.2) 56(84) bytes of data.
From 192.168.177.1 icmp_seq=1 Destination Host Unreachable
From 192.168.177.1 icmp_seq=2 Destination Host Unreachable
From 192.168.177.1 icmp_seq=3 Destination Host Unreachable
^C
--- 192.168.177.2 ping statistics ---
5 packets transmitted, 0 received, +3 errors, 100% packet loss, time 4002ms
pipe 3
root@armada:~# uname -a
Linux armada 4.7.3-marvell #25 SMP Wed Sep 14 19:24:33 CEST 2016 armv7l armv7l armv7l GNU/Linux

And on 4.4.20. But at this point I am worrying that I'm doing something wrong so i would like to go over the configurations I made.

this is a list of thing I change.

  1. apt-get update && apt-get upgrade
  2. enable ip forwarding in /etc/sysctl.conf
  3. adding this config  to /etc/network/interfaces
auto eth1 iface 
eth1 inet static 
address 192.168.177.1 
netmask 255.255.255.0 
  1. perform a reboot
  2. on the computer connected to the clearfog I create a static IP like this
auto eth0
iface eth0 inet static
address 192.168.177.2
netmask 255.255.255.0
gateway 192.168.177.1
  1. and perform a reboot
  2.   and then on the clearfog I try pinging 192.168.177.2 but it always gets lost.

I was wondering if these are the right settings

Share this post


Link to post
Share on other sites

Thats a switched device, which means: you give your bridged device an ip, and the ports use it.

Make sure you are really using the switch, and not the SFP ! 

I used archlinux and it worked without problems setting the br0 up myself, give it an ip adress, register the lan1-lan6 ports to it

 

also: iptables -L 

ethtool eth0 eth1 eth2

 

unfortunately only 4.4.x from clearfog supports sfp, thats how to see that it is the sfp device. if you have further problems, i can check this evening in detail. the sfp cage is (iirc) defined in the .dtb in /boot

Share this post


Link to post
Share on other sites

Yes, its the pro i use. It does not matter which image you use. If you use armbian, the lan* ports should be already there for usage. If not, create (as mentioned in the PM) the bridge device via systemd with the lan* devices. It should work out of the box.

 

I would recommend using mii-tool, ethtool and ifconfig to check whats going on.

Share this post


Link to post
Share on other sites

yeah I think I found the problem. I couldn't load the mv88e6xxx_drv module in /etc/modules. I also tried the modules in this link: http://cateee.net/lkddb/web-lkddb/NET_DSA_MV88E6XXX.html but with the same result. I send an email to SolidRun and waiting for there response ( hopefully I get something useful but i highly doubt that).

 

I am using latest vanilla jessie server from armbian for the clearfog pro.

 

EDIT 1:

after updating to the dev branch the module became available.

 

EDIT 2:

okay I have setup a bridge with lan1-lan6 as bridge ports and gave the bridge an IP address. But now I'm completely lost. I thought that the device behind lan1 would show up on my router but that appears not to be the case. Am I doing something wrong or is my understanding of bridges flawed? How do I communicate to the device behind lan1? 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
1 1