• 0

Problems with Gigabit


monti
 Share

3 3

Question

Hi,

 

we bought several Lime2 and tested them.

Unfortunatelly, the GBit-Lan did not seem to work reliyable. Later ping tests revealed a packet loss

on many boards of 1% to 20%. (eg. "ping -s 9000 -i 0.0001 -c 5000 fritz.box"). Some boards dont have

any problems, other more. On heavy access with SSD it's increasing a little. It's happens also without

SSD. Other boards worked fine at the same power and network cable.

 

Its possible thant this strange TX_DELAY isn't set correctly? Are there other problems known?

 

I used the wheezy image with kernel 3.4.105-lime2 and 3.4.107 from you latest wheezy image.

The image with Kernal 4.0.4 stopped after "restarting sshd", so I couldnt test them.

 

Any thoughts? Can I adjust the TX-Delay timing without recompiling?

 

Thanks,

 

Jan

 

 

Link to post
Share on other sites

Recommended Posts

  • 0

I have an Olimex Lime 2 connected to a router that has GLan ports.

My notebook is connected to the router but has only a 100 MBit ethernet port.

 

When I run iperf3 as a server on my notebook I have the full speed.

 

[ ID] Interval           Transfer     Bandwidth       Retr
[  4]   0.00-10.00  sec   110 MBytes  92.1 Mbits/sec  152             sender
[  4]   0.00-10.00  sec   110 MBytes  92.0 Mbits/sec                  receiver
 
But when I run iperf3 as a server on the board I have this result.

 

[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-10.00  sec  4.62 MBytes  3.88 Mbits/sec                  sender
[  4]   0.00-10.00  sec  4.62 MBytes  3.88 Mbits/sec                  receiver
 
When this happens I restart the board and I have the full speed again on both direction. Sometimes I have to restart the board two or three times to have again the full speed. This works for days or weeks and then I have to restart the board again if I need a fast speed.
 
I can't understand where is the problem.
Link to post
Share on other sites

Armbian is a community driven open source project. Do you like to contribute your code?

  • 0

Yes, first things which is strange is that you don't use latest build, neither for kernel neither for u-boot. I don't know if this particular combination of u-boot and kernel makes troubles, but it's possible. First do an update, than do repeat tests. We already solved some problems since:

ii linux-u-boot-lime2 5.00 armhf Uboot loader 2016.01

If you want to use vanilla kernel than uninstall this u-boot and install 

linux-u-boot-lime2-next
Link to post
Share on other sites

  • 0

apt-get update or apt-get dist-upgrade don't show any update about u-boot, only the kernel.

I've used your update script to switch to the vanilla kernel.

 

It's is possible that I stop to update u-boot in some way that I don't know after this post http://forum.armbian.com/index.php/topic/295-freezing-problem-with-olimex-a20-lime-2/ 

 

Now I do some tests and I come back if there are problems.

Thanks

Link to post
Share on other sites

  • 0

After the Igor's post I switched to mainline kernel.

I also installed the u-boot with the path of the DRAM_CLK

 

I've seen the other difference in the patch but I don't understand it.

The lan works properly for a while and then I have to restart the board to see the full speed (with the previous kernel and u-boot). The changes in the patch can produce this behavior?

With the new kernel and uboot (http://beta.armbian.com/pool/main/l/linux-u-boot-lime2-next/linux-u-boot-next-lime2_5.24.161101_armhf.deb) I haven't seen net problems yet. Igor said that this has DRAM_CLK patch. I don't know if it has also the ethernet path.  

Link to post
Share on other sites

Guest
This topic is now closed to further replies.
 Share

3 3