1 1
Choryu Park

[Solved] Asus Tinkerboard, I need to upgrade PSU?

Recommended Posts

Hmm... I have similar problem for Asus tinkerboard hangs thread's thing.

First, I've reinstall OS few days ago, because OS partition is crashed by system hangs.

I've test next build but it can't be reboot (I don't know why). cause I've install legacy build.

 

It looks pretty works well, so I've install 'transmission-daemon' to build my own seedbox.

I've plugged 500GB 2.5in External HDD and 128GB Flash Drive, and use 3A Micro-USB adapter.

 

then... ta-da! system hangs!

generally It works good 1~2 days after boot. but randomly hangs.

 

I think it's temp things cause install Fan on 3.3V GPIO, but same. It hangs.

 

Before install External HDD and Flash Drive, It never hangs!

 

I think problem maybe caused by;

1. Flash Drive

2. 3A PSU

3. 'transmission-daemon'

 

So, I will try 'Direct connect power to 5V GPIO', and question is this.

 

Can I use 5V 4A PSU?

by this video, Tinkerboard's max consumption is 2.2A.

External HDD + Flash Drive's consumption is 1.0A ~ 1.2A (expected)

So, I need more then 3A PSU, but Tinkerboard can supply over 3A to GPIO Pin?

and, I know GPIO Power supply is sensitive to Voltage. It's correct? then how can I protect circuit?

 

 

First, I will try to remove Flash Drive of this weekend.

Tinkerboard installed on my uncle's home, cause I can't manage/test on weekdays. :(

 

 

Thank you.

 

Edited by Choryu Park
solved.

Share this post


Link to post
Share on other sites

Do you have any logs to share?

 

More amperage won't help, the problem is voltage drop, which increases with amperage consumed. 

 

GPIO can supply a decent amount of power, I would not be overly concerned of the consumption.  While long term you can't pull 4 amps, in short bursts it is achievable.  If there is concern, I would make sure to attach to both 5V and 2 gnd pins (The 2nd ground pin is a few pins over from the 3 typically used.)

Share this post


Link to post
Share on other sites
4 hours ago, TonyMac32 said:

Do you have any logs to share?

 

More amperage won't help, the problem is voltage drop, which increases with amperage consumed. 

 

GPIO can supply a decent amount of power, I would not be overly concerned of the consumption.  While long term you can't pull 4 amps, in short bursts it is achievable.  If there is concern, I would make sure to attach to both 5V and 2 gnd pins (The 2nd ground pin is a few pins over from the 3 typically used.)

I have no log... now. I will bring Tinkerboard to my home on weekend, then check and provide log!

 

So, ok. I will try to decrease power consumption (disconnect USB or something), and connect 5V 3A PSU connect directly to GPIO.

If it fails, I'll post here. Thank you! :)

Share this post


Link to post
Share on other sites
9 hours ago, Choryu Park said:

... snip ..

What power supply are you using, brand?

 

I'm currently testing this NorthPada adapter & it seems to be coping extremely well (so far).

 

using

openssl speed -multi $(grep -ci processor /proc/cpuinfo)

 to give it a good workout 

 

Here's what armbianmonitor says:-

Spoiler

 


07:42:25: 1800MHz  8.11  76%  13%  62%   0%   0%   0% 68.1°C
07:42:31: 1800MHz  8.10  76%  13%  62%   0%   0%   0% 68.5°C
07:42:36: 1800MHz  8.10  76%  13%  62%   0%   0%   0% 69.2°C
07:42:41: 1704MHz  8.09  76%  13%  62%   0%   0%   0% 68.8°C
07:42:46: 1704MHz  8.08  76%  13%  62%   0%   0%   0% 63.8°C
07:42:52: 1704MHz  8.07  76%  13%  62%   0%   0%   0% 63.3°C
07:42:57: 1704MHz  8.07  76%  13%  62%   0%   0%   0% 63.8°C
07:43:02: 1704MHz  8.06  76%  13%  62%   0%   0%   0% 62.1°C
07:43:07: 1704MHz  8.06  76%  13%  62%   0%   0%   0% 61.2°C
07:43:13: 1704MHz  8.05  76%  13%  63%   0%   0%   0% 62.1°C
07:43:18: 1704MHz  8.05  76%  13%  63%   0%   0%   0% 61.7°C
07:43:23: 1704MHz  8.04  77%  13%  63%   0%   0%   0% 60.8°C
Time        CPU    load %cpu %sys %usr %nice %io %irq   CPU
07:43:29: 1704MHz  8.04  77%  13%  63%   0%   0%   0% 60.0°C
07:43:34: 1704MHz  8.04  77%  13%  63%   0%   0%   0% 61.2°C
07:43:39: 1704MHz  8.03  77%  13%  63%   0%   0%   0% 61.7°C
07:43:44: 1704MHz  8.03  77%  13%  63%   0%   0%   0% 60.0°C
07:43:50: 1704MHz  8.03  77%  13%  63%   0%   0%   0% 59.5°C
07:43:55: 1704MHz  8.02  77%  13%  63%   0%   0%   0% 59.5°C
07:44:00: 1704MHz  8.09  77%  13%  63%   0%   0%   0% 60.8°C
07:44:06: 1704MHz  8.09  77%  13%  64%   0%   0%   0% 59.5°C
07:44:11: 1704MHz  8.08  77%  13%  64%   0%   0%   0% 59.1°C
07:44:16: 1704MHz  8.07  77%  13%  64%   0%   0%   0% 59.5°C
07:44:22: 1704MHz  8.07  77%  13%  64%   0%   0%   0% 59.1°C
07:44:27: 1704MHz  8.06  77%  12%  64%   0%   0%   0% 58.2°C
07:44:32: 1704MHz  8.06  77%  12%  64%   0%   0%   0% 58.2°C
07:44:37: 1704MHz  8.05  77%  12%  64%   0%   0%   0% 58.6°C
07:44:43: 1704MHz  8.05  77%  12%  64%   0%   0%   0% 57.7°C
Time        CPU    load %cpu %sys %usr %nice %io %irq   CPU
07:44:48: 1704MHz  8.04  77%  12%  64%   0%   0%   0% 58.6°C
07:44:53: 1704MHz  8.04  78%  12%  64%   0%   0%   0% 60.4°C
07:44:59: 1704MHz  8.04  78%  12%  64%   0%   0%   0% 60.4°C
07:45:04: 1704MHz  8.03  78%  12%  65%   0%   0%   0% 59.1°C
 

07:48:46: 1704MHz  8.15  80%  11%  68%   0%   0%   0% 59.1°C
07:48:51: 1704MHz  8.14  80%  11%  68%   0%   0%   0% 58.2°C
07:48:57: 1704MHz  8.13  80%  11%  68%   0%   0%   0% 58.2°C
07:49:02: 1704MHz  8.12  80%  11%  68%   0%   0%   0% 58.2°C
07:49:07: 1704MHz  8.11  80%  11%  68%   0%   0%   0% 60.0°C
07:49:13: 1704MHz  8.10  80%  11%  68%   0%   0%   0% 59.5°C
07:49:18: 1704MHz  8.09  80%  11%  68%   0%   0%   0% 60.4°C
07:49:23: 1704MHz  8.08  80%  11%  68%   0%   0%   0% 60.4°C
07:49:28: 1704MHz  8.08  80%  11%  68%   0%   0%   0% 60.0°C
07:49:34: 1704MHz  8.07  80%  11%  68%   0%   0%   0% 61.2°C
07:49:39: 1704MHz  8.06  80%  11%  69%   0%   0%   0% 61.7°C
07:49:44: 1704MHz  8.06  80%  11%  69%   0%   0%   0% 60.8°C
07:49:50: 1704MHz  8.05  80%  11%  69%   0%   0%   0% 61.7°C
07:49:55: 1704MHz  8.05  80%  11%  69%   0%   0%   0% 61.2°C
07:50:00: 1704MHz  8.12  80%  11%  69%   0%   0%   0% 61.2°C
Time        CPU    load %cpu %sys %usr %nice %io %irq   CPU
07:50:06: 1704MHz  8.11  80%  11%  69%   0%   0%   0% 61.7°C
07:50:11: 1704MHz  8.10  80%  11%  69%   0%   0%   0% 61.7°C
07:50:16: 1704MHz  8.09  80%  11%  69%   0%   0%   0% 60.8°C
07:50:22: 1704MHz  8.08  80%  11%  69%   0%   0%   0% 61.2°C
07:50:27: 1704MHz  8.08  81%  11%  69%   0%   0%   0% 61.7°C
07:50:32: 1704MHz  8.07  81%  11%  69%   0%   0%   0% 62.9°C
07:50:37: 1704MHz  8.06  81%  11%  69%   0%   0%   0% 62.5°C
07:50:43: 1704MHz  8.06  81%  11%  69%   0%   0%   0% 62.1°C
07:50:48:  600MHz  7.41  81%  10%  69%   0%   0%   0% 48.2°C
07:50:53:  600MHz  6.82  80%  10%  69%   0%   0%   0% 46.8°C
07:50:58:  600MHz  6.27  80%  10%  69%   0%   0%   0% 45.0°C
07:51:03:  600MHz  5.77  80%  10%  69%   0%   0%   0% 42.3°C
07:51:08:  600MHz  5.31  80%  10%  69%   0%   0%   0% 41.8°C
07:51:13:  600MHz  4.88  80%  10%  69%   0%   0%   0% 41.4°C
07:51:18:  600MHz  4.49  80%  10%  68%   0%   0%   0% 40.5°C

 

This is with the following attached:

 

FM transmitter - not sure what that's drawing but I remember (when buying it) the seller said 500mv, but I dunno.

A next thing co, c.h.i.p - Have no idea what that draws.

 

I did attach a 5200mah battery in charge mode along with the above which was happily charging away until I killed the board running stress in a stupid manner, it would not boot again with the battery attached, so I suspect the battery screamed "I want more" & was duelling it out with the others, when the power was returned to the board, En GARDE! :lol:

 

---

 

The armbianmonitor output looks wrong (to me), surely it should've gotten much hotter? The drop down to 600MHz was when openssl finished.  I can't be sure whether the drop to 1704MHz was also because openssl had finished or it throttled? :unsure:

 

I've also purchased a usb doctor thing to measure the draw so should be able to give the result of that too when it arrives.

Edited by Tido
added spoiler

Share this post


Link to post
Share on other sites
9 minutes ago, mpmc said:

The armbianmonitor output looks wrong (to me), surely it should've gotten much hotter?

 

It uses /etc/armbianmonitor/datasources/soctemp which is a symlink created at boot trying to use the correct temperature source (there's some confusion and changes wrt RK3288 kernels going on -- you might follow this and check available thermal zones yourself)

Share this post


Link to post
Share on other sites
5 minutes ago, mpmc said:

I've also purchased a usb doctor thing to measure the draw so should be able to give the result of that too when it arrives.


This board without anything attached consumes (at peaks) more power that it's possible to deliver via microUSB connector. Some might work, but most not. Mighty ASUS sold you board failed by design. Board will crash even you attached the cable to the source which is able to deliver 100A at 5V. Is this clear? If not, check some insights: https://forum.armbian.com/index.php?/forum/31-sd-card-and-power-supply/

 

GPIO powering with better PSU and USB stuff attached via powered USB hub is the only way if you want to stress your board.

Share this post


Link to post
Share on other sites

@Igor

 

I'm already aware of the limits of microUSB :) Adding "Is this clear?"  really wasn't needed, makes you sound stressed :(. And, yes I've already read those posts :) .

 

This board without anything attached consumes (at peaks) more power that it's possible to deliver via microUSB connector.

 

Well, this NorthPada adapter must be certainly able to handle it as It hasn't once crashed for the past few weeks, I've left it alone for 5 days (without a reboot) & went to check it was still up, uptime said 5 + days, so no reboot had occurred. I crashed it myself using stress trying use more RAM than allowed (just to see if I could) :lol:.

 

---

 

Please bare in mind I'm only testing whether this adapter is able to keep the board alive with some devices & so far it has, I'm not expecting it to be able to power a dozen devices and the board without some issues, that would be stupid. 

Share this post


Link to post
Share on other sites
3 minutes ago, mpmc said:

really wasn't needed, makes you sound stressed 


I rather expose the obvious than writing another post ... which I am writing anyway, but for other reason :) I am glad you understand things :)

Share this post


Link to post
Share on other sites
9 minutes ago, mpmc said:

this NorthPada adapter must be certainly able to handle it

 

That's the reason why anyone permanently dealing with this shit show called 'powered by Micro USB' gets annoyed sooner or later. :) 

 

You can attach whatever you want with an amperage rating as high as some thousand amps to a Micro USB port and it won't help since it's not about amperage but about voltage drops. In my opinion boards with a boot peak consumption above 800mA that use this shitty Micro USB connector by default should be phased out.

 

You either had luck so far or by chosing a PSU that is advertised to power shitty devices by design you chose one that is prepared to compensate for the Micro USB voltage drops (then it's a 5.25V PSU and not a 5V PSU). But even if your PSU is prepared for those voltage drops the situation with Tinkerboard is still just a shit show since Micro USB is not specified for anything higher than 1.8A -- just grab a magnifying glass and look at those laughable tiny contacts. If you like pictures like that below just give it a try to overload these tiny contacts with a 3A load. Please take a video and upload it somewhere so we can all have a laugh.

 

87292d1415813822t-wp_20141112_11_10_26_p

Share this post


Link to post
Share on other sites
1 hour ago, tkaiser said:

 

It uses /etc/armbianmonitor/datasources/soctemp which is a symlink created at boot trying to use the correct temperature source (there's some confusion and changes wrt RK3288 kernels going on -- you might follow this and check available thermal zones yourself)

 

Thanks, I've checked all listed..

 

25 minutes ago, tkaiser said:

 

That's the reason why anyone permanently dealing with this shit show called 'powered by Micro USB' gets annoyed sooner or later. :) 

 

You can attach whatever you want with an amperage rating as high as some thousand amps to a Micro USB port and it won't help since it's not about amperage but about voltage drops.

 

 

Again, you're telling me something I already know!

 

Quote

In my opinion boards with a boot peak consumption above 800mA that use this shitty Micro USB connector by default should be phased out.

 

I agree.

 

Quote

 

You either had luck so far or by chosing a PSU that is advertised to power shitty devices by design you chose one that is prepared to compensate for the Micro USB voltage drops (then it's a 5.25V PSU and not a 5V PSU).

 

No luck, I just didn't go for the cheapest adapter available!

Quote

But even if your PSU is prepared for those voltage drops the situation with Tinkerboard is still just a shit show since Micro USB is not specified for anything higher than 1.8A -- just grab a magnifying glass and look at those laughable tiny contacts. If you like pictures like that below just give it a try to overload these tiny contacts with a 3A load. Please take a video and upload it somewhere so we can all have a laugh.

:( you are a real lovely person.  Schadenfreude isn't a nice trait to have, but whatever floats your boat.

Share this post


Link to post
Share on other sites
43 minutes ago, Torgar said:

Just posting a link to a product is a bit .... Do you own it? Do you have experience how good it works? 60$ for a 300mAh LiPo, charger circuit and MCU. This plus and a *random MCU* should do the same job. (Ok, 500mA less output and input voltage is more limited, but for a price of around ~10$ with MCU, instead of 60$.)

Share this post


Link to post
Share on other sites

Has no experience with the product. Just wanted to share information about a product tailored for Tinkerboard. I agree that it is not cheap!

Share this post


Link to post
Share on other sites
On 20.9.2017 at 11:58 PM, Torgar said:

Just wanted to share information about a product tailored for Tinkerboard.

 

Sorry, but there is exactly NOTHING tailored for Tinkerboard, it's just the same thing as this RPi add-on for €5 less: https://shop.olmatic.de/de/usv-raspberry-pi/2-susv-pi-advanced-4260434190029.html -- most probably you pay €5 more since they needed to replace a Raspberry symbol with a Tinkerboard logo in their advertisements and on product packaging.

 

Raspberries are based on a TV box SoC, have no PMIC and so you need such expensive 'UPS' add-on boards if you want to run Raspberries from battery. Tinkerboard is based on a tablet SoC combined with an appropriate PMIC (power management IC capable of charging / control a battery). If the Tinkerboard would not be such a horrible design fail all that's needed there to provide 'battery capabilities' would be a battery connector attached to the PMIC (and maybe some boost converter somewhere). The RK3288 is made for tablets and laptops (Chromebooks) designed to run mostly from battery, it's almost insane to combine a RK3288 based board with faulty power design with such an expensive battery thingie.

 

To get the Tinkerboard powered reliably all that's needed is just either desoldering the shitty Micro USB jack to replace it with a more suitable barrel connector or to power it with suitable cables through GPIO pin header in the first place (using 2x5V and 2xGND pins). This will both prevent undervoltage situations and crappy Micro USB equipment melting once you need to feed more than 2.5A continually.

 

Share this post


Link to post
Share on other sites

Update:

 

I'm happy to report that my tinkerboard and northpada power supply - are still alive and in one piece (including the cables/connectors, yes I checked) - after being continually under load for almost three days. The board (under a GPIO connected fan) and psu got warm, but not hot to touch at any point, the microusb connection on the board, never once got warm.

 

BUT:

 

@tkaiser is right - even if the manner he goes about it is less than tactful - the board should be powered by GPIO. But in my case, headless usage with only a few devices connected, I don't foresee any issues. So if you plan on powering by the microusb connector (which isn't recommended :lol: ) it should be okay with a decent PSU, well in my case it is, but YMMV.

Share this post


Link to post
Share on other sites

Just thought I'd pop in to say my tinkerboard has been powering a C.H.I.P and an FM transmitter (500a) for 20 days+ now without much issue. I'm just about to reflash it with Debian :).

 

Spoiler

Welcome to ARMBIAN 5.32 user-built Ubuntu 16.04.3 LTS 4.11.6-rockchip   
System load:   0.00 0.00 0.00      Up time:       20 days        
Memory usage:  2 % of 2007MB     IP:            192.168.1.104
CPU temp:      33°C               
Usage of /:    4% of 29G        

Last login: Thu Oct  5 13:27:15 2017 from 192.168.1.103
 

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
1 1