Armbian for Amlogic S9xxx kernel 5.x


Recommended Posts

Armbian is a community driven open source project. Do you like to contribute your code?

So I have a Beelink GT1 (Not Ultimate) and I've tried several different versions of Debian and Ubuntu.  The only dtb I can get to work is Khadas vim 2, but the Network Manager Wait Online fails every time, so when I boot to desktop I get no network.  Any help?

Link to post
Share on other sites
On 7/2/2019 at 3:33 PM, balbes150 said:

New image ver 5.90

I have downloaded and installed Armbian_5.90_Aml-s905_Ubuntu_bionic_next_5.2.0-rc7-next-20190701_desktop.

 

 

It works great on my Mecool km8 s912 1GB.

 

Video performance is excellent.

 

Is the 5.2 Kernel using Hardware Video decoding?

 

Is Zram working? Swap on HTOP shows no Swap memory?

Link to post
Share on other sites
8 hours ago, balbes150 said:

branch le

 

 

Hello, I've tested v5.90 on my T95Q (S905X2). I cannot see if cpu freq is changing: htop is not showing the cpu freqs, if I try to go into armbian-config/System/CPU, I get the same error I got with v5.89, if I try to use cpufreq-info, it says "no or unknown cpufreq driver is active on this CPU".

 

So, how to know if cpu freq is really changing? Am I doing something wrong?

Note: I'm using the default dtb, the same I'm using with v5.89 (meson-g12a-x96-max.dtb).

 

Thank you very much,

Link to post
Share on other sites

Hello,

 

After trying lots of the provided DTBs, I have found a few files that allow me to successfully boot into the OS. However, I am yet to find one that provides ethernet or even better, wireless connectivity. Therefore I figured it'd be better to just dump the DTB from my box's ROM.

 

The extracted DTB from /dev/dtb turned out to be around 256KB, much bigger than the ones already provided. After de- and recompiling this DTB using:

 

dtc -I dtb -O dts -o dts.img dtb.img

dtc -I dts -O dtb -o newdtb.img dts.img

 

I ended up with newdtb.img being around ~32KB. Not bad.

After copying this file to my SD card and specifying it in uEnv.ini, however, armbian refuses to boot.

 

Why is this? Am I missing something here? Both the decompiling and compiling process spitted out some warnings, which I both ignored since the readable dts output seemed fine to me.

 

Thanks!

Link to post
Share on other sites
1 hour ago, DismissedGuy said:

Hello,

 

After trying lots of the provided DTBs, I have found a few files that allow me to successfully boot into the OS. However, I am yet to find one that provides ethernet or even better, wireless connectivity. Therefore I figured it'd be better to just dump the DTB from my box's ROM.

 

The extracted DTB from /dev/dtb turned out to be around 256KB, much bigger than the ones already provided. After de- and recompiling this DTB using:

 

dtc -I dtb -O dts -o dts.img dtb.img

dtc -I dts -O dtb -o newdtb.img dts.img

 

I ended up with newdtb.img being around ~32KB. Not bad.

After copying this file to my SD card and specifying it in uEnv.ini, however, armbian refuses to boot.

 

Why is this? Am I missing something here? Both the decompiling and compiling process spitted out some warnings, which I both ignored since the readable dts output seemed fine to me.

 

Thanks!

You can't use dtb from android as is... 

Link to post
Share on other sites
1 hour ago, DismissedGuy said:

I see. Is there anything I can do with the dtb/dts that would allow me to use it with this armbian build?

Rewrite it. Use armbian as example. Write correct memory/bus addresses etc. You can find specific help in google just type "Device tree"

Link to post
Share on other sites
On 7/4/2019 at 2:40 PM, balbes150 said:

The new version of the images 5.90_20190704  for S905x2 S922.

Added support for frequency adjustment. Now the system should be able to use all the power of these processors. :)

How can we know (where can we see) cpu freq is changing when using v5.90?

Link to post
Share on other sites

Hello! I have installed latest build of debian buster on my tvbox (x96 mini, on a usb, not internal memory) and now i have aproblem: wifi is not working, system just dont see any any wifi chip. what can i do?

Spoiler

Здравствуйте, установил я последний билд дебиана на флешку и вставил в свой x96 mini, но вайфая он не видит от слова совсем, предлагает только проводное подключение. Модпроб из прошлого треда не помог, пака /lib/modules/ ничего интересного не содержит. Как я могу заставить вайфай адаптер работать?

 

Link to post
Share on other sites

The new version of images of 5.91.

The script of the images amlg12 already included in the activation script of sound (started manually it is no longer necessary, at first start, the system itself needs to run).

 

Pay attention. Images of Odroid-N2 I combined with the images of aml-g12. Now one common image for all s905x2 s922 N2 will be released.

Link to post
Share on other sites

I am a little bit confused by all the version and Kernel  numbering in Balbes version of Armbian.

 

Can someone please tell me the difference between Balbes  Armbian 

 

version 5.2rc7 and version 5.1.15

 

Is one a permanent version and the other, more of a temporary one.

 

If you update what version do you get?

Link to post
Share on other sites
18 minutes ago, balbes150 said:

New universal version 5.91_20190711 (5.2 kernel). Works on all s9xxx with sound.

It would be great to see kernel sources for this version in your github.  20190704 did not show alsa devices on my s912. Or this can be fixed with scripts?

Link to post
Share on other sites
33 minutes ago, sivanoff said:

It would be great to see kernel sources for this version in your github.  20190704 did not show alsa devices on my s912. Or this can be fixed with scripts?

Tomorrow I will move to the desired branch and create a TAG for the Armbian build environment.

Link to post
Share on other sites
On 6/15/2019 at 5:40 PM, balbes150 said:

For S905X without HW support, the browser can play full screen YouTube video with 720p desktop resolution.

 

This information is in this topic (description of system startup and installation in eMMC).

 

For use with video, you can use Armbian with the optional HW acceleration script. Information about this version of there is in this topic previously (version of DEV with mali).

 

I don't have that kind of equipment. I don't know if it will work or not with Armbian and Libreelec. I'm not dev Coreelec have no idea how well it works or not.

 

I have not tested such modes of operation.

 

 

Thank you very much!

I have followed the instructions about booting Armbian (5.91) from SD card and I'm successful able to login to desktop.

I did check the chrome GPUs flags and the h/w acceleration is disabled.

 

Quote

For use with video, you can use Armbian with the optional HW acceleration script. Information about this version of there is in this topic previously (version of DEV with mali)


Is there any separate script to run? Could you please provide me a reference?
I could not find a proper post related to this.

Link to post
Share on other sites

I'm getting into trouble when I try to compile a driver for the TBS5520SE USB DVB/S/S2 tuner>


Preparing to compile for kernel version 5.2.0
File not found: /lib/modules/5.2.0-aml-g12/build/.config at ./scripts/make_kconfig.pl line 33, <IN> line 4.
make[1]: *** [Makefile:388: allyesconfig] Error 2

There is no build directory in the referenced modules directory, is it possible to build it_

Any advice?

Link to post
Share on other sites
Guest
This topic is now closed to further replies.