11 11
balbes150

Armbian for TV box rk3328

Recommended Posts

Hey @hexdump I got the UART cable, and I tried to connect in many ways, using the console in Mac and using Putty in Windows as described here:
https://learn.adafruit.com/welcome-to-circuitpython/advanced-serial-console-on-mac-and-linux
(in the previous case not listed in the device list) and here:

https://forum.armbian.com/topic/8237-serial-console-access-via-usb-uartgadget-mode-on-linuxwindowsosx/

 


Can you tell my please how you got it working? Maybe my system is no booting at all?

Thanks.

 

Share this post


Link to post
Share on other sites

Hi 

 

I have a5max tvbox.

 

I successfuly boot on sd card  and usb stick.

 

But another side eMMc not working.Any one have right dtb file for eMMC working correct.

Share this post


Link to post
Share on other sites
1 hour ago, bybik said:

Hi 

 

I have a5max tvbox.

 

I successfuly boot on sd card  and usb stick.

 

But another side eMMc not working.Any one have right dtb file for eMMC working correct.

 

I think dtb is not the issue. Did you follow these steps for eMMc?

 

4. Rename the file "/boot/mvr9-uboot.img" to "/boot/uboot.img" in /boot directory

5. Run as user "root" script "/boot/create-mbr-linux.sh"

6. To run the script "/root/install.sh"

 

First time I forgot to follow step 4 & 5. If you go up few pages, you will also find mgx0 faced similar problem. Just check

Share this post


Link to post
Share on other sites

But when i  hit fdisk -l command.

I Don't see the emmc.Only show sd card and usb stick.  

Share this post


Link to post
Share on other sites
On 6/2/2019 at 11:14 PM, hexdump said:

can you maybe include it into the next image you build?

I tried to add, but there is an error at build, I will check that disturbs.

Share this post


Link to post
Share on other sites
1 hour ago, balbes150 said:

Update image 5.88 20190612

 

 

Trying out disco desktop on my MX10, great so far :thumbup:

Share this post


Link to post
Share on other sites
20 hours ago, balbes150 said:

In the repository Disсo until the worker LIGHTDM, so you have to use the NODM.

OK. A few weird things

1. htop does not show cpu temp

2. Preferred application launch error /usr/lib/aarch64-linux-gnu/xfce4/exo-1/exo-helper-1 (No such file or directory)

SOLVED: install libexo-1-0

3. ping: socket: Operation not permitted. which ping -> /usr/bin/ping instead of /bin/ping

SOLVED: sudo setcap cap_net_raw+p /bin/ping

Share this post


Link to post
Share on other sites
40 minutes ago, amirul said:

3. ping: socket: Operation not permitted. which ping -> /usr/bin/ping instead of /bin/ping

 

I have same issue with S9xx disco distribution.

Share this post


Link to post
Share on other sites

@Sico - did you get your usb serial adapter soldered properly to the board in the box and do you get some readable output when the box boots? if not there should be a lot of ressources on the net on how to get this working. please keep in mind, that rockchip boards usually use a speed of 1500000 instead of the usual 115200. if you get some boot output, then please create a pastebin of the boot output when you try to boot armbian on that box and post the link here.

 

good luck - hexdump

Share this post


Link to post
Share on other sites
12 hours ago, sekarpdkt said:

 

I have same issue with S9xx disco distribution.

Either use /bin/ping or do sudo setcap 'cap_net_admin,cap_net_raw+ep' /usr/bin/ping

Share this post


Link to post
Share on other sites

Sorry for asking a noob question but how do I get may A5XMax box with Android 8.1 to boot from sd-card? It just starts android when I insert the card and power up...

Share this post


Link to post
Share on other sites
3 minutes ago, Reddwarf said:

Sorry for asking a noob question but how do I get may A5XMax box with Android 8.1 to boot from sd-card? It just starts android when I insert the card and power up...

Try editing /boot/extlinux/extlinux.conf and uncommenting the line with rk3328-a5x.dtb in it, and commenting all other FDT lines. If that doesn't work try the other dtbs in /boot/dtb/rockchip/rk3328-a5x*

Share this post


Link to post
Share on other sites
1 hour ago, amirul said:

Try editing /boot/extlinux/extlinux.conf and uncommenting the line with rk3328-a5x.dtb in it, and commenting all other FDT lines. If that doesn't work try the other dtbs in /boot/dtb/rockchip/rk3328-a5x*

There is no comments at all in extlinux.conf and only one FDT line, I edited the FDT line to use rk3328-box-liantong.dtb since it seems most appropiate for my box....

Share this post


Link to post
Share on other sites

I'm running Armbian on A5X Max and I'm fully satisfied with it, so one more time I have to thanks all the people contributing to the project. I'm also curious about Mycroft (https://mycroft.ai), that is an open source Alexa like SW allowing to control devices via AI based voice recognition. I've seen that Orange PI boards with Armbian can run Mycroft and I would like to know if in your opinion it is possible to add to A5X Max some HW components providing  audio input/output capabilities for interacting with Mycroft on Armbian.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
11 11