H6 Famous Reboot problem


 Share

6 6

Recommended Posts

15 minutes ago, dreddit said:

The legacy fix involves the PH07 but find no reference on the board unless it refers to a gpio pin?

Yes, but this PH7 is the SPDIF-OUT for Audio, which is not even connect on OPi3.

I doubt this fix has anything to do with reboot issue, especially that this FEX attached this PH7 to "recovery" button ... :o

Link to post
Share on other sites

Armbian is a community driven open source project. Do you like to contribute your code?

15 minutes ago, dreddit said:

The legacy fix involves the PH07 but find no reference on the board unless it refers to a gpio pin?

Yes, but this PH7 is the SPDIF-OUT for Audio, which is not even connect on OPi3.

I doubt this fix has anything to do with reboot issue, especially that this FEX attached this PH7 to "recovery" button ... :o

Link to post
Share on other sites

15 minutes ago, dreddit said:

The legacy fix involves the PH07 but find no reference on the board unless it refers to a gpio pin?

Yes, but this PH7 is the SPDIF-OUT for Audio, which is not even connect on neither OPi3, OPiOnePlus or OPiLite2.

I doubt this fix has anything to do with reboot issue, especially that this FEX attached this PH7 to "recovery" button ... :o

Link to post
Share on other sites

SPIDF-OUT is PL9.

I think  the legacy version doesn't use the watchdog or not the same to reboot the board.

 

EDIT: I think it uses the ARISC co-processor

does someone with the h64 can test if the WDOG works ?

 

/* This should reset the system after 0.5s */
# devmem $((0x030090a0 + 0x0014))
0x00000001
# devmem $((0x030090a0 + 0x0018))
0x00000000
# devmem $((0x030090a0 + 0x0018)) 32 0x1

/* This should reset the system after 1s (as recommended in the User Manual) */
# devmem $((0x030090a0 + 0x0014))
0x00000001
# devmem $((0x030090a0 + 0x0018))
0x00000000
# devmem $((0x030090a0 + 0x0018)) 32 $((0x1 << 4))
# devmem $((0x030090a0 + 0x0018))
0x00000010
# devmem $((0x030090a0 + 0x0018)) 32 $((0x1 << 4 | 0x1))

 

Link to post
Share on other sites

12 minutes ago, martinayotte said:

You are better looking at the schematic of any H6 (OPi3, OPiOnePlus, OPILite2) before arguing, PL9 is S-IR-RX, PH7 is really SPDIF-OUT ...

Oups indeed, My brain switch between IR and SPDIF.

 

The patch is from me and yes I tested it. Still not posted it because it's more a hack.

Link to post
Share on other sites

6 minutes ago, froezus said:

The patch is from me and yes I tested it. Still not posted it because it's more a hack.

Oh ! So, @froezus is in fact Clément Péron ? :o

Alors, bienvenue sur Armbian ... Je preśume que tu es basé en France, selon l'heure de ta patch ? Moi, je suis au Québec ...

Je vais donc essayer celle-ci sous peu !

Salutation ! ;)

Link to post
Share on other sites

3 hours ago, froezus said:

The patch is from me and yes I tested it. Still not posted it because it's more a hack.

Did you got chance to figure out if the changes breaks or works for H3/H5/A64 ?

If not, we will need to build different BL31 for H6 differently from H3/H5/A64, since I'm not fluent with ATF, I'm not even sure that Armbian scripts distinguish between those ATF flavors accordingly ...

Did you exchange discussions with @megi and @Icenowy and any other about the issue ? Maybe the Official ML will still be a good place ...

Thanks for your work, since we struggling about the issue since at least 3 months ...

Link to post
Share on other sites

13 hours ago, megi said:

U-boot will also need patching, because it doesn't use ATF for reset.

What would be this second patch for the U-Boot "reset" ?

 

EDIT : for the "reboot" patch, I'm confirming : it works ! Thanks a lot to both @froezus and @megi !!!:thumbup:

EDIT2 : tested on all my H6, OPiOne+/OPiLite2/OPi3 ... And patch committed in Armbian ! :P

Link to post
Share on other sites

46 minutes ago, froezus said:

My UART is broken

:lol:

You should do like me : I have more than a dozen of USB-TTL around, almost every boards have one, so I don't have to waste time unplugging/plugging them while testing. I've even placed a new order on eBay to get more ...

46 minutes ago, froezus said:

could you test this patch ?

Tested on OPiOnePlus, now doing the OPiLite2 and OPi3 ... Patch is already committed to Armbian !

Thanks a lot for the help ! :beer:

 

EDIT : OPiLite2 and OPi3 tested too ...

Link to post
Share on other sites

4 minutes ago, martinayotte said:

Oh ! On the board side ... :wacko:

Next time, it is better to short the USB-TTL side, they are less expensive ... :P

 

Yes, at least the RX is still working.

 

BTW i have sent the patch for U-Boot if you could add your "Tested-by" tag for the reset patch.

 

Thanks

Link to post
Share on other sites

just compiled fresh full OS image (  Armbian_5.78_Orangepioneplus_Debian_stretch_dev_5.0.7.img ) but alas " reboot " hangs,

so therefore my guess is I was too early and will wait another few days building from scratch, thanks for your efforts!

 

:~/armbian/patch/atf/atf-sunxi64$ ls -la
total 36
drwxrwxr-x 4 dolphs dolphs 4096 Apr  9 16:32 .
drwxrwxr-x 5 dolphs dolphs 4096 Mar 11 00:03 ..
-rw-r--r-- 1 root  root   902 Apr  9 16:32 0001-Fix-reset-issue-on-H6-by-using-R_WDOG.patch
-rw-rw-r-- 1 dolphs dolphs 1112 Mar 11 00:03 add-SRAM-mapping-for-SCPI.patch.disabled
drwxrwxr-x 2 dolphs dolphs 4096 Apr  9 16:32 board_pine64so
drwxrwxr-x 2 dolphs dolphs 4096 Mar 11 00:03 board_pinebook-a64
-rw-rw-r-- 1 dolphs dolphs 1079 Mar 11 00:03 enable-a53-errata-workaround.patch.disabled
-rw-rw-r-- 1 dolphs dolphs 1315 Mar 11 00:03 enable-additional-regulators.patch
-rw-rw-r-- 1 dolphs dolphs  525 Mar 11 00:03 set-rsb-to-nonsec.patch

 

Just noticed the patch is added with root user instead of mine, perhaps need to chown it and give it another try?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

6 6