Jump to content
  • 0

H6 Famous Reboot problem


martinayotte
 Share

Question

Hi everyone !

 

I'm starting this new dedicated thread because I've got some new headache about this issue that we tried to figured out since months...

 

I've received my PineH64 last week, and with this board I don't faced the reboot hang behaviour !

 

Today, since I've committed the OPi3 WIP scripts, and facing same reboot hang, I've decided to to try booting PineH64 image on this OPi3 board, but unfortunately reboot hang still occurs ...

 

This brings me to a conclusion that it is not a software issue, but maybe hardware one ... I will dig on that during next few days by comparing PMIC and other between all those boards ...

 

But I remember that @jernej said that Reboot worked on one of his H6 board ...

@jernej can you confirm which board ? Do you have some boards where you still face reboot hang issue ? Can you try to mix image like I did to give clues ?

 

 

 

Link to comment
Share on other sites

Recommended Posts

Armbian Linux community supported weekly builds download

  • 0
26 minutes ago, haajee said:

yes sinds the last 2 nightly releases that was also my question a few posts above :)

Right, that was why I've build the dev 5.1. It's at 1.8Ghz from boot. All frequencies are available, even 1.64Ghz)
What available frequencies does it show for you? (cpufreq-info)

Link to comment
Share on other sites

  • 0
14 minutes ago, NicoD said:

Right, that was why I've build the dev 5.1. It's at 1.8Ghz from boot. All frequencies are available, even 1.64Ghz)
What available frequencies does it show for you? (cpufreq-info)

 

Welcome to ARMBIAN 5.87.190519 nightly Ubuntu 18.04.2 LTS 5.1.3-sunxi64

 

analyzing CPU 0:
  driver: cpufreq-dt
  CPUs which run at the same hardware frequency: 0 1 2 3
  CPUs which need to have their frequency coordinated by software: 0 1 2 3
  maximum transition latency: 244 us.
  hardware limits: 480 MHz - 1.49 GHz
  available frequency steps: 480 MHz, 720 MHz, 816 MHz, 888 MHz, 1.08 GHz, 1.32 GHz, 1.49 GHz
  available cpufreq governors: conservative, userspace, powersave, ondemand, performance, schedutil
  current policy: frequency should be within 480 MHz and 1.49 GHz.
                  The governor "ondemand" may decide which speed to use
                  within this range.
  current CPU frequency is 888 MHz (asserted by call to hardware).
  cpufreq stats: 480 MHz:87.91%, 720 MHz:1.92%, 816 MHz:1.00%, 888 MHz:2.43%, 1.08 GHz:1.51%, 1.32 GHz:0.78%, 1.49 GHz:4.45%  (26822)

 

 

Link to comment
Share on other sites

  • 0
3 minutes ago, haajee said:

  available frequency steps: 480 MHz, 720 MHz, 816 MHz, 888 MHz, 1.08 GHz, 1.32 GHz, 1.49 GHz

Very strange. I should be having the same image. Armbian_5.87_Orangepi3_Ubuntu_bionic_dev_5.1.3_desktop build 19/05/19.
I'm using the OPi3 and you the OPi1+.
I'll download the nightly for OPi3 and see if there's a difference with my build and the nightly. Should be both the same.

Could be there's seperate patches done for the OPi1+ that didn't go in 5.1. I expect the same of the OPi3 throttle issue.
I didn't follow the dev of the OPi1+. Only OPi3 and PineH64. So I don't know the differences between OPi1+ and OPi3. But since they both need different images there's going to be important differences. That needed a seperate approach.

Link to comment
Share on other sites

  • 0
9 minutes ago, martinayotte said:

I'm not very familiar with throttling ...

I'm reading everything again. But with so many pages it could takes days before I find it :)

54 minutes ago, haajee said:

  available frequency steps: 480 MHz, 720 MHz, 816 MHz, 888 MHz, 1.08 GHz, 1.32 GHz, 1.49 GHz

I've jus tried Armbian_5.87.190519_Orangepi3_Ubuntu_bionic_dev_5.1.3 that I downloaded from nightly. It's also 1.8Ghz.
Do you know how this was with kernel 5.0 on the OPi1+?

 

Link to comment
Share on other sites

  • 0

@martinayotte I've just seen another "reboot problem" with the OPi3. Screensaver/sleep had to go on, but instead it rebooted. Simple fix is to disable sleep.
But since a few months the power manager seems to have disappeared from the Armbian Desktop. I need to install one myself. Is there any reason for this? @Igor It's on all Armbian desktop images since a few months that it seems missing.

Link to comment
Share on other sites

  • 0
1 hour ago, NicoD said:

Screensaver/sleep had to go on, but instead it rebooted.

From what I know, Sleep/Hibernate works only on Legacy, since it rely on AR100 ARISC co-processor, not yet supported on Mainline.

That is true for all AllWinner SoC, not only H6 ...

For more details, here is http://linux-sunxi.org/AR100

For example, it is well known that Pinebook with Mainline, doing sleep simply returns to normal desktop, without even doing a reboot.

 

Link to comment
Share on other sites

  • 0

Wouldn't it be better to disable screensaver and power manager settings by default?

Without power manager there's no simple way for the user to disable this him/herself.

I've seen this behaviour before where screensaver didn't work because of the sleep mode of the power manager(N2 Mate Desktop). I'll see if this is also the case here.

Link to comment
Share on other sites

  • 0

Hi all, it's 2021 and this famous reset problem is still a problem with the Allwinner A64. I've made a long article about everything I tried to get a A64 reset to initiate, even low-level register writes, but I'd like to get another set of eyes on this. Maybe I'm missing something obvious?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...