All Activity

This stream auto-updates     

  1. Past hour
  2. balbes150

    Armbian for Amlogic S9xxx kernel 4.1x (>= ver 5.55)

    Kernel N2 for Armbian is the result of joint work BayLibre and developer community Libreelec (we work together closely). It takes time for everything to look finished. Only then will the publication.
  3. balbes150

    X96 MAX (S905X2) with Armbian-ubuntu

    Show photos of your model and SATA connector. I just checked image 20190412 on my X96Max (S905X2) 4\32. eMMC without problems visible, works utility DDBR (allows you to create and restore full backup eMMc) and installation works Armbian in eMMC.
  4. martinayotte

    uart interface Gpio 8 + 10 on the rock pi4

    Good catch ! ... I'm often suffer of dyslexia ...
  5. martinayotte

    GPIO Hat not detected over the IIC interface SCL, SDA

    The I2C present on Header pins 3 and 5 is the I2C7. To get I2C7 appearing as /dev/i2c-7, it requires to load the rockchip-i2c7.dtbo overlay which is present in /boot/dtb/rockchip/overlay. To do that, add the "overlays=i2c-7" into the /boot/armbianEnv.txt and reboot.
  6. NicoD

    Armbian for Amlogic S9xxx kernel 4.1x (>= ver 5.55)

    Great job. Any idea when you'll release? I'm gathering information for a review video about the N2. Ubuntu Mate has too many problems to advice to use for productivity use. Meveric's Stretch is better but swap/zram also ain't working. With that working in your Armbian I think Armbian is the best image for productivity with the N2.
  7. koakh

    X96 MAX (S905X2) with Armbian-ubuntu

    Yes it seem that is a USB <> sata bridge Its what I try to find, a way to use it on armbian, it works on android Thanks @balbes150
  8. balbes150

    Armbian for Amlogic S9xxx kernel 4.1x (>= ver 5.55)

    Sound through HDMI and the rest is there , but it is WIP and not yet for public use.
  9. SecureXperts

    GPIO Hat not detected over the IIC interface SCL, SDA

    Hi pavelectric The /dev/i2c-2 is not available on my Image. Do in need to load some Kernel modules for that? Thanks
  10. Today
  11. pavelectric

    GPIO Hat not detected over the IIC interface SCL, SDA

    So check on the other bus ... root@rockpi:~# i2cdetect -y 2
  12. SecureXperts

    uart interface Gpio 8 + 10 on the rock pi4

    The file is /boot/armbianEnv.txt and not in the /etc ;-)
  13. I have the following hat http://wiki.seeedstudio.com/Raspberry_Pi_Relay_Board_v1.0 my image detects the i2c interfaces and mounts them in /dev as i2c-0 i2c-1 i2c-3 i2c-4, I can scan the different i2c interfaces as folloging interface i2cdetect -y 1 root@rockpi:~# i2cdetect -y 1 0 1 2 3 4 5 6 7 8 9 a b c d e f 00: -- -- -- -- -- -- -- -- -- -- -- -- -- 10: UU 11 -- -- -- -- -- -- -- -- -- -- -- -- -- -- 20: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 30: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 40: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 50: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 60: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 70: -- -- -- -- -- -- -- -- I have set 0x20 address on my relay Board but cannot see the interface. Has anyone a hint what configuration settings i need to change Many Thanks Roman
  14. NicoD

    Armbian for Amlogic S9xxx kernel 4.1x (>= ver 5.55)

    It's great to have another option. Only problems I found was no on-board audio(usb audio adapter worked) and no cpu control. Otherwise it's solid. I'll keep an eye open on the progress. I red with kernel 5.2 cpu control will be enabled. Then it's perfect for me. I've put a lot of time into trying to get zram/swap to work with the Odroid kernel without any luck. With yours it works, so I know this will be ok in the future with Armbian. Thanks.
  15. I ran into the same issue after updating the kernel. Florian Fainelli told me, that with newer kernels, we need to specify "vlan_filtering 1" during creation of the bridge. Otherwise all the switch ports may end up in dumb switch mode (no separation between WAN and LAN ports). The only problem, when still on Debian Jessie: the ip command doesn't accept this option. So, I ended up upgrading from Jessie to Stretch. Here are the steps starting from the bricked device via serial console: Jessie with too new kernel (4.19) remove bound IPs (LAN: 192.168.0.20, WAN: 192.168.1.3)from bridge root@lamobo:~# bridge vlan show port vlan ids wlan0 1 PVID Egress Untagged eth0.102 1 PVID Egress Untagged br0 1 PVID Egress Untagged root@lamobo:~# ip addr show 3: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group defa0 link/ether xx:xx:xx:xx:xx:xx brd ff:ff:ff:ff:ff:ff inet6 xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx/64 scope global mngtmpaddr dynamic valid_lft forever preferred_lft forever inet6 xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx/64 scope link valid_lft forever preferred_lft forever 12: br0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group0 link/ether xx:xx:xx:xx:xx:xx brd ff:ff:ff:ff:ff:ff inet 192.168.0.20/24 brd 192.168.0.255 scope global br0 valid_lft forever preferred_lft forever inet 192.168.1.3/24 brd 192.168.1.255 scope global br0 valid_lft forever preferred_lft forever inet6 xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx/64 scope link valid_lft forever preferred_lft forever root@lamobo:~# ip addr del 192.168.0.20/24 dev br0 root@lamobo:~# ip addr del 192.168.1.3/24 dev br0 assign desired IP to eth0 (since switch is in unconfigured mode) root@lamobo:~# ip addr add 192.168.0.20/24 dev eth0 root@lamobo:~# ping 192.168.0.200 PING 192.168.0.200 (192.168.0.200) 56(84) bytes of data. 64 bytes from 192.168.0.200: icmp_seq=1 ttl=64 time=0.701 ms root@lamobo:~# route add default gw 192.168.0.200 root@lamobo:~# ping 8.8.8.8 PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data. 64 bytes from 8.8.8.8: icmp_seq=1 ttl=51 time=25.7 ms Follow the Debian Distribution Upgrade Guide change in /etc/apt/preferences.d/90-backports.pref instances of "jessie" to "stretch" change in /etc/apt/sources.list.d/armbian.list and /etc/apt/sources.list instances of "jessie" to "stretch" root@lamobo:/home/mbs# apt-get update root@lamobo:/home/mbs# apt-get dist-upgrade put new DSA compatible /etc/network/interfaces in place (change "pre-up ip link add br53125 type bridge" to "pre-up ip link add br53125 type bridge vlan_filtering 1" ) reboot When using a fresh downloaded image, a properly configured /etc/network/interfaces file also containing "vlan_filtering 1" works as well, but I had some issues to get hostapd running. First off, the wifi interface name changed from wlan0 to wl<mac-address>. Besides, I had some problems with blocked radio. It seems, uninstalling network-manager helps (I don't see a reason to have network-manager on a router). Otherwise, the rfkill tool helps in resolving this issue.
  16. gandolfi

    Armbian for Amlogic S9xxx kernel 4.1x (>= ver 5.55)

    i will prefer to use armbian with Kodi but I did not succeed to install kodi.
  17. Understood; thanks for your help - I shall stick with the older version for now.
  18. The one which is not yet supported by modern Linux. I heard that three exists and since I have two different ones and they both work ... Perhaps in a few months from now. Until then, you are destined to stock 3.10.y kernel based images. More info.
  19. In short, there is no hope to get the camera working on 4.x kernels, because they don't have CSI support ATM. I did not get it to work yet, but, first, grab something using 3.4.x kernel. Spent 3 days on it, still stuck. Also, try gc_2035 ... just in case ... or with dash ... not sure.
  20. Is there a way to tell which panel I have? This is one of the earliest pinebooks I believe, it shipped 8/2/2017.
  21. Yes, it boots to Xenial without issue. Screen comes on and I can login.
  22. guidol

    Nextcloud slow to load

    OK - may be a stupid idea, but did you test the same usage with another governor like performance in /etc/default/cpufrequtils Check also there the MIN_SPEED for 480000 because less could make problems in disk-activity-performance Maybe you could also test with armbianmonitor -m the cpu-frequence when in idle and then when you do access your system also take a look with cpufreq-info !?
  23. Igor

    Updated Pine64so images

    Due to problems with Ethernet, untested since I don't have this board. Waiting for user feedback.
  24. I have three Pinebooks. All works. But I have 2 out of 3 different panels. There is another panel out there, which might not be covered. What about Xenial version with old kernel? Does it work?
  25. There is nothing on the screen, as best I can tell the screen is not powered. Completely black.
  26. You mean the desktop doesn't come up or there is nothing on the screen?
  1. Load more activity