All Activity

This stream auto-updates     

  1. Past hour
  2. TonyMac32

    Daily (tech related) news diet

    I use gedit over an SSH session with Xming on Windows 10. [emoji38] that keeps me from from having to have multiple mouse/keyboard setups with my gaming PC. Sent from my Pixel using Tapatalk
  3. seawolfssn

    Helios4 Support

    Well I don't know what happened but a few days ago I started getting SMART warnings from one of my drives. Then the next day seek errors on all 4 drives. They are older so i figured nothing out of the ordinary. I ordered new drives to start replacing these. Last night the entire system died. And what's weird is it took the external USB drives I had plugged in down as well. They were on, but they were just clicking their heads. I plugged the externals into my own PC and they turned out to be OK, for some reason they aren't getting enough power from the USB of the helios4. Well I went and disconnected the NAS drives and on a hunch i plugged the external back in, and put the helios to power without any NAS in it and the external drive worked again and was detected! So I figured some malfunction in the 3.5" drives must have caused other issues like the externals not working. I tried a different 3.5" drive I had laying around. Was never detected. Tried another brand new drive, still not detected. I plugged a 2.5" drive in just to see what would happen and it was detected fine! I plugged one of the brand new WD reds i just bought and still nothing. I don't even think it's even spinning up. I tried all 4 power connectors, and even reseated the cables into the board to make sure they were secure... I don't think they're getting any or enough power :\
  4. Igor

    Daily (tech related) news diet

    I don't think there is any. Unfortunately not everything is perfect in this build system ... but we will fix it once
  5. Today
  6. jeanrhum

    Armbian for Amlogic S9xxx kernel 4.1x (>= ver 5.55)

    I'm currently using a GT1 ultimate with 5.75 release of Balbes150 and vim2 dtb. I don't use it as a desktop but with another s912 box used as a desktop, I use also vim2 dtb successfully.
  7. First of all, thanks for sharing your opinions. My shortlist is: 1) Odroid HC-1 - due to known stability 2) Rock64 - it has USB3 on board and recently I purchased USB3 dock for 2 drives. Works nice, uas supported, but no trim. So idea was to connect 2 drives -ssd for system and rotational for data, but looks like trim support is not for me. That's not good, but, well. Nothing stops me for rotational drive for system. Or leave system on _good_ _expensive_ microSD, or make the "read only root", which is promising, but I guess kernel updates will suffer while changing "/boot" data. 3) Orange Pi Prime. Good for it's price, has wifi onboard (hope it supports host mode for hostapd in latest kernel), but no USB 3.0. (2) and (3) are 64bit I guess. Not sure I do have 64 bit tasks (e.g. Apache/nginx large file upload), but still good to have. Also I'm quite sure they both consume less power then HC1. The case is not electricity bill, but requirements for PSU. I run my "rig" from 10A 5V psu, which powers cubie, usb hub, couple of orange pi's (pc2 and pc) without any issues. Probably HC-1 will be ok with this setup also. Personally I really like coming Allwinner H6 boards. They are colder on same Mhz's, but Armbian is in testing stage for them and quite far from stable version.
  8. I have a Beelink GT1 (not Ultimate) with 2GB RAM and 16GB storage. I tried installing the 5.77 build but can't seem to get to the desktop (I've tried many of the DTBs to no avail). On CoreElec I use gxm_q201_2g.dtb but that file itself caused issues. Has anyone gotten Beelink GT1 to work? All of the posts I searched from Beelink GT1 users are from several years ago.
  9. jeanrhum

    Home server - Cubieboard2 replacement

    You're right, but znoxx may already have an USB-sata bridge since he mentioned this option. If price is not so important, rk3399 is clearly a better choice with other possibilities.
  10. well is it really cheaper? Assuming the 2gb ram is really a requirement: Board: 35$ Reliable USB-Sata bridge: 10$ you save roughly 5$.. Depending on other requirements, the HC1/HC2 has a lot more horse power and a proper casing solution which is still missing if you opt for the rock64.. If encryption is important maybe a ARMv8 might be a better choice. But then I would probably opt for a RK3399 (support not 100% mature yet) but decent mainline support and more options to bring up SATA than with a RK3328 (and the price for the cheaper RK3399 are quite okay)..
  11. chwe

    Daily (tech related) news diet

    notepad ++ for windows and atom for armbian (on ubuntu).. problem is.. when creating patches.. the whole kernel repositories are root:root which makes editing in it uncomfortable.. @Igor a rational behind it?
  12. Igor

    filesystem error on one time

    Your SD card is failing or its fake. Use some completely different one.
  13. AndrewDB

    Armbian for Amlogic S9xxx kernel 4.1x (>= ver 5.55)

    I have also experienced that, it's the kernel random generator that requires a source of entropy to initialize the driver. There are a number of workarounds , google for it.
  14. Igor

    Orangepi 3 h6 allwiner chip

    https://www.armbian.com/get-involved
  15. Hello, I'm trying to activate the uart interface Gpio 8 + 10 on the rock pi4. I have currently installed the image of radxa. --> ARMBIAN 5.67 user-built Debian GNU/Linux 9 (stretch) 4.4.154-rk3399rockpi4b My Linux knowledge is still in the beginning. Who can help me to activate the upart interface Gpio 8 + 10 on the rock pi4. Thank you
  16. greg798

    Orangepi 3 h6 allwiner chip

    Prompt real to include linux kernel video gpu mali midgard opi3? And possible midgard to apply?
  17. This error does not give me peace. U-boot detect pendrive. If system installed in sd card detect usb pendrive. How to check in more detail what causes the problem? Kernel problem ? Some problem in initramfs ?
  18. amirul

    Armbian for Amlogic S9xxx kernel 4.1x (>= ver 5.55)

    I'm running Armbian_5.77_Aml-s912_Ubuntu_bionic_default_5.0.2_20190318 on a BM8 s912. It does seem to take its time launching startx but not minutes. After that it seems to be fine.
  19. I have same the problem. My Orange Pi Zero Plus2 H5 (date 20190116) install to eMMC and cannot boot if remove sdcard :(.
  20. Evgeny  Dmitrichenko

    filesystem error on one time

    I used this image many times and this error is come firts time image: BOARD=orangepipc2 BOARD_NAME="Orange Pi PC2" BOARDFAMILY=sun50iw2 VERSION=5.67 LINUXFAMILY=sunxi64 BRANCH=next ARCH=arm64 IMAGE_TYPE=custom BOARD_TYPE=conf INITRD_ARCH=arm64 KERNEL_IMAGE_TYPE=Image
  21. Evgeny  Dmitrichenko

    filesystem error on one time

    Hello, there I have got three device`s in one room; Image`s for this three device`s was burned to ssd card`s on this week (at 17.04.2019) Today, in the same time (Apr 21 06:47:03) they all fall down with same error (form syslog): Apr 21 06:20:52 localhost systemd[1]: Starting Daily apt upgrade and clean activities... Apr 21 06:20:52 localhost systemd[1]: Started Daily apt upgrade and clean activities. Apr 21 06:25:01 localhost CRON[8132]: (root) CMD (command -v debian-sa1 > /dev/null && debian-sa1 1 1) Apr 21 06:25:01 localhost CRON[8131]: (root) CMD (test -x /usr/sbin/anacron || ( cd / && run-parts --report /etc/cron.daily )) Apr 21 06:30:01 localhost CRON[8283]: (root) CMD (/usr/lib/armbian/armbian-truncate-logs) Apr 21 06:35:01 localhost CRON[8347]: (root) CMD (command -v debian-sa1 > /dev/null && debian-sa1 1 1) Apr 21 06:45:01 localhost CRON[8454]: (root) CMD (/usr/lib/armbian/armbian-truncate-logs) Apr 21 06:45:01 localhost CRON[8455]: (root) CMD (command -v debian-sa1 > /dev/null && debian-sa1 1 1) Apr 21 06:47:01 localhost CRON[8484]: (root) CMD (test -x /usr/sbin/anacron || ( cd / && run-parts --report /etc/cron.weekly )) Apr 21 06:47:03 localhost kernel: [192981.845014] EXT4-fs error (device mmcblk0p1): htree_dirblock_to_tree:1006: inode #172314: block 530053: comm mandb: bad entry in directory: rec_len % 4 != 0 - offset=28672, inode=4294967295, rec_len=65535, name_len=255, size=4096 Apr 21 06:47:03 localhost kernel: [192981.941193] Aborting journal on device mmcblk0p1-8. Apr 21 06:47:03 localhost kernel: [192981.953977] EXT4-fs (mmcblk0p1): Remounting filesystem read-only Apr 21 06:47:03 localhost kernel: [192981.964478] EXT4-fs error (device mmcblk0p1): htree_dirblock_to_tree:1006: inode #172314: block 530052: comm mandb: bad entry in directory: rec_len % 4 != 0 - offset=24576, inode=4294967295, rec_len=65535, name_len=255, size=4096 in kern log i see same error: Apr 21 06:47:03 localhost kernel: [192981.845014] EXT4-fs error (device mmcblk0p1): htree_dirblock_to_tree:1006: inode #172314: block 530053: comm mandb: bad entry in directory: rec_len % 4 != 0 - offset=28672, inode=4294967295, rec_len=65535, name_len=255, size=4096 Apr 21 06:47:03 localhost kernel: [192981.941193] Aborting journal on device mmcblk0p1-8. Apr 21 06:47:03 localhost kernel: [192981.953977] EXT4-fs (mmcblk0p1): Remounting filesystem read-only Apr 21 06:47:03 localhost kernel: [192981.964478] EXT4-fs error (device mmcblk0p1): htree_dirblock_to_tree:1006: inode #172314: block 530052: comm mandb: bad entry in directory: rec_len % 4 != 0 - offset=24576, inode=4294967295, rec_len=65535, name_len=255, size=4096 Environment: BOARD=orangepipc2 BOARD_NAME="Orange Pi PC2" BOARDFAMILY=sun50iw2 VERSION=5.67 LINUXFAMILY=sunxi64 BRANCH=next ARCH=arm64 IMAGE_TYPE=custom BOARD_TYPE=conf INITRD_ARCH=arm64 KERNEL_IMAGE_TYPE=Image In syslog I gote line bofore error = Apr 21 06:47:01 localhost CRON[8484]: (root) CMD (test -x /usr/sbin/anacron || ( cd / && run-parts --report /etc/cron.weekly )) can it be that cron.weekly was do something wrong? How you think, what was going wrong?
  22. Evgeny  Dmitrichenko

    Orange pi pc2 reboot by him self

    thank you, now it`s clear for me
  23. Seasalt

    Armbian for Amlogic S9xxx kernel 4.1x (>= ver 5.55)

    I have updated my s912 Mecool Km8 to the latest Babes Ubuntu version. It all works very very well. Including Video playback. But there is one small new problem. When I boot up there is a inordinate delay before the login screen appears. It could be minutes before the login screen appears. It may appear faster if you click the mouse or keyboard. Is any one having a similar problem?
  24. amirul

    Armbian for Amlogic S9xxx kernel 4.1x (>= ver 5.55)

    add video=1920x1080 to the end of the bootargs line in /boot/uEnv.ini
  25. djurny

    Helios4 Support

    Bad news... It took almost over a week, but: My 2nd box froze today, last output on the serial console: 17:41:22: 800MHz 0.19 10% 2% 0% 1% 5% 0% 67.0°C 0/0 Time CPU load %cpu %sys %usr %nice %io %irq CPU C.St. 17:41:28: 1600MHz 0.17 14% 6% 0% 4% 3% 1% 67.5°C 0/0 17:41:33: 800MHz 0.16 6% 2% 0% 1% 1% 0% 67.0°C 0/0 17:41:38: 1600MHz 0.31 15% 6% 0% 3% 2% 1% 67.5°C 0/0 17:41:43: 1600MHz 0.36 7% 2% 0% 1% 2% 1% 68.0°C 0/0 17:41:48: 1600MHz 0.33 15% 6% 0% 5% 1% 0% 67.5°C 0/0 17:41:53: 1600MHz 0.31 6% 2% 0% 1% 1% 0% 68.5°C 0/0 Same symptoms, NIC is blinking, heartbeat LED is off, serial console is unresponsive. Any thoughts? Groetjes,
  26. martinayotte

    Orangepi 3 h6 allwiner chip

    It is not that easy, you will need to disable few patches, tweaks some others, and create new ones ... But here is at least where you should begin with : diff --git a/config/sources/sun50iw6.conf b/config/sources/sun50iw6.conf index e42581a..0245e64 100644 --- a/config/sources/sun50iw6.conf +++ b/config/sources/sun50iw6.conf @@ -46,11 +46,11 @@ case $BRANCH in KERNELPATCHDIR='sunxi-dev-h6' BOOTSOURCE=$MAINLINE_UBOOT_SOURCE BOOTDIR=$MAINLINE_UBOOT_DIR - BOOTBRANCH='tag:v2019.01' + BOOTBRANCH='tag:v2019.04' #KERNELSOURCE=$MAINLINE_KERNEL_SOURCE KERNELSOURCE="https://github.com/megous/linux" - KERNELBRANCH="branch:orange-pi-5.0" + KERNELBRANCH="branch:orange-pi-5.1" KERNELPATCHDIR='sunxi-dev' KERNELDIR=$MAINLINE_KERNEL_DIR diff --git a/config/sources/sunxi64_common.inc b/config/sources/sunxi64_common.inc index fea1322..aa84a2e 100644 --- a/config/sources/sunxi64_common.inc +++ b/config/sources/sunxi64_common.inc @@ -54,7 +54,7 @@ case $BRANCH in #KERNELSOURCE=$MAINLINE_KERNEL_SOURCE KERNELSOURCE="https://github.com/megous/linux" #KERNELBRANCH='branch:linux-4.19.y' - KERNELBRANCH="branch:orange-pi-5.0" + KERNELBRANCH="branch:orange-pi-5.1" KERNELDIR=$MAINLINE_KERNEL_DIR KERNELPATCHDIR='sunxi-dev' KERNEL_USE_GCC='> 7.0' diff --git a/config/sources/sunxi_common.inc b/config/sources/sunxi_common.inc index 26f8602..c767d33 100644 --- a/config/sources/sunxi_common.inc +++ b/config/sources/sunxi_common.inc @@ -40,7 +40,7 @@ case $BRANCH in #KERNELSOURCE=$MAINLINE_KERNEL_SOURCE KERNELSOURCE="https://github.com/megous/linux" - KERNELBRANCH="branch:orange-pi-5.0" + KERNELBRANCH="branch:orange-pi-5.1" KERNELDIR=$MAINLINE_KERNEL_DIR KERNELPATCHDIR='sunxi-dev' KERNEL_USE_GCC='> 7.0'
  27. jeanrhum

    Armbian for Amlogic S9xxx kernel 4.1x (>= ver 5.55)

    I never tried, but I suppose that this package is better than the generic one.
  1. Load more activity