Single Armbian image for RK + AML + AW (aarch64 ARMv8)


balbes150

Recommended Posts

Donate and support the project!

6 minutes ago, Turgus said:

..and you forgot to place an # before all lines which are not your hw (like rk3399 section..)

 

10 minutes ago, Novato said:

 

sorry, i forgot to type the .dtb extension

It worked, thank you very much for the information, I was very lost here.  Now everything is going smoothly.

IMG_20200530_174006.jpg

Link to post
Share on other sites
5 hours ago, balbes150 said:

To upgrade from the old core, you need to restore the original firmware and go through all the steps for a clean installation. Or perform all the steps manually (do not wait for a detailed step-by-step guide for the manual option, you will have to solve everything yourself on the spot).

Thanks @balbes150 with your hard work to prepare the images is enough for me.

So no "original firmware" no way. If anyone have the "manual recipe" to install latest image on Amlogic board in the manual way I will glad to test the recipe.

Thanks again.

Link to post
Share on other sites
Posted (edited)

I've been able to boot into armbian via sd card without issue using the update method. Ethernet is working and nothing seems to be broken.

 

However, trying to launch Armbian Config to install on eMMC doesn't work because after clicking to open the program a terminal pops up and disappears immediately, similar to how if you opened a command line program in windows just by clicking on it, it would close by itself. 

 

I'm not sure if this is a related problem but running terminal and trying to use su fails even though I'm certain I've got the password correct. I even reformatted and installed the image again on the sd card to make sure I set the password correctly but I always get authentication failed.

 

Sudo also fails unless I press Control+Alt+F3 and then I can login on the new screen.

Synaptic Package Manager isn't able to open at all as well.

 

On another note, is it possible to back up the android system before installing armbian permanently? All the guides I've seen so far for backing up eMMC are to backup armbian, not the original android installed on it.

 

Edited fix: I was able to fix sudo and config by following the steps in the fix sudo thread on this forum. The other issues still remain.

 

 

Edited by Zazazas
Link to post
Share on other sites
6 minutes ago, Reddwarf said:

Sorry I haven't been following this forum for a while so quick question: Can these images run on RK3229 based tv-boxes? Or be recompiled for them?

No, since it's not arm64. Look at this topic:

 

Link to post
Share on other sites

As usual just the newest (maybe test revisions?!) pcb version 4.x has a wifi chip working well, if you got the usual v.1.x-pcb inside with SSV6051(like I got on my first x96mini 2/16 too), just ethernet or usb wifi works.

Link to post
Share on other sites
8 hours ago, Turgus said:

As usual just the newest (maybe test revisions?!) pcb version 4.x has a wifi chip working well, if you got the usual v.1.x-pcb inside with SSV6051(like I got on my first x96mini 2/16 too), just ethernet or usb wifi works.

Oh, no wonder.

I saw your previous posts that said wifi was working and that caused the confusion. Is there no way to get wifi working on this model then?
 

Link to post
Share on other sites

..but I always mentioned that wifi only works on 4.x versions of HW and on other just eth(or usb wifi).

If you would find sources for this chip, you might be able to build the needed modules for this kernel, but I simply prefer using ethernet or usb-wifi (with better connection since antenna is outside the box on other standard x96 mini )which is -if you use the usb ports already- with a 3-Port mini hub plus the usb-wifi under 7-10$/€ shipped from CN.

Link to post
Share on other sites

My H96max crashed today.  Would not boot. 
is there any way, apart from full reinstall to get it bootable again ?

it would only come up with the android recovery. 
could reboot from SD and create data backup. But still takes time to get the rest of what I need installed. HomeAssistant, so mostly docker containers. But my HA backup is a bit old. But I do have the data dirs but it is not the same. 

Link to post
Share on other sites

Armbian_20.05.6_Arm-64_focal_current_5.7.0-rc7_desktop_20200605.img.xz works on my collection of x96 mini 2/16 as expected.

Wifi & BT work only on the 4.x revision boards, on standard versions just ethernet(or usb wifi). No issues with the image so far, installed it already on internal of 3 boxes...

Link to post
Share on other sites

..but on two x96minis I just went back to Armbian_20.08.0_Arm-64_bionic_current_5.7.0-rc7_desktop_20200531.img.xz because there is camorama still available, which gives me the best performance of all webcamviewers with 720p video(on focal with cheese, guvcview, kamoso etc. I always got around 15° higher temperatures and much higher cpu load) without using active cooling system or reducing cam resolution. So I'd appreciate if there were also bionic releases of the images in future to avoid using a noisy fan.
On the box without cams focal works pretty normal, cool and smooth.

Link to post
Share on other sites

 

 

staff can help me ?, I have a project in Brazil(www.sistemafenix.com.br) and replace my raspberry with amlogic s905. I have had many problems with wifi. I bought 30 boxes. Below I present the information find the wifi but do not find any wifi network. With the ifconfig command I was able to view wlan0 but found nothing with the command:

 

This is the last version:

root@arm-64:/home/fenix# uname -a
Linux arm-64 5.7.0-rc7-arm-64 #20.05.6 SMP PREEMPT Fri Jun 5 20:29:42 MSK 2020 aarch64 aarch64 aarch64 GNU/Linux
root@arm-64:/home/fenix# 

root@arm-64:/home/fenix# ifconfig 
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.0.3  netmask 255.255.255.0  broadcast 192.168.0.255
        inet6 2804:14c:87c0:c3ca:736a:38aa:be2a:14c8  prefixlen 64  scopeid 0x0<global>
        inet6 fe80::43d9:c6e0:4c88:1d03  prefixlen 64  scopeid 0x20<link>
        inet6 2804:14c:87c0:c3ca:1192:5116:ca74:fa2c  prefixlen 64  scopeid 0x0<global>
        ether 00:15:18:01:81:31  txqueuelen 1000  (Ethernet)
        RX packets 12444  bytes 10137349 (10.1 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 6605  bytes 1048422 (1.0 MB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 25  

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 425  bytes 35625 (35.6 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 425  bytes 35625 (35.6 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether e0:76:d0:d6:3d:4d  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

root@arm-64:/home/fenix# 
I can see wlan0, but.......

 

root@arm-64:/home/fenix# iwlist wlan0 scan
wlan0     No scan results

root@arm-64:/home/fenix# lsmod
Module                  Size  Used by
fuse                  139264  3
bnep                   28672  2
zram                   45056  2
nls_ascii              16384  1
brcmfmac              389120  0
joydev                 28672  0
hci_uart              126976  0
brcmutil               24576  1 brcmfmac
btqca                  16384  1 hci_uart
btrtl                  20480  1 hci_uart
btbcm                  24576  1 hci_uart
btintel                32768  1 hci_uart
cfg80211              417792  1 brcmfmac
crct10dif_ce           20480  1
meson_vdec             81920  0
lima                   69632  0
gpu_sched              36864  1 lima
ir_nec_decoder         16384  0
bluetooth             446464  13 btrtl,btqca,btintel,hci_uart,btbcm,bnep
v4l2_mem2mem           45056  1 meson_vdec
videobuf2_dma_contig    24576  1 meson_vdec
videobuf2_memops       20480  1 videobuf2_dma_contig
rc_khadas              16384  0
videobuf2_v4l2         36864  2 meson_vdec,v4l2_mem2mem
ecdh_generic           16384  1 bluetooth
ecc                    32768  1 ecdh_generic
meson_ir               16384  0
videobuf2_common       65536  3 meson_vdec,videobuf2_v4l2,v4l2_mem2mem
rfkill                 40960  6 bluetooth,cfg80211
dw_hdmi_cec            16384  0
rc_core                57344  4 rc_khadas,ir_nec_decoder,meson_ir
videodev              294912  4 meson_vdec,videobuf2_v4l2,videobuf2_common,v4l2_mem2mem
ao_cec                 16384  0
mc                     61440  4 videodev,videobuf2_v4l2,videobuf2_common,v4l2_mem2mem
snd_soc_simple_amplifier    16384  1
display_connector      16384  0
sch_fq_codel           20480  3
ip_tables              32768  0
x_tables               45056  1 ip_tables
ipv6                  622592  50
nf_defrag_ipv6         24576  1 ipv6
gpio_keys_polled       16384  0
adc_keys               16384  0
 

armbianmonitor -u
System diagnosis information will now be uploaded to 
http://ix.io/2ozF
Please post the URL in the forum where you've been asked for.
 

I need to produce many boxes with armbian but I need security because wifi chipsets change all the time, I would like to be able to buy hardware compatible with Armbian and its versions. it has been very difficult.

Guys can give me a help. I will be very grateful and desperate because I have many boxes of this model. I saw that on Android the module used by the kernel and dhd.ko on kernel 3.14. What should I do? 

 

The last time I returned 5 box s905 with a problematic wifi  SV6051P driver, I changed and got this model.

This time I'm 30 and I was sure the wifi would be compatible and I can't return it. help me people!

 

Link to post
Share on other sites
32 minutes ago, gilberto said:

 

 

staff can help me ?, I have a project in Brazil(www.sistemafenix.com.br) and replace my raspberry with amlogic s905. I have had many problems with wifi. I bought 30 boxes. Below I present the information find the wifi but do not find any wifi network. With the ifconfig command I was able to view wlan0 but found nothing with the command:

 

 

 

Try this page

to start with

Link to post
Share on other sites
Posted (edited)

How do you disable sleep? I can't wake it up and it's still on since the light is on. 

How do you install it to emmc? I can never find actual instructions for this distro.

Edited by Zazazas
Link to post
Share on other sites
1 hour ago, dbsharpe said:

Try this page

to start with

 

thank you very much for responding, I did the procedure below for my wlan0 device is gone(disapear)

To fix, use

 

mv /lib/firmware/brcm/brcmfmac4330-sdio.txt /lib/firmware/brcm/brcmfmac4330-sdio.txt.old
ln -s  /lib/firmware/brcm/nvram_ap6330.txt  /lib/firmware/brcm/brcmfmac4330-sdio.txt

 

in a shell on the target as root. Not sure where this Ubuntu  distribution fault has crept in.
nvram_ap6330.txt is actually the same file as android system:/etc/wifi/40183/nvram.txt and although not perfect, works better!

 

root@arm-64:/home/fenix# ifconfig 
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.0.3  netmask 255.255.255.0  broadcast 192.168.0.255
        inet6 2804:14c:87c0:c3ca:215:18ff:fe01:8131  prefixlen 64  scopeid 0x0<global>
        inet6 2804:14c:87c0:c3ca:736a:38aa:be2a:14c8  prefixlen 64  scopeid 0x0<global>
        inet6 fe80::215:18ff:fe01:8131  prefixlen 64  scopeid 0x20<link>
        ether 00:15:18:01:81:31  txqueuelen 1000  (Ethernet)
        RX packets 6409  bytes 6392279 (6.3 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 3300  bytes 498137 (498.1 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 22  

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 26  bytes 3529 (3.5 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 26  bytes 3529 (3.5 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

 

 

I will restore it as it was before. If you know of something or how to buy box s905 compatible with armbian.

 

the driver of this wifi is active in the kernel tree, but in the last version of this post it doesn't work. I think it's important to be able to make it work .....

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...