1 1
Club AC-News

Update PHP ?

Recommended Posts

Hi all,

I use a cubieboard3 as a web server. For several months, joomla tells me that I am PHP 7.0.33-0 + deb9u7et that I need to update my version of php to 7.3 or later. In the updates of the bone, I never see these updates of PHP, must it be done manually and how? I am in Debian Stretch with Armbian Linux 4.19.62-sunxi.

Thank you

François

Share this post


Link to post
Share on other sites

Hi,

 

Quote

4.19.62-sunxi

Armbian marked Stretch as EOS. The current supported release is Buster.

 

Quote

4.19.62-sunxi

Outdated as well. You probably missed the versioning change last year.

 

Quote

php to 7.3

You either should ask at Debian forums/search if there are backports for Stretch or update to Debian Buster.

Share this post


Link to post
Share on other sites
36 minutes ago, Club AC-News said:
I use a cubieboard3 as a web server. For several months, joomla tells me that I am PHP 7.0.33-0 + deb9u7et that I need to update my version of php to 7.3 or later. In the updates of the bone, I never see these updates of PHP, must it be done manually and how?

@Club AC-News

I checked on my old FOX G20 with Kernel 4.9.124 and debian-stretch and in the normal debian-repositories there is only PHP v7.0

 

But it seem that you are not the only one who needs >= v7.3 on stretch :)

 

And YES you have to add something manually:

before you can install a new php-version:
==========================================

sudo apt-get update
sudo apt-get upgrade

sudo apt install ca-certificates apt-transport-https
wget -q https://packages.sury.org/php/apt.gpg -O- | sudo apt-key add -
echo "deb https://packages.sury.org/php/ stretch main" | sudo tee /etc/apt/sources.list.d/php.list

after that 

for PHP v7.3:
=============
sudo apt install php7.3
sudo apt install php7.3-cli php7.3-common php7.3-curl php7.3-mbstring php7.3-mysql php7.3-xml

or 

for PHP v7.4:
=============
sudo apt install php7.4
sudo apt install php7.4-cli php7.4-common php7.4-curl php7.4-mbstring php7.4-mysql php7.4-xml

for additonal informations (like configuring Apache/Nginx-Webserver to run PHP) check the following URLs:

https://tecnstuff.net/how-to-install-php-on-debian-9/

https://tecadmin.net/install-php-debian-9-stretch/

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
1 1