Randoms reboot NanoPi M4V2


Go to solution Solved by piter75,

Recommended Posts

Donate and support the project!

21 minutes ago, Igor said:

5V powering via USB-C is on the edge (especially for hungry hw) if it comes via official or unofficial power adapter / cable.

mmm perhaps the cable is the problem... how could I check it? Also I'm using a an adapter to fit from Asia to Europe :)


Anyway, is there any other alternatives you can recommend me?

Link to post
Share on other sites

The cable made something different, since the board was up almost 1.5 days, but it was rebooted again. 


@Werner I'm very noob, can you explain how can I power it up from GPIO?  or which other PSU could work? I read in the internet some guys are using Raspberry's Pi 4 PSU, but reading the specs, are lower than the official from friendelec.


Many thanks.

Link to post
Share on other sites

I've done a lot of tests with the M4V2 and powering and even at 4V it stayed stable. I've never had a crash running the legacy kernel. 
Best thing to check voltage is to use a usb voltage meter in the USB ports of the SBC. Also at the input and see if the difference is big. Using good cables is necessary. Even most USB-C cables are not made for power. This SBC can use up to 2A, most cheap USB cables can't handle that. 
A Raspberry Pi crashes quickly, and is very unstable with even 4.9V. But not the M4V2.

What is connected to it? Maybe a USB over voltage? You could also try a legacy kernel image to see if it's a kernel issue. Also using uart connected to another device you'd probably be able to see what went wrong. 

Link to post
Share on other sites

Thanks all for the messages, I've tried with another one, 6.5V, and it's the same, it was rebooted 3.5hours ago. I don't know if it could be a kernel problem, I'm using also a M4V1 with SATA hat, and kernel 5 and works flawless (Up time:       27 days 1:15), so I think it is related to the PSU/cable...

My main problem here is I'm not good with electric stuff, meters etc, I have an standard meter, but I don't know even how to use it :(


Sorry for asking @NicoD with the usb meter, should be plug and see? :D if so, I think even I could make it.


I'm going to look for a good usb cable... 



Link to post
Share on other sites

You could also

10 minutes ago, i5Js said:

Well, the cable is not the problem, the board rebooted 36 mins ago.... so frustrating.


I used to have a lot of hangs with older mainline kernels. Since I am on the latest everything is running smoothly for me. You could try the latest kernel. You can't download this kernel from the website. You can download this kernel through armbian-config.


Armbian 21.02.2 Buster with Linux 5.10.16-rockchip64

Link to post
Share on other sites

6 hours ago, i5Js said:

Updated to the latest... let's see.

If it fails which I think it will... Can you try this image? https://users.armbian.com/piter75/Armbian_21.05.0-trunk_Nanopim4v2_buster_current_5.10.18_minimal-stability-fix.img.xz

It contains a fix/workaround to dvfs issues I found and makes all of my M4V2 units running stable. Tested with hours of memtester running without failures. It failed pretty quick without the fix.

Link to post
Share on other sites



I recently got a Nanopi M4v2 on which I installed Armbian Buster current and updated the system, including kernel.


After a few hours the board would crash, requiring a power cycle.


Aftet reading this thread I decided to try a fixed frequency, so I left it at 2GHz. With a fixed clockspeed I ran stress tests, several runs of sbc-bench, browser benchmarks,  used it to open documents in Libreoffice, watched videos using the browser, etc. and it was totally stable for over 5 days straight.


I only had problems with Chromium crashing, but Firefox (or equivalent) worked fine.


I changed the max and min clocks to defaults and it locked up about 4 hours later.


The board was working headlessly and I accessed it remotely using xrdp or dwservice.net.


I don't have it connected to UART at the moment because I don't have another computer nearby to connect it to where the board is placed, but if it helps I can find a way to connect it and give you the output.

Link to post
Share on other sites

@i5Js any constant frequency should do, switching cpufreq to performance profile also solved M4V2 stability issues in the past


@i5Js @Glock24 I would appreciate if you verified the image referred in the previous post. If it works without crashes and we merge the change into master we could finally have stable M4V2 in Armbian current out of the box.


Link to post
Share on other sites

6 hours ago, Lennyz1988 said:



Just to confirm you are on this kernel right? Linux 5.10.16-rockchip64




Welcome to Armbian 21.02.2 Focal with Linux 5.10.16-rockchip64


System load: 10%           Up time:       1 day 23:13

Link to post
Share on other sites

  • Solution

@i5Js you can download these packages and install them with apt/dpkg: https://users.armbian.com/piter75/nanopim4v2-stability-fix/

You need both of them for the fix.


When they are correctly installed and the board is rebooted you should see this message in your dmesg:

piter@nanopim4v2-4:~$ dmesg | grep rk808-regulator.*buck
[    2.840331] rk808-regulator rk808-regulator: max buck steps per change: 4

The last "4" means you have the fix. No message or "8" means you don't have a fix.

Link to post
Share on other sites

Hi @piter75, I've just applied the patch, and rebooted the pi


i5js@noldork3sN2:~$ dmesg | grep rk808-regulator.*buck
[    2.883990] rk808-regulator rk808-regulator: max buck steps per change: 4


I'll keep you posted.



Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.