Jump to content

Orange Pi 5 Plus

Recommended Posts

Posted (edited)

A new variation of Orange Pi 5 is now available.  I think it's available on AliExpress, but I've seen the item on Amazon.com as well...reasonable price:




It comes now with the RK3588 instead of the RK3588s of the 5 and 5B.  It's similar in capabilities of the Rock 5B but I believe has a few more bells and whistles.  It has two  2.5GB ethernet ports.  Separate connectors than GPIO for RTC and fan.  Full size HDMI input as well as 2 full size HDMI outputs.  Can have m.2 for 2230 WiFi/BT on top side as well as m.2 2280 on bottom of board.  I think it can only go up to 16GB memory.


Not sure if Armbian will make all of these work...yet.


But this makes perfect sense...I just bouth my Orange Pi 5 about a month ago :(


PS:  A new tag is required for this new variation...I guess.


PPS:  Other thing to note is that Amazon link is for a 16GB version and includes a power supply.  However, this particular listing ships from China.  For Orange Pi 5 and 5B there were listings that were fulfilled by Amazon.  I would think that Orange Pi will/may have those in the near future, that ship from the US...hopefully, but likely a little more expensive.


PPPS:  If you go to that Amazon link, there is also a version with 4GB and no power supply for $99.99 at the time this was posted.

Edited by ArmBoy1988
Link to comment
Share on other sites

Donate your old hardware to community. Start a giveaway Raffle!

I wasn't too upset with the wifi version.


However those two 2.5gbps ethernet ports have me regretting the 5.

You sure do need that good powersupply with this model. I have to run my external data SSD drive off of an externally powered USB hub too, as it draws too much power.

Link to comment
Share on other sites

I was thinking that if the Orange Pi 5 I purchased didn't live up to what I was looking for, I'd buy the Rock 5B or something like that.  In any case, I got the 16GB memory, m.2 for an SSD and I wasn't going to need WiFi or I could just get a WiFi dongle, if needed.  A big difference, for me, is the PCIe throughput, I think that the throughput for the m.2 on the 5 will probably be sufficient.

Link to comment
Share on other sites

Yup packaging looks good indeed, ordered one too so I could use the "old" one for LinuxCNC (great machine for it).


Would've been better if it had a 12v dc input, atm I'm using a 5v 4a usb c adapter, it seems like this is giving me sporadic issues. Hopefully this isn't the case with the OPi5+. Otherwise power direct on the pins worked fine.


I hesitated to buy the NanoPC-T6 which has a nice case (20,-) and 12v input, but it doesn't have MTD and no choice to buy without emmc.


@Avatar Ng Did you buy a case/heatsink with it?

Link to comment
Share on other sites

@royk yeah man, NanoPC-T6 seems like a better deal, I NEED A CASE XD ... 
end up I add on NVME, Wi-Fi6+BT5, casing (design my own), ... etc the cost goes up a lot 😂

Quick update, tried Armbian image "Armbian_22.11.4_Orangepi5_jammy_legacy_5.10.110_gnome_desktop.img" no luck; probably other image is like Radxa 5b image is a closer sibling??
and no debug message due to not found my tty debug cable yet 😅.

Link to comment
Share on other sites

@Efe Çetin Seems like the OPI5 image ("Armbian_23.02.2_Orangepi5_jammy_legacy_5.10.110.img") works better (at least it boots and got into console display) than the one you provide me, I tried both "Armbian_23.08.0-trunk_Orangepi5-plus_jammy_legacy_5.10.160_gnome_desktop.img" and the one from Radxa Rock 5b ("Armbian_23.02.2_Rock-5b_jammy_legacy_5.10.110.img"), these don't even boot with display.


Seems the official branch added support for this new board.

Let me supplement all those debug logs in the following days, apologize for the TTY debug cable, I have to get a new one.

Following were stack trace from TTY, using image  "Armbian_23.08.0-trunk_Orangepi5-plus_jammy_legacy_5.10.160_gnome_desktop.img".


Note: I've flash my SPI Flash by the way, for PCIE NVMe boot using OrangePi official Ubuntu image.


[  430.778765] rk806-pinctrl rk806-pinctrl.7.auto: not freeing pin 1 (gpio_pwrctrl2) as part of deactivating group gpio_pwrctrl2 - it is already used for some other setting
[  431.082338] reboot: Power down
\0\0\0DDR Version V1.08 20220617
LPDDR4X, 2112MHz
channel[0] BW=16 Col=10 Bk=8 CS0 Row=17 CS1 Row=17 CS=2 Die BW=8 Size=4096MB
channel[1] BW=16 Col=10 Bk=8 CS0 Row=17 CS1 Row=17 CS=2 Die BW=8 Size=4096MB
channel[2] BW=16 Col=10 Bk=8 CS0 Row=17 CS1 Row=17 CS=2 Die BW=8 Size=4096MB
channel[3] BW=16 Col=10 Bk=8 CS0 Row=17 CS1 Row=17 CS=2 Die BW=8 Size=4096MB
Manufacturer ID:0x6 
CH0 RX Vref:32.7%, TX Vref:22.8%,21.8%
CH1 RX Vref:31.7%, TX Vref:22.8%,22.8%
CH2 RX Vref:31.7%, TX Vref:22.8%,22.8%
CH3 RX Vref:30.7%, TX Vref:22.8%,22.8%
change to F1: 528MHz
change to F2: 1068MHz
change to F3: 1560MHz
change to F0: 2112MHz
U-Boot SPL board init
U-Boot SPL 2017.09-orangepi (May 25 2023 - 10:42:30)
Trying to boot from MMC1
Trying fit image at 0x4000 sector
## Verified-boot: 0
## Checking atf-1 0x00040000 ... sha256(806278dba1...) + OK
## Checking uboot 0x00200000 ... sha256(6e73bf447d...) + OK
## Checking fdt 0x00311dd0 ... sha256(d2dda3ef7c...) + OK
## Checking atf-2 0x000f0000 ... sha256(c00c7fd75b...) + OK
## Checking atf-3 0xff100000 ... sha256(71c3a5841b...) + OK
## Checking atf-4 0xff001000 ... sha256(2301cf73be...) + OK
Jumping to U-Boot(0x00200000) via ARM Trusted Firmware(0x00040000)
Total: 727.55 ms

INFO:    Preloader serial: 2
NOTICE:  BL31: v2.3():v2.3-405-gb52c2eadd:derrick.huang
NOTICE:  BL31: Built : 11:23:47, Aug 15 2022
INFO:    spec: 0x1
INFO:    ext 32k is valid
INFO:    GICv3 without legacy support detected.
INFO:    ARM GICv3 driver initialized in EL3
INFO:    system boots from cpu-hwid-0
INFO:    idle_st=0x21fff, pd_st=0x11fff9, repair_st=0xfff70001
INFO:    dfs DDR fsp_params[0].freq_mhz= 2112MHz
INFO:    dfs DDR fsp_params[1].freq_mhz= 528MHz
INFO:    dfs DDR fsp_params[2].freq_mhz= 1068MHz
INFO:    dfs DDR fsp_params[3].freq_mhz= 1560MHz
INFO:    BL31: Initialising Exception Handling Framework
INFO:    BL31: Initializing runtime services
WARNING: No OPTEE provided by BL2 boot loader, Booting device without OPTEE initialization. SMC`s destined for OPTEE will return SMC_UNK
ERROR:   Error initializing runtime service opteed_fast
INFO:    BL31: Preparing for EL3 exit to normal world
INFO:    Entry point address = 0x200000
INFO:    SPSR = 0x3c9

U-Boot 2017.09-armbian (May 28 2023 - 19:44:43 +0000)

Model: RK3588 Orange Pi 5 Plus
PreSerial: 2, raw, 0xfeb50000
DRAM:  15.7 GiB
Sysmem: init
Relocation Offset: eda65000
Relocation fdt: eb9f9a98 - eb9fecc8
Using default environment

mmc@fe2c0000: 0, mmc@fe2e0000: 1
Bootdev(atags): mmc 0
MMC0: Legacy, 52Mhz
PartType: EFI
DM: v2
boot mode: None
Model: RK3588 Orange Pi 5 Plus
CLK: (sync kernel. arm: enter 1008000 KHz, init 1008000 KHz, kernel 0N/A)
  b0pll 24000 KHz
  b1pll 24000 KHz
  lpll 24000 KHz
  v0pll 24000 KHz
  aupll 24000 KHz
  cpll 1500000 KHz
  gpll 1188000 KHz
  npll 24000 KHz
  ppll 1100000 KHz
  aclk_center_root 702000 KHz
  pclk_center_root 100000 KHz
  hclk_center_root 396000 KHz
  aclk_center_low_root 500000 KHz
  aclk_top_root 750000 KHz
  pclk_top_root 100000 KHz
  aclk_low_top_root 396000 KHz
Net:   No ethernet found.
Hit key to stop autoboot('CTRL+C'):  0 
switch to partitions #0, OK
mmc0 is current device
mmc@fe2c0000: 0 (SD)
mmc@fe2e0000: 1
switch to partitions #0, OK
mmc0 is current device
Scanning mmc 0:1...
Found U-Boot script /boot.scr
reading /boot.scr
3476 bytes read in 10 ms (338.9 KiB/s)
## Executing script at 00500000
Boot script loaded from mmc 0
reading /armbianEnv.txt
168 bytes read in 2 ms (82 KiB/s)
reading /uInitrd
15256327 bytes read in 1225 ms (11.9 MiB/s)
reading /Image
34638336 bytes read in 2775 ms (11.9 MiB/s)
** Unable to read file /dtb/rockchip/rk3588s-orangepi-5-plus.dtb **
libfdt fdt_check_header(): FDT_ERR_BADMAGIC
No FDT memory address configured. Default at 0xeb9f9a98
** Unable to read file /dtb/rockchip/overlay/rockchip-rk3588-fixup.scr **
Unknown command 'kaslrseed' - try 'help'
Fdt Ramdisk skip relocation
## Loading init Ramdisk from Legacy Image at 0a200000 ...
   Image Name:   uInitrd
   Image Type:   AArch64 Linux RAMDisk Image (gzip compressed)
   Data Size:    15256263 Bytes = 14.5 MiB
   Load Address: 00000000
   Entry Point:  00000000
   Verifying Checksum ... OK
ERROR: Did not find a cmdline Flattened Device Tree
Could not find a valid device tree
SCRIPT FAILED: continuing...

Device 0: unknown device

Device 2: Could not get clock for spi@fe2b0000: -2
unknown device

Device 1: Could not get clock for spi@fe2b0000: -2
unknown device

Device 0: unknown device
starting USB...
Bus usb@fc800000: "Synchronous Abort" handler, esr 0x96000004

* Reason:        Exception from a Data abort, from current exception level
* PC         =   00000000002809c0
* LR         =   00000000002809c0
* SP         =   00000000eb9f8b50
* ESR_EL2    =   0000000096000004
* Reloc Off  =   00000000eda65000

x0 : ffffffffffffffff x1 : 00000000edd3a9f1
x2 : 00000000fffffffc x3 : 0000000000000000
x4 : 00000000edd432ed x5 : 000000000000006e
x6 : 00000000edd2e12e x7 : 0000000000000000
x8 : 0000000000000044 x9 : 0000000000000008
x10: 00000000ffffffd0 x11: 00000000ebc6d288
x12: 0000000000000000 x13: 0000000000000004
x14: 000000000000000c x15: 0000000000000002
x16: 00000000edca9f74 x17: 0000000000000005
x18: 00000000eb9ffce0 x19: 0000000000000000
x20: 00000000ebc88f80 x21: 00000000ebc64140
x22: 00000000ebc89110 x23: 00000000edd4cfec
x24: 00000000edd77d40 x25: 0000000000000000
x26: 0000000000000000 x27: 0000000000000000
x28: 00000000ebc88930 x29: 00000000eb9f8d30

Call trace:
  PC:	[< 002809c0 >]
  LR:	[< 002809c0 >]

	[< 002809c0 >]
	[< 00233494 >]
	[< 0027cb00 >]
	[< 00212d3c >]
	[< 00212ddc >]
	[< 0022ad20 >]
	[< 00218124 >]
	[< 002182d8 >]
	[< 002179ec >]
	[< 0022a2d0 >]
	[< 0022ad20 >]
	[< 00218124 >]
	[< 002182d8 >]
	[< 002179ec >]
	[< 0022a2d0 >]
	[< 0022ad20 >]
	[< 00218124 >]
	[< 002182d8 >]
	[< 00217a28 >]
	[< 00217fdc >]
	[< 00217db8 >]
	[< 002182d8 >]
	[< 002179ec >]
	[< 0022a2d0 >]
	[< 0022ad20 >]
	[< 00218124 >]
	[< 002182d8 >]
	[< 002179ec >]
	[< 0022a240 >]
	[< 00218978 >]
	[< 00216818 >]
	[< 00219018 >]
	[< 0028cc68 >]
	[< 00219254 >]
	[< 00201e18 >]

Copy info from "Call trace..." to a file(eg. dump.txt), and run
command in your U-Boot project: ./scripts/stacktrace.sh dump.txt 

Resetting CPU ...

### ERROR ### Please RESET the board ###


Edited by Avatar Ng
Link to comment
Share on other sites

Here's another, tried an older image "Armbian_22.11.4_Orangepi5_jammy_legacy_5.10.110_gnome_desktop.img", at least there's a display, and then after the Armbian logo loading screen, gets into the following infinite loop (please find full log at attachment)

[  217.042512] rk3x-i2c fec80000.i2c: timeout, ipd: 0x80, state: 3
[  217.145850] rk3x-i2c fec80000.i2c: timeout, ipd: 0x80, state: 3
[  217.249275] rk3x-i2c fec80000.i2c: timeout, ipd: 0x80, state: 3
[  217.352617] rk3x-i2c fec80000.i2c: timeout, ipd: 0x80, state: 3
[  217.455849] rk3x-i2c fec80000.i2c: timeout, ipd: 0x80, state: 3
[  217.559164] rk3x-i2c fec80000.i2c: timeout, ipd: 0x80, state: 3

Image "Armbian_23.02.2_Orangepi5_jammy_legacy_5.10.110.img" is more silent, it stops at "Starting kernel ...", let me know if you need that log too, I forgot to capture it, it also has a display on my HDMI monitor.

Hope that helps.


Edited by Avatar Ng
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...