• Announcements

    • 1. Check power supply, check SD card and check other people experiences

      Power supply issues are one of the three biggest issues you'll face when starting with Single Board Computers (SBCs). SD card issues, whether fake or faulty, are another and issues resulting from poor board design is the other common issues you can encounter.   Power supply issues can be tricky. You might have a noisy power supply that works with one board because it has extra filtering, but won't work with another. Or you're using that cheap phone charger because your board has a microUSB connector, and it is either erratic, or doesn't start up, or even becomes the cause of some SD card issues.    Some tips to avoid the most common causes of problems reported:   Don't power via micro USB  - unless you have optimised your setup for low power requirements. Micro USB is great for mobile phones because they are simply charging a battery. It's bad for SBCs. Yes, it does work for a lot of people, but it also causes more problems and headaches over time than it is worth, unless you know exactly what you are doing. If you have a barrel jack power connector on your SBC, use it instead! If there is an option for powering via header connections, use that option!
        Don't use mobile phone chargers. They might be convenient and cheap, but this is because they are meant for charging phones, not powering your SBC which has particular power requirements.
        When you are evaluating a power supply, make sure you run some stress tests on your system to ensure that it will not cause issues down the path.   (Micro) SD card issues can be sneaky. They might appear right at the start causing strange boot and login errors, or they might cause problems over time. It is best to run a test on any new SD card you use, to ensure that it really is what it is, and to ensure that isn't faulty. Armbian provides you a simple way to do this   --   armbianmonitor -c /path/to/device/to/test  
    • 2. Make sure to collect and provide all necessary information

      We can only help if you provide quality information for us to work with. All stable images from the download section are tested, most stable upgrades are tested and we have tens of thousands of users. Even with regular and extensive testings, bugs sometimes do slip through. This is a voluntary support service and is unrelated to board makers, and is not obligated to provide you any answers. Repeated asking the same questions because you're not happy with the answers will result in you being ignored.

      Before you post a question, use the forum search as someone else might have already had the same problem and resolved it. And make sure you've read the Armbian documentation. If you still haven't found an answer, make sure you include the following in your post:   1. Logs when you can boot the board: armbianmonitor -u (paste URL to your forum post)   2. If your board does not boot, provide a log from serial console or at least make a picture, where it stops.   3. Describe the problem the best you can and provide all necessary info that we can reproduce the problem. We are not clairvoyant or mind readers. Please describe your setup as best as possible so we know what your operating environment is like.     We will not help in cases you are not using stable official Armbian builds, you have a problem with 3rd party hardware or reported problem would not be able to reproduced.

Orange PI PC Wireless Module (8192cu)
1 1

54 posts in this topic

Recommended Posts

Hi,

 

I tried to compile and install this module https://github.com/pvaret/rtl8192cu-fixes

 

but when I run: "sudo dkms install 8192cu/1.10" the result is

 

Building module:
cleaning build area.....
make KERNELRELEASE=3.4.110-sun8i -C /lib/modules/3.4.110-sun8i/build M=/var/lib/dkms/8192cu/1.10/build......(bad exit status: 2)
Error! Bad return status for module build on kernel: 3.4.110-sun8i (armv7l)
Consult /var/lib/dkms/8192cu/1.10/build/make.log for more information.
 
make.log content:
 
DKMS make.log for 8192cu-1.10 for kernel 3.4.110-sun8i (armv7l)
Sun Feb 28 00:13:37 CET 2016
make: Entering directory '/usr/src/linux-headers-3.4.110-sun8i'
  LD      /var/lib/dkms/8192cu/1.10/build/built-in.o
  CC [M]  /var/lib/dkms/8192cu/1.10/build/core/rtw_cmd.o
/bin/sh: 1: /usr/src/linux-headers-3.4.110-sun8i/scripts/recordmcount: not found
scripts/Makefile.build:307: recipe for target '/var/lib/dkms/8192cu/1.10/build/core/rtw_cmd.o' failed
make[1]: *** [/var/lib/dkms/8192cu/1.10/build/core/rtw_cmd.o] Error 127
Makefile:1367: recipe for target '_module_/var/lib/dkms/8192cu/1.10/build' failed
make: *** [_module_/var/lib/dkms/8192cu/1.10/build] Error 2
make: Leaving directory '/usr/src/linux-headers-3.4.110-sun8i'
 
Note: the package linux-headers-generic is not found also.
 
Any help please?
 
Thanks in Advance.
 

Share this post


Link to post
Share on other sites

Headers are present on the system, don't download anything especially not some generic.

cd /usr/src/linux-headers-3.4.110-sun8i/
make scripts # this you will skip in the future when we fix the building process
cd
git clone https://github.com/pvaret/rtl8192cu-fixes
cd rtl8192cu-fixes
make ARCH=arm
# when done
insmod 8192cu.ko
# dmesg
usbcore: registered new interface driver rtl8192cu
WarHawk_AVG likes this

Share this post


Link to post
Share on other sites

The armbian-5.05 builds for OrangePiOne ( simple/xfce - versions ) both fail with 8192cu wifi-dongle EW-7811Un.

Armbian seems to try to register the module twice and causes fatal crashes when using the installed driver(s).

 

======================================================

 

dmesg
-----

[ 6641.758850] rtl8192cu: Chip version 0x10
[ 6641.843455] rtl8192cu: MAC address: 80:1f:02:84:da:34
[ 6641.843475] rtl8192cu: Board Type 0
[ 6641.843697] rtlwifi: rx_max_size 15360, rx_urb_num 8, in_ep 1
[ 6641.843819] rtl8192cu: Loading firmware rtlwifi/rtl8192cufw.bin
[ 6641.844488] usbcore: registered new interface driver rtl8192cu
[ 6641.872716] ieee80211 phy0: Selected rate control algorithm 'rtl_rc'
[ 6641.874212] rtlwifi: wireless switch is on
[ 6641.901717] rtl8192cu driver version=v4.0.2_9000.20130911
[ 6641.901746] Error: Driver 'rtl8192cu' is already registered, aborting...
[ 6642.110495] systemd-udevd[1176]: renamed network interface wlan0 to wlan1

lsmod
-----

Module                  Size  Used by
rtlwifi                46169  0
rtl8192c_common        33409  0
mac80211              366795  2 rtlwifi,rtl8192c_common
8192cu                520853  0
8189es                896688  0

lsusb
-----

Bus 002 Device 012: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]

 

/etc/udev/rules.d/70-persistent-net.rules

--------------------------------------------------

 

# USB device 0x:0x (rtl8192cu)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:e0:4c:81:92:de", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"

# USB device 0x:0x (rtl8192cu)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="80:1f:02:84:da:34", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan1"
 

==============================================
 

The same dongle works flawlessly in the latest Openelec-build from orangepi.org.

 

It would be very helpful to have working wifi with proven reliable USB-dongles. Ethernet works fine in armbian5.05 with speeds of 94Mbs.

 

Will wifi be available in legacy or will we have to wait for 4.x ?

 

Thanks for the good work, OrangePiOne is starting to look like a real contender !

Share this post


Link to post
Share on other sites

Images for H3 Oranges are in pre-release state and poorly working wireless is a known issue. We haven't touch it yet. There are a lot of open issues - welcome to step in.

Share this post


Link to post
Share on other sites

@igor

Thanks for the info and keep up the good work. I'll try to contribute in areas I'm knowledgeable about, mainly testing, documenting and high level use cases.

Igor likes this

Share this post


Link to post
Share on other sites

 

Headers are present on the system, don't download anything especially not some generic.

cd /usr/src/linux-headers-3.4.110-sun8i/
make scripts # this you will skip in the future when we fix the building process
cd
git clone https://github.com/pvaret/rtl8192cu-fixes
cd rtl8192cu-fixes
make ARCH=arm
# when done
insmod 8192cu.ko
# dmesg
usbcore: registered new interface driver rtl8192cu

 

 

Common Edimax dongle EW-7811UN is now fully working by following Igor's procedure for Armbian-5.05.. Thanks !  After configuring wlan0 and testing the connection I disabled old / enabled new WIFI driver

/etc/modules-load.d/modules.conf

#----------disable standard Armbian driver
# 8189es
#----------enable fixed WIFI driver for EDIMAX EW-7811UN
8192cu

The board now reliably starts up and connects to configured wireless network. Performance is adequate in a noisy busy environment, iperf reaches 87 mbps.

 

Problem SOLVED !

Igor likes this

Share this post


Link to post
Share on other sites

Hello!

I am quite new in linux and may be my question is very simple :)

after I did all procedures for Armbian-5.05 above wi-fi seems working (not stable) but if I boot the Orange PI PC without ethernet cable connected wi-fi interface not connecting to router automaticly

wi-fi is working if only eth0 is up. I dont understand how interfaces connected. pls help me

Share this post


Link to post
Share on other sites

Hello!

I am quite new in linux and may be my question is very simple :)

after I did all procedures for Armbian-5.05 above wi-fi seems working (not stable) but if I boot the Orange PI PC without ethernet cable connected wi-fi interface not connecting to router automaticly

wi-fi is working if only eth0 is up. I dont understand how interfaces connected. pls help me

 

With default Debian simple networking config it's not possible to achieve this. Probably the simplest way is to use some other network manager which is also more user friendly, but we don't use it because it has some other limitations and bugs. 

 

However, to achieve only wlan0 connectivity you simply comment out eth0 in your /etc/network/interfaces and reboot into wireless only connection. I assume you already set it up properly - so you have a working wlan0 configuration ... 

 

Edit: Check this topic.

Share this post


Link to post
Share on other sites

An additional step improves performance of module 8192cu ( Proven Edimax EW-7811UN as well as  $1.60 China-crapdongles from Aliexpress )

 

nano /etc/modprobe.d/8192cu.conf

options 8192cu rtw_power_mgnt=0 rtw_enusbss=0

This stops erroneous power management ( dmesg flooded with attempted power switches ). After network reload/restart you get about up to 90mbps from EW-7811UN and gain much stability with the ChinaWifi-crapdongle at up to 60-70mbps, performances measured with iperf ( 4m open space from access point ). Before correction, values were at 12mbps for ChinaWifi. Edimax performs way better than the cheap dongles, but with the options set they are quite useful too . AP mode is not solved yet, might have to wait for saner drivers in mainline.

Share this post


Link to post
Share on other sites

i try but fail .

so in order to connect wifi router on air , i used  repeater , this was simple and saved usb port .

so ifconfig -> eth0 only  , namely no wlan .  

Share this post


Link to post
Share on other sites

i managed to understand what rodolfo said at Posted 31 March 2016 - 10:10 PM .

 

 two more steps  is needed .

 

1) at terminal , wpa_passphrase MyPlace  7082446

 

this gives next info .

 wpa_passphrase MyPlace  7082446
network={
    ssid="MyPlace"
    #psk="7082446"
    psk=06d6f60771f44b0369f226c0ed4757cdc8939a2f3db
}
 

 

2)by using this info , rewrite /etc/network/interfaces

 

auto wlan0
    iface wlan0 inet dhcp
    wpa-ssid MyPlace
    wpa-psk 06d6f60771f44b0369fb1ed4757cdc8939a2f3db
auto lo
    iface lo inet loopback
 

 

then

ifconfig wlan0
wlan0     Link encap:Ethernet  HWaddr 00:22:cf:ec:c8:05  
          inet addr:192.168.10.220  Bcast:192.168.10.255  Mask:255.255.255.0
          inet6 addr: fe80::222:cfff:feec:c805/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:340 errors:0 dropped:0 overruns:0 frame:0
          TX packets:281 errors:0 dropped:1 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:42290 (41.2 KiB)  TX bytes:45931 (44.8 KiB)
 

 

splendid!   orange pi PC can fly in the sky .

i heartly thanks for rodolfo .

Igor and rodolfo like this

Share this post


Link to post
Share on other sites

@igor

 

After fresh install of Armbian_5.10 (jessie legacy server) on OPI ONE wireless dongles 8192cu crash kernel. The proven procedure (see previous posts) for Armbian_5.05 does NOT work for Armbian_5.10.

 

Log from failed installation :

 

root@orangepione:~# cd /usr/src/linux-headers-3.4.112-sun8i/
root@orangepione:/usr/src/linux-headers-3.4.112-sun8i# make scripts
scripts/kconfig/conf --silentoldconfig Kconfig
fs/Kconfig:287: can't open file "fs/fs_compat.kconfig"
/usr/src/linux-headers-3.4.112-sun8i/scripts/kconfig/Makefile:33: recipe for target 'silentoldconfig' failed
make[2]: *** [silentoldconfig] Error 1
/usr/src/linux-headers-3.4.112-sun8i/Makefile:493: recipe for target 'silentoldconfig' failed
make[1]: *** [silentoldconfig] Error 2
make: *** No rule to make target 'include/config/auto.conf', needed by 'scripts'.  Stop.
root@orangepione:/usr/src/linux-headers-3.4.112-sun8i# cd
root@orangepione:~# git clone https://github.com/pvaret/rtl8192cu-fixes
Cloning into 'rtl8192cu-fixes'...
remote: Counting objects: 438, done.
remote: Total 438 (delta 0), reused 0 (delta 0), pack-reused 438
Receiving objects: 100% (438/438), 1.80 MiB | 994.00 KiB/s, done.
Resolving deltas: 100% (223/223), done.
Checking connectivity... done.
root@orangepione:~# cd rtl8192cu-fixes
root@orangepione:~/rtl8192cu-fixes# make ARCH=arm
make ARCH=arm CROSS_COMPILE= -C /lib/modules/3.4.112-sun8i/build M=/root/rtl8192cu-fixes  modules
make[1]: Entering directory '/usr/src/linux-headers-3.4.112-sun8i'
  CC [M]  /root/rtl8192cu-fixes/core/rtw_cmd.o
/bin/sh: 1: /usr/src/linux-headers-3.4.112-sun8i/scripts/recordmcount: not found
scripts/Makefile.build:307: recipe for target '/root/rtl8192cu-fixes/core/rtw_cmd.o' failed
make[2]: *** [/root/rtl8192cu-fixes/core/rtw_cmd.o] Error 127
Makefile:1368: recipe for target '_module_/root/rtl8192cu-fixes' failed
make[1]: *** [_module_/root/rtl8192cu-fixes] Error 2
make[1]: Leaving directory '/usr/src/linux-headers-3.4.112-sun8i'
Makefile:584: recipe for target 'modules' failed
make: *** [modules] Error 2

 

Please advise as to how to proceed in Armbian_5.10 to make 8192cu dongles work again . Thanks.

Share this post


Link to post
Share on other sites

@igor

 

Sorry for the noise - I had not realized that 8192cu module is fixed in the meantime. So all that is needed is enabling the module 8192cu . I will test available modes and performance.

 

Thanks for the good job !

Igor likes this

Share this post


Link to post
Share on other sites

Tested working wifi-dongles with OPI ONE and Armbian_5.10

(Load proper module at startup)

nano /etc/modules-load.d/modules.conf

-------
#8189es
8192cu
--------

 

 

1. RTL8188CUS cheap no-name dongle from Aliexpress ( < $2 )

Bus 002 Device 003: ID 0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN Adapter

identified as (rtl8192cu)

performance :    86.8 Mbits/sec

2. RTL8188EU cheap no-name dongle from Aliexpress ( < $2 )

Bus 001 Device 009: ID 0bda:0179 Realtek Semiconductor Corp. ( noname identified as 8188EU )

identified as (rtl8188eu)

performance :    86.1 Mbits/sec

 

3. RTL8188CUS Edimax EW-7811Un high quality dongle ( $10 )

 

 

Bus 001 Device 008: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]

identified as (rtl8192cu)

performance :    82.9 Mbits/sec

 

 

Remarkably all three dongles perform well in a not too noisy environment. The Edimax dongle is far superior when there is interference ( yes - we all sit in a giant microwave oven )

 

AP mode could not be tested yet. iw list does not return any result with the driver.

Share this post


Link to post
Share on other sites

@igor

 

Sorry for the noise - I had not realized that 8192cu module is fixed in the meantime. So all that is needed is enabling the module 8192cu . I will test available modes and performance.

 

Thanks for the good job !

 

Hey rodolfo,

 

can you please tell me what steps are needed to get those wifi dongles to work? I was able to get them to work on 5.05 but not on 5.10.

Thanks in advance!

 

@ Igor & the armbian team

Thank you for this great OS! You made a great job!

Igor likes this

Share this post


Link to post
Share on other sites

@Chillman

 

For Armbian_5.05 you had to compile a patched version of module 8192cu. This is no longer needed, the module 8192cu is already compiled and ready to use. In order to load it at startup :

 

nano /etc/modules-load.d/modules.conf

 

(change)
-------
#8189es
8192cu
--------

 

configure your network as you did with Armbian_5.05 and you are set to go.

 

Enjoy !

Share this post


Link to post
Share on other sites

try

make m=scripts

We changed to other kernel source in last build. It should be better / more recent.

These instructions do not work. when I enter this command I get the following error

 

 

 

scripts/kconfig/conf --silentoldconfig Kconfig
fs/Kconfig:287: can't open file "fs/fs_compat.kconfig"
/usr/src/linux-headers-3.4.112-sun8i/scripts/kconfig/Makefile:33: recipe for target 'silentoldconfig' failed
make[2]: *** [silentoldconfig] Error 1
/usr/src/linux-headers-3.4.112-sun8i/Makefile:493: recipe for target 'silentoldconfig' failed
make[1]: *** [silentoldconfig] Error 2
make: *** No rule to make target 'include/config/auto.conf', needed by 'include/config/kernel.release'.  Stop.

Share this post


Link to post
Share on other sites

 

These instructions do not work. when I enter this command I get the following error

 

 

 

scripts/kconfig/conf --silentoldconfig Kconfig
fs/Kconfig:287: can't open file "fs/fs_compat.kconfig"
/usr/src/linux-headers-3.4.112-sun8i/scripts/kconfig/Makefile:33: recipe for target 'silentoldconfig' failed
make[2]: *** [silentoldconfig] Error 1
/usr/src/linux-headers-3.4.112-sun8i/Makefile:493: recipe for target 'silentoldconfig' failed
make[1]: *** [silentoldconfig] Error 2
make: *** No rule to make target 'include/config/auto.conf', needed by 'include/config/kernel.release'.  Stop.

 

 

 

I removed 

source "fs/fs_compat.kconfig"

 from /usr/src/linux-headers-3.4.112-sun8i/fs/Kconfig  and then I was able to run make scripts on Armbian 5.10

 

aka

sed -i '287d;' /usr/src/linux-headers-3.4.112-sun8i/fs/Kconfig 

make scripts

i was able to get the module built afterwards.. whether or not i get it to work with my wifi adapter is another story

 

update:

 

wifi seems to be alive now...  i went back to /usr/src and did

sudo cp ./rtl8192cu-fixes/blacklist-native-rtl8192.conf /etc/modprobe.d/
sudo cp ./rtl8192cu-fixes/8192cu-disable-power-management.conf /etc/modprobe.d/

rebooted then re-inserted the wifi

Share this post


Link to post
Share on other sites

Hello everyone

I am a proud new owner of an orange pi pc. I am new here and very grateful for your work

on armbian which makes the board usable. So I sent a small bitcoin donation yesterday.

Now, I am undertaking the first steps with armbian, using the new 5.1 version,
trying to use wifi with 8189cu driver using one of those dongles:
 

Dongle 1: china , lsusb:

Bus 004 Device 003: ID 0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN Adapter B

or alternatively dongle 2, a well known Edimax 7811un, lsusb:

Bus 004 Device 002: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]

both dongles worki well in raspi 2. When one of them is inserted in third boot,
armbian will automatically load rtl8192 module, which does not produce a wlan interface.

So according to rodolphos post #18 in this thread I have changed /etc/modules commenting out
#8189es and inserting 8192cu at the top. I reckon this is not the same as rtl8192.

now a wlan0 device shows up when entering "ifconfig".

iwlist wlan0 then shows visible networks, like in this extract:

          Cell 03 - Address: 26:65:11:FA:EB:10
                    ESSID:"Gast"
                    Protocol:IEEE 802.11bgn
                    Mode:Master
                    Frequency:2.462 GHz (Channel 11)
                    Encryption key:on
                    Bit Rates:300 Mb/s
                    Extra:wpa_ie=dd160050f20101000050f20201000050f20201000050f202
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (1) : TKIP
                        Authentication Suites (1) : PSK
                    Extra:rsn_ie=30140100000fac020100000fac040100000fac020000
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
                    IE: Unknown: DD6F0050F204104A0001101044000102103B00010310470010BAE2343E91CE490C1609EB8F5005378E1021000341564D1023000446426F78102400043030303010420004303030301054000800060050F20400011011000446426F78100800022388103C0001031049000600372A000120
                    Quality=96/100  Signal level=51/100  


innocent networks removed for protection.
Using wpa_passphrase I have created this gast.conf for wpa_supplicant.

network={
	ssid="Gast"
	psk=1a97bf36071e3e957e4c68cd530c56d2e328a4fcde5540c18a103477c7cc23e5
}


when now entering wpa_supplicant -B -iwlan0 -c gast.conf -d
the driver cannot be opened and the response is like this:
 

wpa_supplicant v2.3
random: Trying to read entropy from /dev/random
Successfully initialized wpa_supplicant
Initializing interface 'wlan0' conf 'gast.conf' driver 'default' ctrl_interface 'N/A' bridge 'N/A'
Configuration file 'gast.conf' -> '/root/gast.conf'
Reading configuration file '/root/gast.conf'
Priority group 0
   id=0 ssid='Gast'
nl80211: Could not add multicast membership for vendor events: -2 (No such file or directory)
nl80211: Remove monitor interface: refcount=0
netlink: Operstate: ifindex=4 linkmode=0 (kernel-control), operstate=6 (IF_OPER_UP)
nl80211: Set mode ifindex 4 iftype 2 (STATION)
nl80211: Failed to set interface 4 to mode 2: -19 (No such device)
wlan0: Failed to initialize driver interface
Failed to add interface wlan0
wlan0: Cancelling scan request
wlan0: Cancelling authentication timeout

So this is it. Of course I also tried "desktop" image with wicd automatic configuration which fails the same, but does not show any debug info.

I would be thankful for any tips!

 

best,

gnasch

Share this post


Link to post
Share on other sites

@gnasch

 

Obviously your network dongles are recognized. Try the following steps :

 

nano /etc/wpa_supplicant/wpa_supplicant.conf

-----------------------------------------------------------

 

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
        ssid="Gast"
        psk=1a97bf36071e3e957e4c68cd530c56d2e328a4fcde5540c18a103477c7cc23e5
        key_mgmt=WPA-PSK
}
 

nano /etc/network/interfaces

--------------------------------------

allow-hotplug wlan0
   iface wlan0 inet dhcp

        wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
 

 

>>>>>There may be hotplugging junk left from previous attempts

 

nano /etc/udev/rules.d/70-persistent-net.rules

------------------------------------------------------------

(clear out all wlan entries)

 

restart and enjoy !

Share this post


Link to post
Share on other sites

@Chillman

 

For Armbian_5.05 you had to compile a patched version of module 8192cu. This is no longer needed, the module 8192cu is already compiled and ready to use. In order to load it at startup :

 

nano /etc/modules-load.d/modules.conf

 

(change)

-------

#8189es

8192cu

--------

 

configure your network as you did with Armbian_5.05 and you are set to go.

 

Enjoy !

 

@rodolfo:

My biggest thanks to you! I had read this in the thread before but adding the right and commenting out the wrong module in this file was not enough to configure the network via wicd in my case (wicd's error notification: bad password).

Thanks to your comment #22 I did the configuration myself and it worked immediately!

 

I've written a short tutorial in the German Orange Pi Forum, I hope that's ok for you (credits to this thread are in there, of course!).

 

Have a nice weekend!

rodolfo likes this

Share this post


Link to post
Share on other sites

I'm at the end of my rope trying to get this to work with 5.1

Original wifi module that worked with 5.05

lsusb:
ID 0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN Adapter

Tried

nano /etc/modules-load.d/modules.conf

#8189es
8192cu

I get this in my dmesg

Error: Driver 'rtl8192cu' is already registered, aborting...

and lsmod gives:

Module                  Size  Used by
rtlwifi                46157  0
rtl8192c_common        33398  0
mac80211              363732  2 rtlwifi,rtl8192c_common
8192cu                627893  0

iwconfig shows the device just fine.  After 2 days, I thought it was the cheap dongle, so I went and purchased the recommended one and still it doesn't work

lsusb:
ID 20f4:648b TRENDnet TEW-648UBM 802.11n 150Mbps Micro Wireless N Adapter [Realtek RTL8188CUS]

I've tried blacklisting the driver, which causes nothing to work (as expected).  I've tried everything in Post #22 and still nothing.

 

HELP!!

 

Some additional information:

started over with a fresh image, enabled 8192cu in modules.conf (disabled 8189es) and made no other changes to any files.  lsmod shows 8192cu as the only driver loaded.  Insert TRENDnet device and here is the dmesg output

[    4.938536] rtl8192cu driver version=v4.0.2_9000.20130911
[    4.938692] usbcore: registered new interface driver rtl8192cu
 
... (Insert dongle)
 
[  247.013492] ehci_irq: highspeed device connect
....
[  247.434416] USB_SPEED_HIGH
[  247.434489] CHIP TYPE: RTL8188C_8192C
[  247.434567] register rtw_netdev_ops to netdev_ops
[  247.434807] Chip Version ID: VERSION_NORMAL_TSMC_CHIP_88C.
[  247.434840] RF_Type is 3!!
[  247.435279] EEPROM type is E-FUSE
[  247.435306] ====> ReadAdapterInfo8192C
[  247.435534] Boot from EFUSE, Autoload OK !
[  247.588284] EEPROMVID = 0x20f4
[  247.588308] EEPROMPID = 0x648b
[  247.588323] EEPROMCustomerID : 0x00
[  247.588339] EEPROMSubCustomerID: 0x00
[  247.588354] RT_CustomerID: 0x00
[  247.588379] _ReadMACAddress MAC Address from EFUSE = xx:xx:xx:x:xx:xx
[  247.588405] EEPROMRegulatory = 0x0
[  247.588421] _ReadBoardType(0)
[  247.588437] BT Coexistance = disable
[  247.588455] mlmepriv.ChannelPlan = 0x00
[  247.588476] _ReadPSSetting...bHWPwrPindetect(0)-bHWPowerdown(0) ,bSupportRemoteWakeup(0)
[  247.588502] ### PS params=>  power_mgnt(1),usbss_enable(0) ###
[  247.588522] ### AntDivCfg(0)
[  247.588538] readAdapterInfo_8192CU(): REPLACEMENT = 1
[  247.588560] <==== ReadAdapterInfo8192C in 150 ms
[  247.589898] rtw_macaddr_cfg MAC Address  = d8:eb:97:30:df:a3
[  247.589931] bDriverStopped:1, bSurpriseRemoved:0, bup:0, hw_init_completed:0
[  247.592351] _rtw_drv_register_netdev, MAC Address (if1) = xx:xx:xx:xx:xx:xx
[  247.719356] Error: Driver 'rtl8192cu' is already registered, aborting...

Share this post


Link to post
Share on other sites

If I blacklist rtl8192cu, lsmod shows

 

Module                  Size  Used by
8192cu                627893  0

 

and dmesg has

 

root@orangepipc:~# dmesg | grep rtl
[    4.698692] rtl8192cu driver version=v4.0.2_9000.20130911
[    4.836033] usbcore: registered new interface driver rtl8192cu

Share this post


Link to post
Share on other sites

@Pride: no need to blacklist, what does iwlist wlan0 show?

 

gnasch

This is frustrating.  I just woke up, turned it on, and now it is working correctly with the TRENDnet dongle.  No changes from last night.  arghhh

 

iwlist wlan0 scanning showed the router on both dongles.  I'm not sure what changed, but I will cycle this through some shutdowns and reboots to see if it sticks.

Share this post


Link to post
Share on other sites

This is frustrating.  I just woke up, turned it on, and now it is working correctly with the TRENDnet dongle.  No changes from last night.  arghhh

 

iwlist wlan0 scanning showed the router on both dongles.  I'm not sure what changed, but I will cycle this through some shutdowns and reboots to see if it sticks.

 

Have similar trouble. 

lsusb
Bus 001 Device 002: ID 0bda:8179 Realtek Semiconductor Corp.
root@orangepione:~# lsmod
Module                  Size  Used by
8188eu                911607  0
8192cu                627893  0

Build module 8192cu by manual from #20 post http://forum.armbian.com/index.php/topic/749-orange-pi-pc-wireless-module-8192cu/#entry8860

nano /etc/modules-load.d/modules.conf (change)

#8189es

8192cu

 

dmesg show error: 

[   64.785939] ehci_irq: highspeed device connect
[   65.020127] usb 1-1: new high-speed USB device number 2 using sunxi-ehci
[   65.277512] RTL871X: module init start
[   65.277531] RTL871X: rtl8188eu v4.3.0.6_12167.20140828
[   65.277541] RTL871X: build time: Apr 30 2016 19:47:19
[   65.277559] sw_usb_enable_hcd: usbc_num = 5
[   65.277567] [rf_pm]: regulator on.
[   65.287586] WRN:L148(drivers/usb/sunxi_usb/manager/usb_hcd_servers.c):ERR: unkown usbc_no(5)
[   65.292669] bFWReady == _FALSE call reset 8051...
[   65.327362] RTL871X: MAC Address from Efuse is 40:a5:ef:0f:fa:75
[   65.337542] RTL871X: rtw_ndev_init(wlan0)
[   65.338976] RTL871X: rtw_ndev_init(wlan1)
[   65.340305] usbcore: registered new interface driver rtl8188eu
[   65.340321] RTL871X: module init ret=0

And i have two not working  wlan in list 

root@orangepione:~# iwconfig
lo        no wireless extensions.
tunl0     no wireless extensions.
wlan1     unassociated  Nickname:"<WIFI@REALTEK>"
          Mode:Managed  Frequency=2.412 GHz  Access Point: Not-Associated
          Sensitivity:0/0
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

wlan0     unassociated  Nickname:"<WIFI@REALTEK>"
          Mode:Managed  Frequency=2.412 GHz  Access Point: Not-Associated
          Sensitivity:0/0
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
Need any help from community 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

1 1

  • Support the project

    We need your help to stay focused on the project.

    Choose the amount and currency you would like to donate in below.