hanguofu

Members
  • Content Count

    25
  • Joined

  • Last visited

 Content Type 

Forums

Member Map

Store

Crowdfunding

Raffles

Applications

Calendar

Everything posted by hanguofu

  1. I didnot find a driver for MT7668RSN at armbian Armbian_20.02.0-rc1.038_Aml-s9xxx_eoan_current_5.5.0-rc6_desktop_20200205 . There is little info. about this chip on Internet either . But it works at the orignal android with kernel 3.14. Will it be avail. at the coming new armbian release ? Regards ! Guofu Han P.S. if this is not the right place to post it , please help me to move it . Thanks !
  2. I installed armbian_eoan_desktop_5.5 on my set-top box and updated mesa to 20.1-devl . But I found out the Xfce4 desktop is a little bit larger than my TV screen . I checked the Application->setting->display and used xrandr -q to print out the parameters : Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 3840 x 2160 HDMI-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 575mm x 323mm 1920x1080 60.00*+ 60.00 50.00 59.94 24.00 23.98 1920x1080i 60.00 50.00 59.94 1680x1050 59.88 1280x1024 60.02 1280x960 60.00 1360x768 60.02 1280x800 59.91 1280x720 60.00 50.00 59.94 1024x768 60.00 800x600 60.32 56.25 720x576 50.00 720x480 59.94 But I found out nothing . Is this a bug in mesa ?
  3. Thanks for your contribution ! May I apply this update to armbian debian bullseye too ?
  4. Thanks for sharing your knowledge ! I am going to check out the branch linux-5.6.y from https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git . But I had a problem to find out the kernel source version for the 'stable', 'current' and 'dev' builds : when I checked config/sources/families/meson-gxl.conf , I didnot find out the version name . Which patch version ( meson64-current , meson64-dev , meson64-legacy ) should I apply to that branch please ?
  5. Thanks for the tip. I tried to build the latest mesa 20.0.2 on my armbian Eoan with Linux 5.5.0-rc6-aml-s9xxx but failed . After the installation , the keyboard and mouse are very sluggish . Could you please tell me how to build it on armbian ? Regards !
  6. After the firmware installed , I tried mpv with option "vo=gpu gpu-context=drm hwdec=auto" , but it failed to start : [cplayer] v: Waiting for scripts... [ytdl_hook] v: script-opts/ytdl_hook.conf not found. [ytdl_hook] v: lua-settings/ytdl_hook.conf not found. [stats] v: script-opts/stats.conf not found. [stats] v: lua-settings/stats.conf not found. [cplayer] v: Done loading scripts. event: start-file [cplayer] info: Playing: http://www.justfortest.com/videoclip.mp4 [cplayer] v: Running hook: ytdl_hook/on_load [ytdl_hook] v: ytdl:// hook [ytdl_hook] v: not a ytdl:// url [stream_callback] v: Opening http://www.justfortest.com/videoclip.mp4 [demux] v: Trying demuxers for level=normal. [lavf] v: Found 'mov,mp4,m4a,3gp,3g2,mj2' at score=100 size=2048. [ffmpeg/demuxer] v: mov,mp4,m4a,3gp,3g2,mj2: Protocol name not provided, cannot determine if input is local or a network protocol, buffers and access patterns cannot be configured optimally without knowing the protocol [demux] v: Detected file format: mov,mp4,m4a,3gp,3g2,mj2 (libavformat) [cplayer] v: Opening done: http://www.justfortest.com/videoclip.mp4 event: tracks-changed event: tracks-changed [cplayer] v: Running hook: ytdl_hook/on_preloaded [lavf] v: select track 0 [lavf] v: select track 1 [cplayer] info: (+) Video --vid=1 (*) (h264 800x480 25.000fps) [cplayer] info: (+) Audio --aid=1 (*) (aac 2ch 44100Hz) event: metadata-update [vo/gpu/opengl] v: Initializing GPU context 'drm' [vo/gpu] error: VT_GETMODE failed: Inappropriate ioctl for device [vo/gpu/opengl] warn: Failed to set up VT switcher. Terminal switching will be unavailable. [vo/gpu/opengl] v: Initializing KMS [vo/gpu/opengl/kms] v: Connector 32 currently connected to encoder 31 [vo/gpu/opengl/kms] v: Selected Encoder 31 with CRTC 40 [vo/gpu/opengl] v: DRM Atomic support found [vo/gpu/opengl/kms] v: Using default plane 34 for OSD [vo/gpu/opengl/kms] v: Using default plane 37 for video [vo/gpu] v: GBM_FORMAT_ARGB8888 supported by OSD plane. [vo/gpu] v: Creating GBM device [vo/gpu] v: Initializing GBM surface (1920 x 1080) [vo/gpu/opengl] v: Initializing EGL [vo/gpu/opengl] v: EGL_VERSION=1.4 [vo/gpu/opengl] v: EGL_VENDOR=Mesa Project [vo/gpu/opengl] v: EGL_CLIENT_APIS=OpenGL OpenGL_ES [vo/gpu/opengl] v: Trying to create Desktop OpenGL context. [vo/gpu/opengl] v: Attempting to find EGLConfig matching GBM_FORMAT_ARGB8888 [vo/gpu/opengl] v: Found matching EGLConfig for GBM_FORMAT_ARGB8888 [vo/gpu/opengl] v: Initializing EGL surface [vo/gpu] v: GL_VERSION='2.1 Mesa 19.2.1' [vo/gpu] v: Detected desktop OpenGL 2.1. [vo/gpu] v: GL_VENDOR='lima' [vo/gpu] v: GL_RENDERER='Mali450' [vo/gpu] v: GL_SHADING_LANGUAGE_VERSION='1.20' [vo/gpu] v: Loaded extension GL_ARB_map_buffer_range. [vo/gpu] v: Loaded extension GL_ARB_vertex_array_object. [vo/gpu] v: Loaded extension GL_ARB_sync. [vo/gpu] v: Loaded extension GL_ARB_get_program_binary. [vo/gpu] v: Loaded extension GL_ARB_debug_output. [vo/gpu/opengl] v: Preparing framebuffer [vo/gpu] error: Failed to commit ModeSetting atomic request (-13) [vo/gpu/opengl] error: Failed to set CRTC for connector 32: Permission denied [vo/gpu] error: Failed initializing any suitable GPU context! [cplayer] fatal: Error opening/initializing the selected video_out (--vo) device. event: track-switched event: audio-reconfig [lavf] v: deselect track 0 [cplayer] info: Video: no video [ad] v: Codec list: [ad] v: aac - AAC (Advanced Audio Coding) [ad] v: aac_fixed (aac) - AAC (Advanced Audio Coding) [ad] v: Opening decoder aac [ad] v: Requesting 1 threads for decoding. [ad] v: Selected codec: aac (AAC (Advanced Audio Coding)) [af] v: User filter list: [af] v: (empty) event: audio-reconfig event: file-loaded [cplayer] v: Starting playback... [cplayer] v: EOF code: 6 event: audio-reconfig [ad] v: Uninit decoder. event: tracks-changed event: end-file event: idle =============================================================================================================== Do you have any idea on it ? Regards ! Guofu Han
  7. I saw there is some firmware at https://github.com/LibreELEC/meson-firmware/tree/master/meson . Just wonder if any of you has apply it to s905x tv box ? Does it utilize HW video decoder to play video ? Regards ! Guofu Han
  8. Thanks for the tips. Did you mean I should run the script https://packagecloud.io/install/repositories/zhangn1985/mesa/script.deb.sh on Armbian_20.02.0-rc1.037_Aml-s9xxx_buster_current_5.5.0-rc6_desktop_20200205.img ? Could you please shed some light on how to apply the ( which ? ) vdec patches ? Regards !
  9. @ning : Glad to hear that . Could you please tell me how to apply the codec to current mainline armbian OS ? I installed the latest armbian ( Armbian_20.02.0 with eoan desktop ) at my s905x tv box and I would like to try it . Thankyou !
  10. For reason I can't explain here , I had to run a video player at Non-X window OS ( Armbian_5.96_Aml-g12_Ubuntu_bionic_default_5.3.0_server ) at a S905X tv-box. I tried to play a mp4 video ( H.264 + AAC ) at the video player ( mpv ) with drm driver. The quality is just so so. Is there any other driver recommended ? Did Amlogic provide a linux video driver which can hard-decode h.264 ? Regards !
  11. How to enter armbian ? I installed Armbian_5.94_Aml-g12_Ubuntu_bionic_default_5.2.1_20190821 at a corrupted android stb ( s905x , 2g ddr3 , 8g emmc ). The original android system was damaged somehow and it halted during the launch process. But fortunately , its bootloader is good. So I stopped the uboot process when it is going to launch the kernel and installed armbian 5.94 with the autoscr cmd. The armbian system runs smoothly at the u-disc except for the following error messages at its first run : -------------------------------------------------------------------------------------- Enable G12 sound. AMLG12 amixer: Unable to find simple control 'FRDDR_A SRC 1 EN Switch',0 amixer: Unable to find simple control 'FRDDR_A SINK 1 SEL',0 amixer: Unable to find simple control 'FRDDR_B SRC 1 EN Switch',0 amixer: Unable to find simple control 'FRDDR_B SINK 1 SEL',0 amixer: Unable to find simple control 'FRDDR_C SRC 1 EN Switch',0 amixer: Unable to find simple control 'FRDDR_C SINK 1 SEL',0 amixer: Unable to find simple control 'TOHDMITX I2S SRC',0 amixer: Unable to find simple control 'TOHDMITX Switch',0 ------------------------------------------------------------------------------------- But I went on with the installation of armbian to the emmc of the stb and the installation went on smoothly . But it seems I did not clean up the android bootargs properly and the system runs into the recovery ( ? ) section of the original android system ( ? ) . I would like to get rid of the android system completely and play with armbian 5.94 . Could you please shed some light on it ? Enclosed please find the boot log : printenv.txt
  12. What is wrong with my compiled kernel ? I played with the official img : Armbian_5.77_Aml-s905_Ubuntu_bionic_default_5.0.2_20190401.img.xz on my usb stick and everything is good. However , a fter I replaced the original zImage with the one I compiled , there are a lot of failed to start services . The compiled kernel is built in the followin g way : git clone https://github.com/150balbes/Amlogic_s905-kernel.git git checkout 20190319 copy the official kernel config : config-5.0.2-aml-s905 to Amlogic_s905-kernel/.config export ARCH=arm64 export CROSS_COMPILE=/home/hanguofu/gcc-linaro-7.3.1-2018.05-x86_64_aarch64-linux-gnu/bin/aarch64-linux-gnu- and I built the kernel with a make flag : LOCALVERSION="-aml-s905" The compiled kernel has the same size as the zImage at the Armbian_5.77_Aml-s905_Ubuntu_bionic_default_5.0.2_20190401.img.xz However , the compiled kernel is not as good as the oringinal one . The startup process ( running at the USB stick ) shows a lot of failed services but it finally reached the login prompt. Is there sth. wrong with my built process ?
  13. Where is /boot/uInitrd ? I tried to build a specific version 5.77 myself . So I checked out https://github.com/150balbes/Build-Armbian and reset the header ( commit ) to f4dfe5f4bcfd261b10954504bc1be0f7537ddb69 ( the one dated 20190323 ) However , the generated img. does not has the uInitrd : ( excerpt from build log ) sent 350.16M bytes received 262.89K bytes 77.87M bytes/sec total size is 355.44M speedup is 1.01 [ .... ] Copying files to /boot directory symlink has no referent: "/home/hanguofu/build_armbian_577/Build-Armbian/.tmp/rootfs-default-aml-s905-bionic-no/boot/uInitrd" 54.52M 100% 302.10MB/s 0:00:00 (xfr#78, to-chk=0/82) The file list at /boot : Mode LastWriteTime Length Name ---- ------------- ------ ---- d----- 2019/6/6 14:34 .Thumbnail d----- 2019/6/6 14:34 Android d----- 2019/6/6 14:34 dtb d----- 2019/6/6 14:34 dtb-5.0.2-aml-s905 d----- 2019/6/6 14:34 extlinux d----- 2019/6/6 13:10 LOST.DIR -a---- 2019/6/1 16:00 829 aml_autoscript -a---- 2019/6/1 16:00 757 aml_autoscript.cmd -a---- 2019/6/1 16:00 651 aml_autoscript.zip -a---- 2019/6/1 16:00 1536 armbian_first_run.txt.template -a---- 2019/6/1 16:00 4882 boot-desktop.png -a---- 2019/6/1 16:00 38518 boot.bmp -a---- 2019/6/1 15:56 160374 config-5.0.2-aml-s905 -a---- 2019/6/1 16:00 521 emmc_autoscript -a---- 2019/6/1 16:00 449 emmc_autoscript.cmd -a---- 2019/6/1 16:01 7658731 initrd.img-5.0.2-aml-s905 -a---- 2019/6/1 16:00 901632 s905x-uboot.img -a---- 2019/6/1 16:00 1765 s905_autoscript -a---- 2019/6/1 16:00 1693 s905_autoscript.cmd -a---- 2019/6/1 15:56 4029826 System.map-5.0.2-aml-s905 -a---- 2019/6/1 16:00 215 uEnv.ini -a---- 2019/6/1 15:56 20090888 vmlinuz-5.0.2-aml-s905 -a---- 2019/6/1 15:56 20090888 zImage Is there sth. I missed ? Should I delete anything and rebuild the img. again ? Regards ! Guofu Han
  14. Thanks for the tip. The point is : I would like to make change to the U-boot ( /home/hanguofu/Build-Armbian/cache/sources/u-boot-aml-s9xxx) instead of kernel ( /home/hanguofu/Build-Armbian/cache/sources/LINUX_DEFAULT/20180925 ). How to tell the tool to patch U-boot instead of the kernel please ? I didnot find out such an option or compile switch.
  15. I run Armbian tool ( checked out from https://github.com/150balbes/Build-Armbian )with command ./compile.sh CREATE_PATCHES="yes" , but only see the request for patch the kernel : [ warn ] Make your changes in this directory: [ /home/hanguofu/Build-Armbian/cache/sources/LINUX_DEFAULT/20180925 ] [ warn ] Press <Enter> after you are done [ waiting ] I would like to patch the U-boot ( u-boot-aml-s9xxx ) instead of kernel . Should I manually add the patch to the userpatches/u-boot directory for my aml-s9xxx board ?
  16. I installed Armbian_5.60_Aml-s9xxx_Ubuntu_xenial_default_4.18.7 to the EMMC of my s905x TV Box , so far so good . Yesterday I trimmed some drivers and built the kernel successfully . The following packages are generated with armbian build tool : linux-dtb-aml-s9xxx_5.60_arm64.deb linux-headers-aml-s9xxx_5.60_arm64.deb linux-libc-dev-aml-s9xxx_5.60_arm64.deb linux-image-aml-s9xxx_5.60_arm64.deb linux-source-default-aml-s9xxx_5.60_all.deb I am going to ssh into my box and run "dpkg -i " commands to update kernel . Is it safe to do so while Armbian is running ?
  17. I put the img. Armbian_5.59_Aml-s9xxx_Ubuntu_xenial_default_4.18.0_20180823.img into a usb disc. and boot it successfully with my TV box. I havenot flashed the emmc yet . Another word , I played with Armbian installed at the U-disc. However , when I tried to upload/download files to/from the box with tool "Xftp 5" ( from NetSarang ) , the tool failed to connected to the box. The box and my pc are in the same local network ( 192.168.0.xxx ) Of course , the ssh service is good and I can log into the box with tool "Xshell 5". Is the ftp service not avail. at the img. ?
  18. I am trying to build 150balbes/Build-Armbian at my Ubuntu18 PC . However , the download process of toolchains are very slow. I had already spent most of the day in it. Unfortunatly , some of the toolchains was downloaded with warnings : [ warn ] Verification failed Could you please tell me the list of all needed toolchains and its source ? I will try to downlaod them in another way. Thanks ! Guofu Han
  19. Since there is a well-known security issue at s905(x) SOCs : https://fredericb.info/2016/10/amlogic-s905-soc-bypassing-not-so.html Is it possible to disable serial console at s905 u-boot ? Does the setting at device tree apply to kernel only or both kernel and u-boot drivers ? Regards ! Guofu Han
  20. I am referring to s905(x) series SOCs. Is it possible to create a cryptpasswd at encrypted OTP and use it to unlock root file system on boot ? If not , is it possible to use a security chipset such as ATSHA204 / DX81C04 / ZW30I8 / SMEC98SP to feed s905(x) the key ? Regards ! GuoFu Han
  21. Yes . You are right . I did not notice s905x is a 64-bit SOC. Cheer ~~~
  22. arch ( ARM or ARM64 ) problem : Hi , All : I installed Armbian_5.41.1_S9xxx_Ubuntu_xenial_3.14.29_mate_20180421.img at the SD card for my s905x TV box and it seems O.K. Now I tried to cross compile an application at my Ubuntu PC for this lovely device. The first problem I encountered is the choice of arch. I worked out a 32-bit arm application ( target arch : ARM) with the cross compile tool . The generated binary is : hello-world : ELF 32-bit LSB executable, ARM, EABI5 version 1 (SYSV), dynamically linked, interpreter /lib/ld-linux-armhf.so.3, for GNU/Linux 3.2.0, not stripped Unfortunately , I did not find the needed interpreter at the tv box . The only interpreter I found at the img at the SD card is : /lib/ld-linux-aarch64.so.1 -> aarch64-linux-gnu/ld-2.23.so Does it mean that the img is for ARM64 arch ? Is there a ld-linux-armhf interpreter at the image ?
  23. Yes . You got it . I only have a traditional tv set with cvbs ( composite or AV ) input and a computer monitor with VGA input.
  24. Sorry for my question if it had been asked : is there any Ubuntu img available for MXQ PRO+ 4K ( s905x , 2G/16G ) with cvbs compatibility ? I donot have a hdmi monitor and I would like to try Ubuntu on my tv box. I tried multi-boot with Armbian_5.44_S9xxx_Ubuntu_xenial_3.14.29_server_20180515.img at my sd card , but there is no av ( cvbs ) output at all. I am not sure if the dtb.img is suitable for my tv box ( I tried several dtb files ) or the armbian Ubuntu img does not support cvsb output at all ?
  25. I think webrtc is a very interesting feature for such devices. Unfortunately , I only saw a drive ( UV4L : https://www.raspberrypi.org/forums/viewtopic.php?f=43&t=105019) for Raspberry Pi2/Pi3 in linux. Does somebody here have any idea to cross-compile native webrtc source code for such a device ? Regards ! GuoFu Han