Jump to content

Search the Community

Showing results for tags 'nanopik2-s905'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Community
    • Announcements
    • Feature Requests
  • Using Armbian
    • Beginners
    • Software, Applications, Userspace
    • Advanced users - Development
  • Upcoming Hardware (WIP)
    • News
    • Odroid M1
    • ROCK 5B
  • Maintained Hardware
    • Board does not start
    • Amlogic meson
    • Allwinner sunxi
    • Marvell mvebu
    • Rockchip
    • Other families
  • Unmaintained (CSC/EOL/TVB) / Other
    • TV boxes
    • Off-topic
    • Amlogic meson
    • Allwinner sunxi
    • Marvell mvebu
    • Rockchip
    • Other families

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Matrix


Mastodon


IRC


Website URL


XMPP/Jabber


Skype


Github


Discord


Location


Interests

Found 15 results

  1. Hi Folks, did anybody got a working Armbian image for the Nanopi-K2 EMMC version. The SD Version works great, I'm looking for an EMMC version, or a tutorial on how to convert the SD version into an EMMC Version. I know that there is an EMMC OÌmage at NanoPi Download page, BUT with this version none of the 4 USB Ports is working, and the Kernel is 3.14. and cannot be updated anymore. many thanks for any hint PS: I also try to contact nanopi support but I never get any response from them. wikrie
  2. Like Le Potato, status of support. Unlike Le Potato, WIP board without official support, 90% of this is incidental to improved mainline support/easy adaptation of fixes for other boards. Current next image kernel: 4.14 Dec. 14 2017: Functions working for me (N=1 sample size) WiFi functioned for me out of the box. HDMI (I added this functionality some time ago) HDMI Sound (Added as of 1:45 Dec.14, not part of any image/build yet) USB Ethernet (no long-term stability testing yet) Jan. 24 2018: small bugfix Board now reports 2 GB RAM instead of 1 July 8, 2018: "Next" kernel (4.17) bugfix HDMI audio repaired (in build system, images not built yet) DVFS better, but still throwing errors [BUG] No USB on K2.
  3. as described in: https://gitlab.freedesktop.org/mesa/mesa/issues/2377 it's possible to use meson HW video codec now, but in the URL, not very clear, does any one know how to use it?
  4. Hi, I recently installed a fresh Armbian and did some tests. I noticed two major problems: Video is not accelerated: it is absolutely unusable with kodi Bluetooth seems absent (missing from DTB? other reason?) Please find below execution outputs of some commands: root@nanopik2-s905:~$ cat /etc/armbian-release # PLEASE DO NOT EDIT THIS FILE BOARD=nanopik2-s905 BOARD_NAME="NanoPi K2" BOARDFAMILY=meson-gxbb BUILD_REPOSITORY_URL=https://github.com/armbian/build BUILD_REPOSITORY_COMMIT=b9814056 DISTRIBUTION_CODENAME=focal DISTRIBUTION_STATUS=supported VERSION=20.11.3 LINUXFAMILY=meson64 BRANCH=current ARCH=arm64 IMAGE_TYPE=stable BOARD_TYPE=conf INITRD_ARCH=arm64 KERNEL_IMAGE_TYPE=Image root@nanopik2-s905:~$ root@nanopik2-s905:~$ hciconfig root@nanopik2-s905:~$ root@nanopik2-s905:~$ rfkill list 0: phy0: Wireless LAN Soft blocked: no Hard blocked: no root@nanopik2-s905:~$ Is there any people with same problem on their boards? Any idea on how to fix bluetooth feature? I read all 7 pages but I did not find anything useful to solve my problem. Another information, I boot original image from friendlyarm and bluetooth is up and running so my board is physically good.
  5. My NanoPiK2 is installed with Armbian Focal desktop system. When I used it normally for a day, I manually shut it down (closed properly). But when I restarted it, it finally displayed and stayed at [OK] Reached target Host and Network Name Lookups. Unable to enter the system. I tried to insert the SD card into the computer to search for the boot logs, but I couldn’t find it. How do i solve this problem?THANKS
  6. Well, no fancy introduction here, because this doesn't pretend to be a script for the general use, only for testers who want to try the current *very early* status of the media capabilities in the Armbian meson mainline kernel. Warning: It will replace your current kernel with a pre-compiled nightly 4.19.20. Instructions: Download, untar and run. If you need further instructions, then you are not ready for this script (again, it is very unpolished, not for general use). Download link: https://mega.nz/#!YvYUhayC!CI1fl52V4tV0G4oqUib4W-NlMpVSpLDp8kmo74g-V08 Things that you can try with this script, on a X session: Use a 1080p@30fps h264 video, and play it with "mpv -hwdec <filename>". You'll see in the logs that it is decoding through v4l-m2mcopy Install and run glmark2-es2 Use Chromium WebGL Play a 1080p@30fps video in YouTube in full-screen smoothly. I'm pretty sure it is not really using HW decoding as it claims (there is no initialization message in dmesg), but it's smooth for sure. Gstreamer is tested not to work, in some other forum I was told that Bionic version is not enough and I need to compile a newer one. Performance is not in any way good, but it is a starting point. Anyway, the first TO-DO is getting the mali module integrated into the kernel, so there is no need to compile it separately.
  7. How do you enable the UART GPIO serial port (i.e., the one on pins 8 & 10) on a Nano Pi K2? The only active serial port I see from `dmesg | grep serial` is ttyAML0, which I'm assuming is the serial port on the debugging pins. FWIW, I'm using the 4.14.69-meson64 kernel on a Nano Pi K2.
  8. I think it would make sense to rename the forum section here from "Amlogic S905(x)" to "Amlogic". It would make much more sense for me to talk here for example about the Armbian port of the Odroid C0/C1/C1+ (Amlogic S805) then in any other forum section.
  9. Hello, After installing Armbian 5.59 I have problems with sound. When I install the distribution with the 4.14.69 kernel, I have an intermittent sound. When with 4.18.7 sound is missing. How can I fix it? Is it possible to change the kernel? If so, please follow the instructions step by step. greetings trebor
  10. hi dear all i am MS student and want to make my own development board for S905. if i purchase components from market and make a pcb then is it work? any one can answer my question?
  11. Hello everybody! I want setup my nonopi k2 as small home server, but I ran intoproblem with microSD that ruined all my plans. The trouble is that under load such as downloading or unpacking files (about 100M) or even doing 'apt update' can couse I/O errors. In dmesg I see lines like this: [ 309.344144] mmc0: tried to reset card, got error -110 [ 309.344157] print_req_error: I/O error, dev mmcblk0, sector 13022080 [ 309.344169] print_req_error: I/O error, dev mmcblk0, sector 13022088 [ 309.344176] print_req_error: I/O error, dev mmcblk0, sector 13022096 [ 309.344183] print_req_error: I/O error, dev mmcblk0, sector 13022104 [ 309.344190] print_req_error: I/O error, dev mmcblk0, sector 13022112 [ 309.344197] print_req_error: I/O error, dev mmcblk0, sector 13022120 [ 309.344204] print_req_error: I/O error, dev mmcblk0, sector 13022128 [ 309.344211] print_req_error: I/O error, dev mmcblk0, sector 13022136 [ 309.344218] print_req_error: I/O error, dev mmcblk0, sector 13022144 [ 309.344225] print_req_error: I/O error, dev mmcblk0, sector 13022152 [ 309.346208] mmcblk0: error -110 sending status command, retrying [ 309.347117] mmcblk0: error -110 sending status command, retrying [ 309.348024] mmcblk0: error -110 sending status command, aborting [ 309.351791] EXT4-fs warning (device mmcblk0p1): ext4_end_bio:323: I/O error 10 writing to inode 384761 (offset 0 size 4341760 starting block 1628016) [ 309.351802] Buffer I/O error on device mmcblk0p1, logical block 1626736 [ 309.351814] Buffer I/O error on device mmcblk0p1, logical block 1626737 [ 309.351820] Buffer I/O error on device mmcblk0p1, logical block 1626738 [ 309.351825] Buffer I/O error on device mmcblk0p1, logical block 1626739 [ 309.351830] Buffer I/O error on device mmcblk0p1, logical block 1626740 [ 309.351835] Buffer I/O error on device mmcblk0p1, logical block 1626741 [ 309.351840] Buffer I/O error on device mmcblk0p1, logical block 1626742 [ 309.351845] Buffer I/O error on device mmcblk0p1, logical block 1626743 [ 309.351851] Buffer I/O error on device mmcblk0p1, logical block 1626744 [ 309.351856] Buffer I/O error on device mmcblk0p1, logical block 1626745 [ 309.352386] EXT4-fs warning (device mmcblk0p1): ext4_end_bio:323: I/O error 10 writing to inode 384761 (offset[ 309.576236] EXT4-fs error (device mmcblk0p1): ext4_journal_check_start:61: Detected aborted journal [ 309.584404] EXT4-fs (mmcblk0p1): Remounting filesystem read-only 0 size 4341760 starting block 1628272) [ 309.352925] EXT4-fs warning (device mmcblk0p1): ext4_end_bio:323: I/O error 10 writing to inode 384761 (offset 0 size 4341760 starting block 1628528) [ 309.353459] EXT4-fs warning (device mmcblk0p1): ext4_end_bio:323: I/O error 10 writing to inode 384761 (offset 0 size 4341760 starting block 1628784) [ 309.353970] EXT4-fs warning (device mmcblk0p1): ext4_end_bio:323: I/O error 10 writing to inode 384761 (offset 0 size 4341760 starting block 1628820) [ 309.354081] EXT4-fs warning (device mmcblk0p1): ext4_end_bio:323: I/O error 10 writing to inode 384762 (offset 0 size 4358144 starting block 1629076) [ 309.354619] EXT4-fs warning (device mmcblk0p1): ext4_end_bio:323: I/O error 10 writing to inode 384762 (offset 0 size 4358144 starting block 1629332) [ 309.355155] EXT4-fs warning (device mmcblk0p1): ext4_end_bio:323: I/O error 10 writing to inode 384762 (offset 0 size 4358144 starting block 1629588) [ 309.355694] EXT4-fs warning (device mmcblk0p1): ext4_end_bio:323: I/O error 10 writing to inode 384762 (offset 0 size 4358144 starting block 1629844) [ 309.356206] EXT4-fs warning (device mmcblk0p1): ext4_end_bio:323: I/O error 10 writing to inode 384762 (offset 0 size 4358144 starting block 1629884) [ 309.367665] mmc0: card 0001 removed [ 309.570456] Buffer I/O error on dev mmcblk0p1, logical block 135371, lost sync page write [ 309.574990] Aborting journal on device mmcblk0p1-8. [ 309.575014] Buffer I/O error on dev mmcblk0p1, logical block 131072, lost sync page write [ 309.575021] JBD2: Error -5 detected when updating journal superblock for mmcblk0p1-8. [ 309.576224] Buffer I/O error on dev mmcblk0p1, logical block 0, lost sync page write [ 309.576236] EXT4-fs error (device mmcblk0p1): ext4_journal_check_start:61: Detected aborted journal [ 309.584404] EXT4-fs (mmcblk0p1): Remounting filesystem read-only [ 309.590414] EXT4-fs (mmcblk0p1): previous I/O error to superblock detected [ 309.590435] Buffer I/O error on dev mmcblk0p1, logical block 0, lost sync page write I`ve already tried default, next, dev and self-built images, but every-time get the same problem. On default img i also have such messages. But they don`t cause a chash. [ 309.301045] mmcblk0: response CRC error sending r/w cmd command, card status 0xd00 I have no problems with this SD card if I use it with my phone or laptop. Thank you in advance!
  12. Allcon, my pik2 constantly locks up. i havent been able to find anything that causes. going to cut this short before it locks up http://ix.io/1e4Q i have tried SD cards from san disk pny verbatim lexar: no change i have tried different power supplies. the barrel jack under vairous voltages: many different power supplies i cannot find any consistancy.
  13. This was briefly discussed in another topic, but the idea would be to make 4.14 the default kernel for Le Potato and K2, and change next to the newest stable kernel. The reason is, the 4.14 is the vendor kernel for Le Potato, K2 is only supported via it's similarity to C2 and Le Potato, and we currently don't have a "mainline" for Amlogic as everything moves forward. Consequences: Default build it yourself with the 3.14 will no longer be possible. We do not provide images of this build anyway. Next image users will get updated to the newest stable rather than staying on 4.14 This is what needs the discussion. I put a quick post on the Facebook group for Libre Computer I belong to, so far I've gotten half the community having seen the post and nothing but positive feedback on the change proposal. Looking to get any feedback available here. March 30, 2018 Status: Building "Default" image for either Le Potato or K2 will give you 4.14.y with Current BayLibre patches (K2 had other issues due to a board rename some time ago, broke u-boot process and boot script generation) Next still at 4.14.y waiting for 4.16
  14. It seems the Armbian test image for the NanoPi-K2 only works on an SD card. At least mine doesn't seem to boot when I put it on the 8GB eMMC module. Is there an eMMC armbian image for the NanoPi-K2 or is there something I need to do to get the existing image to boot on the eMMC module?
  15. What's happen with my nano pi k2 just boot up and stop here. GXL:BL1:9ac50e:a1974b;FEAT:ADFC318C;POC:3;RCY:0;EMMC:0;READ:0;CHK:AA;SD:0;READ:0;0.0;CHK:0; no sdio debug board detected TE: 194208 BL2 Built : 13:48:56, Sep 23 2016. gxl g7459bd4 - jianxin.pan@droid06 set vcck to 1120 mv set vddee to 1000 mv Board ID = 6 CPU clk: 1200MHz DQS-corr enabled DDR scramble enabled DDR3 chl: Rank0+1 @ 792MHz - PASS Rank0: 1024MB(auto)-2T-11 Rank1: 1024MB(auto)-2T-11 DataBus test pass! AddrBus test pass! Load fip header from SD, src: 0x0000c200, des: 0x01400000, size: 0x00004000 New fip structure! Load bl30 from SD, src: 0x00010200, des: 0x01100000, size: 0x0000d600 Load bl31 from SD, src: 0x00020200, des: 0x10100000, size: 0x00015400 Load bl33 from SD, src: 0x00038200, des: 0x01000000, size: 0x000a3400 NOTICE: BL3-1: v1.0(debug):2e39a99 Is the problem with boot loader or kernel or OS?
×
×
  • Create New...