Audio hardware not recognized with Odroid N2 kernel 5.4


Recommended Posts

Armbianmonitor:

Hi,

 

I am using the Odroid N2, and I have recently switched from the Hardkernel-supplied Ubuntu Mate, to an Armbian version with kernel 5. I was hoping to combine a homemade NAS using CPU accelerated LUKS-encrypted disks with a Kodi mediacenter, and the N2 seems to have excellent properties to do both. 

Installing these Armbian functions immediately fixed a few problems that Hardkernel's Ubuntu had (unstable BTRFS driver, and I also see no sign of the USB3 disconnect problems that Odroid used to have).

 

However, this version has a problem to recognize audio hardware - in the GUI, I am unable to select HDMI audio or analog audio.

 

- For the choice of "Default Server", I see the following options:

  • {3ed2e13b98b344e2be6883689b69143e}unix:/run/user/1000/pulse/native
  • <my own hostname>
  • <an account on a LibreElec box running elsewhere on my LAN>

- For the choice of "Default Sink", I only get "Dummy Output", regardless of the above choice I make

 

For reference:

- Audio on the Hardkernel edition works normally. I can choose analog or HDMI audio, and when I choose HDMI audio, the sound comes out of my monitor speakers.

- The Hardkernel used kernel version 4.9, where I am now using kernel 5.4. I tried both Bionic Desktop with kernel 5.4, and Buster Server with kernel 5.4 where I installed the GUI from armbian-config.

 

Is this a known problem (e.g. with kernel 5.4), and/or is there a way I can troubleshoot this?

Edited by SnijtraM
mention the N2
Link to post
Share on other sites
Armbian is a community driven open source project. Do you like to contribute your code?

39 minutes ago, SnijtraM said:

Is this a known problem


Basic hardware support for Odroid N2 was developed in private kernel 4.9.y and functions are slowly getting to the mainline kernel. Some functions has to be written from scratch, some come in with minor changes, some will never get there ... This situation is normal and expected. Having functionality of development and stability / modernity of modern kernels is rare and expensive luxury.

 

49 minutes ago, SnijtraM said:

I tried both Bionic Desktop with kernel 5.4, and Buster Server with kernel 5.4 where I installed the GUI from armbian-config.


Hardware support is identical in all cases. If it doesn't work under one, it doesn't work elsewhere. Different versions are for applications like OMV which works only with Debian. Some people needs this and that Ubuntu for whatever reasons regardless of hardware support.
 

Link to post
Share on other sites

I have an SD card only, and no eMMC. I see no boot.scr.aw.

Instead I renamed boot.scr to boot.scr.old, and copied boot.scr.mmc to boot.scr.

This time it boots up and all looks fine, except a set of error messages when I switch from GUI to console:

fe.dai-link-0: ASoC: no backend DAIs enabled for fe.dai-link-0

repeated a few dozen times.

Sadly, the audio devices are still not available :(

Link to post
Share on other sites

Try the latest universal version 20200218 (with u-boot added to the SD card). You have followed the instructions from the first message of the topic about universal images to enable audio on G12 (remove pulsaudio and run the script g12_sound.sh) ? By the way, I recommend switching to using the new u-boot for SPIN and running all systems at once with USB 3.0 (this is significantly faster than an SD card and much easier, you don't need card readers on your PC to write and edit settings on your PC).

Link to post
Share on other sites

I made some attempts to boot this image from an SD card (other options are not useful to me), but failed to get it going. I did find the script g12_sound.sh on the slightly older image, after uninstalling pulseaudio and related drivers, the audio controls on the GUI were simply gone, and from a run of Kodi it seems that the system recognizes the analog output only, but even then, when I plug my headphone, it stays completely silent.

I do not have that much time to spend and this new image clearly has quite a bit of technical debt still - it is not solving any problems for me, so I won't be building the all-in-1 setup that I had in mind.

If I were Odroid, I would base myself on N2-specific image, and try to get the remaining drivers integrated in the mainline kernel.

Link to post
Share on other sites

Well, i have read all things i could on forum... Nothings tell me what to do or why there is no sounds on hdmi.

I'm not a coders, juste Odroid N2  user curious about debian system ( i'm on fedora usually )

 

Thanks for reply, i find the armbian-config, set up  the " Linux N2 5.7.15-meson64 #20.08 "... no stereo jack out or hdmi sound for me.

 

Maybe in a 5.8 kernel , we have to wait and listen, i guess.

 

Regards

Link to post
Share on other sites
1 hour ago, 4RK4DI3N said:

I'm not a coders, juste Odroid N2  user curious about debian system ( i'm on fedora usually )


This board works in the best possible way, on Fedora it probably doesn't even boot and will stay that way for a while, unless Fedora has someone that will specially focus on this hardware.

 

1 hour ago, 4RK4DI3N said:

Maybe in a 5.8 kernel , we have to wait and listen, i guess.


We already have everything what is developed. Numbers doesn't mean much. Supporting development matters.

Link to post
Share on other sites

Hello,

 

I know the development is hard things to do, many thanks to you and all developers for all the good works !

 

As much i know, Fedora can run on it. I allready try it on Odroid C2 last year, using ARCH linux procedure.

It ran using a server image ( no X11, no sound, installed Mate-desktop but never find a way to sound... ).

 

There's official image for Fedora32 - 64bits - arm for some SOC , and a general image.

I've read on hard Kernel Forum that Centos image exist too, someone did it ( i didn't test it at this moment ).

 

For me exploring, Debian is a '+' in my computer culture, and help me to stay open to other system.

Supporting is everything, i guess. At my level, i can't do much more to help... And i know saying sound is not working is not help.

 

I am just wondering where is the issue, on my side, on kernel boot side... No offense about the development !

I tryed to install 'odroid-alsa.deb' too but dident work... Now i guess that the sound driver is on 'meson64.dtb' thing.  

 

:)

 

Best regards.

 

 

Link to post
Share on other sites
On 9/3/2020 at 1:17 AM, DeterminedOpier said:

And google won't let you log in with chrome grrr.  

That's a problem on other boards too.
With Firefox you can login to google. But there facebook and google mail don't work right(and this forum).
So I use Vivaldi browser for all that. Youtube, facebook, google mail all work on it. And it plays video pretty well without VPU acceleration.
I think here's the latest version. Only snapshots available, so you can't upgrade.
https://vivaldi.club/d/13006
 

23 hours ago, Salvador Liébana said:

not working neither on kernel 5.8.5 armbian focal. nothing on aplay -l

Also not on Balbes images?
 

Link to post
Share on other sites
On 9/6/2020 at 1:27 AM, Salvador Liébana said:

not working neither on kernel 5.8.5 armbian focal. nothing on aplay -l

I just checked the latest versions of the Focal images with the 5.7.16, 5.8.5, 5.9.0-rc4 kernel on N2, and the HDMI sound works. What versions of images are you trying ?

By the way, on the latest versions of LE-10 with the kernel 5.8.7 + Panfrost + mesa 20.2.0-rc4 , HW Kodi acceleration works on g52\g31.

Link to post
Share on other sites
5 hours ago, N2_user said:

Did we miss something to do ti get soundcard working with hdmi ? 

 

You missed that we already wasted hundreds of hours trying to get audio working - invest your time to study data on links below + many other functions you might personally not need or take as granted. Our next try will be in a couple of months if we will find time within our private time to support this hardware. Since all this is open source community development ... you can fix audio and submit a fix.

If you want to see development progress:
https://docs.armbian.com/Release_Changelog/
https://github.com/armbian/build/commits/master

Link to post
Share on other sites

Ok i understand....

 

But i'm still surprise that  Mr Balbes150 says there is sound in 5.8.x kernels, and you disagree for a couple of months in the futur.

If only i have "The Fix" ... I'll share with you off course, that's the deal and soul  of GNU/linux users, ins't it ?

 

I'm surprise too, about HardKernel people, not sharing the sound HDMI drivers sources.. I understand it in this way, maybe i'm wrong ! 

( i suppose it's a driver issue to integrate with kernel,  maybe it's working  will installing it with an apt install command  ? )

 

Thank you for efforts , times, replies, and informations.

 

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...