Jump to content
  • 0

OrangePi Zero2 - Allwinner H616


Werner
 Share

Question

Before complaining about an issue read this!

 

tl;dr: Put your Zero2 and/or any other H616 based device on the shelf and WAIT for proper support to come. And no. There is no ETA. Assuming usable state end 2021/beginning 2022.

 

Software support is still work in progress and under heavy development. Provided preview images can break any time. Do not report this, we are aware of that and can/will not help you with that if you are not willing to investigate and research by yourself.

Feel free to join fellow developers to their efforts to create proper software support. But don't waste our time with complains. Thank you!

 

https://github.com/apritzel/linux/commits/h616-v5

https://github.com/jernejsk/u-boot/tree/h616-v2

https://github.com/apritzel/arm-trusted-firmware/tree/h616-v2-wip

 

 

-----------------------------------------------------------------------------

 

I started to play with this board and obviously failed miserably creating a basic Armbian integration.

 

Anyway. These are the information I collected so far:

 

dtb extraction from Xulong image: https://pastebin.com/raw/Uni2JzBF

 

orangepimonitor 🙄  http://ix.io/2FM0

 

 

root@orangepizero2:/etc/apt# lsmod
Module                  Size  Used by
zram                   36864  2
sprdwl_ng             438272  0
sprdbt_tty             36864  2
uwe5622_bsp_sdio      294912  2 sprdbt_tty,sprdwl_ng

 

kernel config: https://pastebin.com/raw/e2jTTZ7A

Link to comment
Share on other sites

Recommended Posts

  • 0
1 hour ago, lampra said:

Is anyone skilled enough to write a patch for the DT?


I trade my skills for help on tasks that doesn't require so much skills, but they still require time and attention.
https://forum.armbian.com/forum/54-help-wanted/

 

Currently working on sunxi bump to 5.13.y but since I am on vacations, my wife can interrupt this violently :D;) If time permits, I'll try to fix this, but can't promise.

Link to comment
Share on other sites

Help Armbian team helping you

  • 0
On 7/20/2021 at 6:48 PM, lampra said:

According to apritzel OPI zero2 has - unsupported Allwinner WiFi/BT chip

The firmware of the wifi seems to be available here. The schematics of WiFi/BT are available here

If I understand correctly, we need a pr for the firmware and a patch(overlay?) of the upcoming DT provided by apritzel.

Is anyone skilled enough to write a patch for the DT?

Hi,

 

I'm new to this thing, but I did some digging.

 

There's a possibility that the AW859A is either a rebadged UWE5622, or is compatible with it. There's also a reference to a device, that is SC2355.

 

I only managed to find a little info about the UWE5622, and it might have some connections to Unisoc, a yet another Chinese fabless semiconductor maker, but not sure. You can get a bit more info by googling, including the name of some binary file.

Link to comment
Share on other sites

  • 0

Is there any way to get an image output out from the board currently? I would like to help with testing at least, but currently I don't have a UART cable, only a monitor with an HDMI input, and an old CRT TV (which would be good if it had a reason to stay with me for at least a bit longer, like for testing :) ).

Link to comment
Share on other sites

  • 0
2 hours ago, ZILtoid1991 said:

I don't have a UART cable

Mandatory for proper testing. Everyone who tinkers with SBCs should have such a thing. Also they are dirt cheap.

Link to comment
Share on other sites

  • 0
On 7/24/2021 at 8:36 PM, ZILtoid1991 said:

Hi,

 

I'm new to this thing, but I did some digging.

 

There's a possibility that the AW859A is either a rebadged UWE5622, or is compatible with it. There's also a reference to a device, that is SC2355.

 

I only managed to find a little info about the UWE5622, and it might have some connections to Unisoc, a yet another Chinese fabless semiconductor maker, but not sure. You can get a bit more info by googling, including the name of some binary file.

Here is the Datasheet for AW859A

CDW-20U5622-02_SPECIFICATIONS_20200306(全志专用AW859A).pdf

Link to comment
Share on other sites

  • 0

https://github.com/armbian/build/pull/2620/files

We have more or less fully functional image with legacy kernel, but 5.13.y hangs at:

 

Spoiler
## Executing script at 4fc00000
U-boot loaded from SD
Boot script loaded from mmc
131 bytes read in 2 ms (63.5 KiB/s)
19495 bytes read in 6 ms (3.1 MiB/s)
Failed to load '/boot/dtb/allwinner/overlay/-fixup.scr'
12104617 bytes read in 1001 ms (11.5 MiB/s)
22200328 bytes read in 1835 ms (11.5 MiB/s)
Moving Image from 0x40080000 to 0x40200000, end=41790000
## Loading init Ramdisk from Legacy Image at 4ff00000 ...
   Image Name:   uInitrd
   Image Type:   ARM Linux RAMDisk Image (gzip compressed)
   Data Size:    12104553 Bytes = 11.5 MiB
   Load Address: 00000000
   Entry Point:  00000000
   Verifying Checksum ... OK
## Flattened Device Tree blob at 4fa00000
   Booting using the fdt blob at 0x4fa00000
   Loading Ramdisk to 49474000, end 49fff369 ... OK
   Loading Device Tree to 0000000049406000, end 0000000049473fff ... OK

Starting kernel ...

 

@jernej Do you know latest working combination (atf / u-boot / kernel) ?

Link to comment
Share on other sites

  • 0

Hasn't ATF been mainlined already? Also U-Boot master received necessary changes already IIRC. Linux sources from apritzel are most up-to-date AFAIK with h616-v9 branch or whatever number he is currently working on.

Link to comment
Share on other sites

  • 0
3 hours ago, Werner said:

Hasn't ATF been mainlined already? Also U-Boot master received necessary


Yes, we are attached to mainline ATF and u-boot. Probably kernel is the problem. 

Link to comment
Share on other sites

  • 0
On 8/12/2021 at 6:01 AM, Werner said:

Linux sources from apritzel are most up-to-date AFAIK with h616-v9 branch or whatever number he is currently working on.

Latest versions are actually less featureful because it's easier to merge series if there is less patches and thus more consensus how to do things. I can't tell which is the most featureful branch from the top of my head, probably v6 or v7. Certainly last variant contain no USB support.

Link to comment
Share on other sites

  • 0
On 8/15/2021 at 11:14 PM, Igor said:

I am unable to test if that helps at least by the end of this week.

Tested after changing ATF to mainline master, and it's loading the kernel. Ethernet and usb also working http://ix.io/3woR

To me, it seems that we need to stick to 5.13 (which  includes all the patches) for a while, as the discussion for the mainline support is far from concluded.

Link to comment
Share on other sites

  • 0
3 hours ago, lampra said:

5.13

Yeah, would also not make much sense to backport those to 5.10 since 5.15 will probably be next LTS release and is only a few month ahead and probably will include those patches already.

Link to comment
Share on other sites

  • 0

Hi, I recently received this board and I was able to get the docker started. Maybe someone may find it useful.
After installing via "armbian-confix" if try to start docker service with

$ systemctl start docker

 we get this error: 

● docker.service - Docker Application Container Engine
   Loaded: loaded (/lib/systemd/system/docker.service; enabled; vendor preset: enabled)
   Active: activating (auto-restart) (Result: exit-code) since Tue 2021-08-24 20:09:34 MSK; 26ms ago
     Docs: https://docs.docker.com
  Process: 11947 ExecStart=/usr/bin/dockerd -H fd:// --containerd=/run/containerd/containerd.sock (code=exited, status=1/FAILURE)
 Main PID: 11947 (code=exited, status=1/FAILURE)
dpkg: error handling package docker-ce (--configure):
 installed docker-ce package post-installation script subprocess returned error exit status 1

In "journalctl -xe" we get the following - "Running iptables --wait -t nat -L -n failed with message: `# Warning: iptables-legacy tables present, use iptables-legacy to see them\niptables: Operation not supported.`, error: exit status 1."
And to fix it, you need to use the following command:

$ update-alternatives --set iptables /usr/sbin/iptables-legacy

Then restart the service and docker works.

Link to comment
Share on other sites

  • 0
3 hours ago, mantouboji said:

How long will it take to boot properly?

I expect within a day and eternity or never. You could as well ask a clairvoyant.
This is the only board using this SoC. So not that much development for it. Things are evolving. But no idea if it will ever be a good board for everyone.
So only for the brave for now. I'm also waiting and watching for good news about it. Hardware wise it's an ok board. But not worth buying.

Link to comment
Share on other sites

  • 0
7 minutes ago, mantouboji said:

I tried,can't pass build

This is what I did here

ATFSOURCE='https://github.com/ARM-software/arm-trusted-firmware'
ATFBRANCH='branch:master'

edit: You also need all the patches (for h616 and opz2). I did not check if the patches are present or not in armbian master, as I had included them in previous builds. If not, you need to include them. 

Link to comment
Share on other sites

  • 0
37 minutes ago, lampra said:

This is what I did here

ATFSOURCE='https://github.com/ARM-software/arm-trusted-firmware'
ATFBRANCH='branch:master'

edit: You also need all the patches (for h616 and opz2). I did not check if the patches are present or not in armbian master, as I had included them in previous builds. If not, you need to include them. 

where did you get those H616 patches?

Link to comment
Share on other sites

  • 0

Yes, I just changed these two lines. 

 

I found I made a mistake, use "head" rather than "branch:master" 

 

So I  change to exactly as you writo, others keep the Armbian master.

 

After build and burn to SD card,  still stuck at "Starting Kernel ... " 

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...