-bash: ./program: cannot execute binary file: Exec format error


Recommended Posts

I'm having trouble running a program
this error when running the program: 

-bash: ./program: cannot execute binary file: Exec format error

 

And I checked the file, it turns out that the error is on the machine type, the program requires an x86-64 machine, while my armbian linux machine is aarch64

 

When I check with this program file command the result is:

: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, interpreter /lib64/ld-linux-x86-64.so.2, for GNU/Linux 2.6.32, BuildID[sha1] =c67539ec4f37bbb5d61546fade0a8b7bf2ee4659, stripped

 

And here are my server specs:
 

Linux localhost 5.1.0-rc1-aml-s905 #5.84 SMP PREEMPT Tue May 7 11:18:59 MSK 2019 aarch64 GNU/Linux

 

Until now I have not found the package that the program needs to install, please help, maybe there is a solution?

thanks

Link to post
Share on other sites

Armbian is a community driven open source project. Do you like to contribute your code?

You cannot run ARM binaries on Intel architecture and vice versa without some kind of emulation. Ideally you pick up a binary for the matching architecture.

Also since you did not tell which program you try to run there is no way to help any further.

 

Link to post
Share on other sites

The radiobot program I want to run shoutirc.com
I've tried changing OS but still can't run, the problem is in the interpreter /lib64/ld-linux-x86-64.so.2 whereas on my server the interpreter is /lib/ld-linux-aarch64 .so.1

does that package exist for armbian linux?

Link to post
Share on other sites

57 minutes ago, gufril said:

it seems the program is only for amd all
is there armbian amd?

The problem is that all binarys at the Download-Page for RadioBot are all for PC-CPUs like 32bit (Intel x86) and 64Bit (AMD64, also Intel 64Bit PC-CPUs) and there is no source-packge for self compiling.

It seems your only chance is to create a Support-Ticket, because on the top of the page you could see:
 

Would you like to see another native build for your distro/OS/platform? 
Please submit a Support Ticket and we'll see what we can do...

 

On the Linux-Installation page http://wiki.shoutirc.com/index.php/Installation there is also an entry for debian with the dependencies:
 

4. Debian 10: Type sudo apt-get install openssl sqlite3 libsqlite3-0 default-libmysqlclient-dev libcurl4 libphysfs1 tcl8.6 libloudmouth1-0 libtag1v5 espeak espeak-data festival libssl1.1 libwxgtk3.0-0v5 libsqlite3-0 libmpg123-0 libogg0 libvorbis0a libvorbisfile3 libsndfile1 libavformat58 libavcodec58 libmp3lame0 libflac8 libresample1 libfaac0 libprotobuf17 libmuparser2v5 liblua5.2-0 libaacplus2 libsoxr0

 

But you need a binary for your aarch64 SBC :(

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

1 1