Armbian for Amlogic S805 and S802/S812


masteripper
 Share

40 40

Recommended Posts

Thanx RaptorSDS

Now I can boot... yeesssss...

 

But I have now another problem.

I install OMV, and afteer that i can not fix eth mac adress.. Afteer every boot change mac adress, and ip adress. I set  mac adreess in /etc/network/interfaces, but not solved the problem.

How can I fix that.?

Link to post
Share on other sites

Armbian is a community driven open source project. Do you like to contribute your code?

vor 12 Stunden schrieb mexmet:

Thanx RaptorSDS

Now I can boot... yeesssss...

 

But I have now another problem.

I install OMV, and afteer that i can not fix eth mac adress.. Afteer every boot change mac adress, and ip adress. I set  mac adreess in /etc/network/interfaces, but not solved the problem.

How can I fix that.?

short goog le and i found OMV has its own network-manager , all settings in interfaces will be ignore

you have to set all network things inside OMV

 

https://forum.openmediavault.org/index.php?thread/23034-network-manager/&postID=176055

Link to post
Share on other sites

Hey everyone, I updated my guide on making Docker work here https://github.com/SLAzurin/armbian-aml-s8xx-kernel-build-steps

(For Ubuntu/Debian on linux version 5.10)

 

@balbes150 The previous comment for Docker requirements is wrong.

These here are the only config you need to enable to make Docker work when you build the linux kernel.

CONFIG_POSIX_MQUEUE=y
CONFIG_POSIX_MQUEUE_SYSCTL=y

I hope you can add it successfully for the next release, thank you for your work.

Link to post
Share on other sites

vor 8 Stunden schrieb AzuriAdore:

Hey everyone, I updated my guide on making Docker work here https://github.com/SLAzurin/armbian-aml-s8xx-kernel-build-steps

(For Ubuntu/Debian on linux version 5.10)

 

@balbes150 The previous comment for Docker requirements is wrong.

These here are the only config you need to enable to make Docker work when you build the linux kernel.

CONFIG_POSIX_MQUEUE=y
CONFIG_POSIX_MQUEUE_SYSCTL=y

I hope you can add it successfully for the next release, thank you for your work.

i do not know if there will be a new build because balbes150 has stop working on this box , but on kernel GIT and linx GIT  there still some person who fix things maybe you have to ask there.

Link to post
Share on other sites

On 8/1/2021 at 2:51 AM, RaptorSDS said:

i do not know if there will be a new build because balbes150 has stop working on this box , but on kernel GIT and linx GIT  there still some person who fix things maybe you have to ask there.

Ok thanks for the heads up, I'll try to contact xdarklight to see if those can be enabled by default.

Link to post
Share on other sites

On 1/16/2020 at 12:00 AM, Red2 said:

I have an old tv box with S802 

MXIII 4k 1g8g netxeon m82

Just wondering what the latest Linux image I can get it to run and where would I find an image file. Most I find seem to only be for 2g boxes or I'm misinterpreting the info, which isn't that unlikely. Everything I have tried has failed so it would be nice to know if someone else got Linux install on one and which version

Thank in advance

Hey, 

 

Can anyone help me? 

 

My device is Netxeon M82G V2.0 S812/2G/8G/AP6330 (Tronsmart MXIII Plus clone?).

 

It's not booting proper. What shall I do first? 

 

Sometimes it boots until Android Logo on the screen and mostly you can just see Android TV Googleatv logo at the start. 

 

I recognized that ricoh rn5t618m chipset gets very fast hot. 

 

Any ideas or suggestions? Does someone still have an original image for debricking tries? 

Link to post
Share on other sites

ricoh rn5t618m is the power managment IC , if this is your main error than also a image can not help you

its look like you found the startup problem

 

if the power IC get wrong settings from image maybe a linux can help

 

When you get multiboot activate you can boot from SD or USB , you have not to fear to brick because orginal android is not touched

( get a orginal image is hard to find because of the varity of the box )

 

 

maybe someone else can jump in and have more ideas about the thermal problems

Link to post
Share on other sites

Hey @RaptorSDS,

 

Thanks for your comment. I think so to and I don't know if it's a software or hardware related problem. 

 

I just noticed that the chip gets very fast hot.... 

 

Hmm... I would love and really appreciate if someone could offer an image or link to a possible download. 

 

I would think it's best to start a debricking try from windows with amligic-tool or something similar. 

 

I just did this with rk3229 boxes... 

 

But this S812 is opened and I can do some shortcut or whatever is needed to bring it to mask rom mode. 

 

 

Link to post
Share on other sites

@Alex83 be aware S812 is no rk3229 you can deep brik this device  , Amlogic has no fallback to sd card when internal memory fail or boot loader missing 

 

only real way is to get into boot loader and install aml_autoscript.zip than you get multiboot and can use sdcard as linux boot drive

Link to post
Share on other sites

Hey guys,

I'm releasing my personal Armbian build for AML s8xx compatible with Docker.

 

Armbian: 21.11.0

Ubuntu: 20.04 focal
Linux: 5.14-rc2 by xdarklight
Original build files by balbes150

I only tweaked the board settings.


Files used here:
https://github.com/SLAzurin/build-armbian-custom/tree/s8xx

 

Build steps on system with Ubuntu 20.04 and docker:

  1. Copy files from `userpatches.s8xx` to `userpatches`
  2. ./compile_s812.sh
  3. Mount the output image file to your filesystem (Check `postbuild.sh` for more details)
  4. Change the label for the ext4 partition to be `ROOTFS`
  5. Unmount image file and flash to SD Card.
  6. (Optional) Generate new .sha file with `sha256sum $IMAGE > $IMAGE.sha`

Downloads here:

https://github.com/SLAzurin/build-armbian-custom/releases/tag/v2021.11-s8xx
 

I will not be taking any requests, it is already hard enough to get an image released as it is.

You get what you get. Thank you for understanding =)

Edit:

When you try to install Docker,
If you run into an issue that says cannot find package docker-ce, or something similar, do this:

sudo sed -i "s/focal/bionic/g" /etc/apt/sources.list.d/docker.list
sudo apt-get update
sudo apt-get install -y docker-ce docker-ce-cli containerd.io

 

Link to post
Share on other sites

On 4/5/2021 at 7:09 PM, Ruf73 said:

@balbes150, good day!

I ran Armbian_5.77_Aml-s812_Debian_stretch_default_3.10.108_20190326.img from the SD card, then copied it to nand.
However, there was a problem. When I boot from the SD card, the system did not start without an hdmi cable until I removed the parameter "logo=osd1,loaded,0x15100000,1080p,full" from the uEnv.ini. It was in this configuration that I copied the system to nand.
But when the system starts from nand, in the Kernel command line I again see the logo parameter! And the system does not start without a hdmi cable. How do I edit the Kernel command line?

 

upd: solved the problem myself, thanks for the silence :thumbup:

Hi,

Can you please help me,

i have a M8S BCM4335 2GB

 

Which dtb did you used to boot with Armbian_5.77_Aml-s812_Debian_stretch_default_3.10.108_20190326.img ?

 

did you resolved 'HDMI must be pluged to boot' issue ?

 

Thank you in advance ;)

 

FYI, i am actually booting with Armbian_5.44_S812_Debian_stretch_3.10.108_server_20180521.img without specifiying the db (strang ...) but hdmi need to be pluged if unplaged the linux crash

 

BR,

Nab

Link to post
Share on other sites

@Nabiloo

on 5.77 and 5.44 there should be only two m8s dtb files , your choice is only small.

 

normally a there is a standard dtb ( i thing a mxii one)  already on boot folder as dtb.img,

on 3.10.108 Kernel image you have to copy and rename your dtb to dtb.img on boot folder

 

some box still with right dtb have the HDMI plug problem , there was a patch with a HDMI plug dongle without cable

Link to post
Share on other sites

On 1/26/2021 at 12:45 PM, menelike said:

@SteeMan

 

Thanks for your response. I am not sure what you mean with "clean copy", but  Kernel 3.x runs perfectly fine on the device. I just wanted to upgrade debian from stretch to bullseye because of missing/outdated debian packages.

But I think that you're correct, there is no upgrade path. 😪

 

Luckily I had a H96 Pro H3 with a S905x which I managed to run the bullseye on.

 

Hi. Have you been able to get the wifi to work with 2.4 and 5 GHz on your H96 Pro in Bullseye?

Link to post
Share on other sites

 Share

40 40