Recommended Posts

Hi use a Nano Pi Neo  with the Debian Server Image  and and want to try install Pi-Hole but  while the Installation Process  i get a Error. The Script cant add a Password to the New User that Pi-Hole require  (Yes i am use Root)  i get a Stunnel4 error ?!?!  Thanks for your Help

Edited by Igor
adjusted title
Link to post
Share on other sites
Donate and support the project!

If your system works fine - which means you have last version and no errors on file system or similar crazy problems ... than this looks more like a general pi-hole-install issue for Pi hole support line if exists, unrelated to this particular hardware and probably also unrelated to the system. (Debian, Ubuntu, Raspbian, ... )

 

I only installed this Pi-hole once, some time ago and since it worked out of the box I didn't learn anything about it :) I used to run some very complex scenarios within Armbian Debian version, so I doubt there is any related problem with Armbian.

Link to post
Share on other sites

Hi, this is Dan Schaper, one of the developers on the Pi-hole project. 

 

If you are still running into issues with the install, please let us know either here, or via message.

 

We are working on how to better work with the various Armbian SBC's and distributions, so any reports would be helpful and will help us with a better product.

Link to post
Share on other sites

Using the latest armbian image for nano pi, I installed pi hole via the bash install method.  Installation went good, initialization was rocky but started after doing the pi hole -u and pihole -d, but I'm now experiencing the familiar issue of pi hole randomly ceasing to block ads with 0 blocks in the past 24 hours.  I have a backup pi hole setup on a raspberry pi 3 in case of an instance such as this (my router has the nano pi as primary dns and the raspberry pi as secondary) and all ad blocking is currently being diverted to the raspberry.

 

I'll check the usual stuff: command line ad site ping, SD card being full, lighthttpd running, sql, etc., and report back

Link to post
Share on other sites
  • lanefu unlocked this topic

 

6 hours ago, lanefu said:

The workaround for installing pi-hole seems to be to manually install these packages first


sudo apt install php-cgi php-common php php-sqlite3

 

Odd. It is been quite a few month since last time I've set up a Pi-Hole but I cannot remember that I had to install dependencies by hand. This has probably been fixed in the meantime (?).

I may try this later this day since I wanted to test a few RC1 images on my boards anyways.

Link to post
Share on other sites

since buster I do install pihole the normal curl way, but it "breaks" while installing/updating the php packages.

then when pihole puts me back to a prompt I do try to install a already installed package (like espeak on my system) then apt memorizes that espeak is already installed and wil then install the php packages.

after that when trying the curl way the second time it installs fine, because the php packages are alredy installed....

 

So preinstalling the php "dependencies" by hand is just the same, but faster :)

 

Link to post
Share on other sites

I setup a lot of Piholes in lxc containers running Debian and the installer is always messing up something with the dependancies. Usually requires some manual package installation. This is both due to the minimal nature of the initial lxc rootfs but the installer has been buggy for al one long time. Downloading the installer bash file and running it like bash -x install.sh usually reveals where and what goes wrong.

Link to post
Share on other sites
20 hours ago, Werner said:

could confirm that the installer script dies after checking the dependencies....odd.

OK ;) with the dependencies the installer doenst dies after the dependencies-checkup:
 

sudo apt install php-cgi php-common php php-sqlite3 -y && curl -sSL https://install.pi-hole.net | bash

Did work for pihole 4.3.1/4.3.2

 

Also the "update" to 5.0 beta did work flawless:
 

echo "release/v5.0" | sudo tee /etc/pihole/ftlbranch
pihole checkout core release/v5.0
pihole checkout web release/v5.0

 

Link to post
Share on other sites

Yeah, but my guess is it is not intended by the developers over there to work this way :D

 

https://gist.github.com/EvilOlaf/ee16e3325b702a95b264dfc65937a78d

 

The last command before it dies is debconf-apt-progress -- apt-get --yes --no-install-recommends install netcat idn2 sqlite3 dns-root-data lighttpd php-common php-cgi php-sqlite3

If I run it by hand it dies the same way.

THOUGH if I remove the debconf-apt-progress it runs fine....

 

I provided a bunch of log files to pihole and cews kind a confirmed the issue. Lets see if they can fix it.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...