NanoPC T3+ boot troubles


Recommended Posts

Armbian is a community driven open source project. Do you like to contribute your code?

17 hours ago, aitek said:

I use the FriendlyElec's img file working good.  but Armbian_5.59 can't boot.  at the end is always same:   random: crng init done


FriendlyARM uses very different setup. They have their own u-boot and kernel. 

My board works perfectly fine: http://ix.io/1q1R with this image: https://dl.armbian.com/nanopct3plus/Debian_stretch_next.7z Running low on ideas. It can be some different board revision. Have you tried to boot without anything attached? Power and serial console only. Do you have plus model - with 2G of memory?

 

PSU = 5A

SD card = Samsung EVO32GB

Link to post
Share on other sites
13 hours ago, aitek said:

i use FriendlyElec ‘s img work good. but armbian cannot work. maybe my board have some problem? 

Maybe try ramtester in friendlyElec their img. I doubt this is your problem. But I don`t know anything else either.
Boot with nothing attached, try another psu, another sd-card, re-download the image, try an older image. But I think all this is done. And you don`t seem alone with the problem.
For me it all seemed to work fine. I`ve done a lot of benchmarks on it.

Link to post
Share on other sites
4 hours ago, aitek said:

it is have possible have two version nanopc t3 plus?


Yes, we have seen this in the past. They change memory modules for example which need adjustments in u-boot. We use different one ... which is adjusted to support booting modern kernel. To be able to start solving this problem a few components are needed: know-how, time and hardware sample.

 

Another strange thing is that my T3+ has the same revision numbers as yours - at least in mine there is: 1709, check memory chips. Sometimes they don't change revision number and change components. Haven't seen this at FA but elsewhere.

P1110334.JPG

Link to post
Share on other sites
On 1/17/2019 at 7:43 AM, sfalcon said:

I'm having the same problem on my T3+. All the versions of Armbian for the T3+ I've tried give me segfaults on boot.

 

I've notice the mem chips on my board are slightly different to the picture posted.

 

t3+.png?raw=1

I have this revision of nanoPC t3+ too, and I cannot boot either 

the log cat is the same as above @NicroD and @aitek  mentioned 

please let me know if there is any solution to boot

Edited by AmirHG
Link to post
Share on other sites

Hi fellow T3+ owners. I have the same situation; Armbian Bionic for T3+ panics right after boot, probably the memory config has changed.

 

However... if you use the T3 (non plus) armbian image I can not only boot but can flash it to eMMC (I am not saying this is a perm solution).

WiFi works, haven't tried camera but looks stable enough for development.

 

The only issue I have is the usable memory is 1Gb instead of 2Gb. Where does armbian get the available memory from, is it auto detect or is there something like a boot.txt ?

 

Regards,

Morgan 

 

Link to post
Share on other sites
18 hours ago, constantius said:

Please add something


When someone will take responsibility:

BTW. I have 4 different boards and all works fine.

 

2 minutes ago, constantius said:

Is there a way or a chance to enable  2GB RAM in  Nano pi T3+?  I mean build img myself. Thanks for reply in advance.


If you use/build image for T3+ you will have 2GB memory support. If not, than is is possible you have one of those boards with unknown/not supported memory. This is most probably cause of crashing.

Link to post
Share on other sites

I have build img for nano pi t3+ 5.85 armbian kernel 4.14.113 and it does not work either.  I have the same memory number SEC 710.  Only img from t3 without "+" is working but only with 1GB ram.

I can take care about 

Pine64 first realese 

Bananapi M2U / Berry

Firefly RK3399 and

Nanopi T3 plus

I have these boards. 

 

Conclusion for Nano Pi T3 + with memory number begin SEC710 K4B4G16 is that.... no images from dl.armbian work. If you try to build image with kernel 4.14 it also wont work.

Issue kernel panic segmentation fault and more stupid things on your monitor.

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...