19 19
balbes150

Armbian for Amlogic S9xxx kernel 4.1x (>= ver 5.55)

Recommended Posts

11 minutes ago, olivluca said:

 

I'd like to try armbian on a mecool KI pro, any hint on how to convert the dtb from libreelec (kernel 3.14.29)?

Did you try to use the dtbs for p230/p231 (which are for s905d) delivered with the builds by specifying in uEnv.ini ile on boot partition after writing image to card/pendrive? 

Share this post


Link to post
Share on other sites
44 minutes ago, Turgus said:

Did you try to use the dtbs for p230/p231 (which are for s905d) delivered with the builds by specifying in uEnv.ini ile on boot partition after writing image to card/pendrive? 

 

No, I didn't try any armbian image yet, I just searched the messages regarding the k1 pro and saw that there is (was?) no suitable dtb.

Share this post


Link to post
Share on other sites

Then give it a try! ..if it works with one or the other dtb for s905d perfect, if not you loose 30-60 minutes as you could re-format your sd card if it fails (and original system is still working)..

Share this post


Link to post
Share on other sites

I tried now by burning the image on an usb stick and modifying both uEnv.ini and extlinux/extlinux.conf (though I didn't touch uboot on the box so the former should be enough).

 

I used both

dtb_name=/dtb/meson-gxl-s905d-p230.dtb

and

 

dtb_name=/dtb/meson-gxl-s905d-p231.dtb

but none of them worked (I just see the usb stick led flash for a short while then nothing, the screen stays on the "mecool" logo).

 

I didn't boot into android to flash aml_update.zip, but the box was already booting from usb/sd  (in fact I used the same stick to boot coreelec and an sd card to boot libreelec).

Share this post


Link to post
Share on other sites

Hmm, if those two didn't work, maybe try all others too until you find one which boots.. maybe you lack of some features, but try to find one which works somehow.  Maybe try one of the older s905 Armbian 3.14 Kernelversions with 3.xx Kernel and the dtb which works on core/libreelec with your box(got on an H2+-Box also a armbian running, but with older kernel as it works better for me there..)?!

Share this post


Link to post
Share on other sites

I'll try one of the older images tomorrow, but I'd also like to boot a newer kernel (though it won't support hw acceleration) hence my original question on how to convert the 3.14 dtb.

Share this post


Link to post
Share on other sites
8 hours ago, olivluca said:

I didn't boot into android to flash aml_update.zip, but the box was already booting from usb/sd  (in fact I used the same stick to boot coreelec and an sd card to boot libreelec). 

Multiboot from coreelec not compatible with the new versions Armbian with the kernel 4.x

Be sure to activate multi-boot using the new image. If multiboot previously activated is required to repeat activation using files in a new image.

 

Share this post


Link to post
Share on other sites

But the box is already booting from external media (sd/usb). If I use aml_autoscript.zip will it still work as it is working now? (i.e. no external media present boot from nand otherwise boot from external media)?

I don't want to lose the ability to boot coreelec/libreelec.

Share this post


Link to post
Share on other sites

You must use new autoscript. I'm not sure will you have to install again from libreelec if you want to switch back, but you can install it from android every time you need it

But the box is already booting from external media (sd/usb). If I use aml_autoscript.zip will it still work as it is working now? (i.e. no external media present boot from nand otherwise boot from external media)?
I don't want to lose the ability to boot coreelec/libreelec.


Sent from my Redmi Note 4 using Tapatalk

Share this post


Link to post
Share on other sites
7 hours ago, zogu said:

You must use new autoscript. I'm not sure will you have to install again from libreelec if you want to switch back, but you can install it from android every time you need it

 

 

 

 

I tried but still doesn't boot. At least I can still boot libreelec. I'm going to try with an older image.

Share this post


Link to post
Share on other sites

OK, I tried Armbian_5.44_S9xxx_Ubuntu_bionic_3.14.29_icewm_20180729.img.xz and it boots fine. Now, back to my original question: how do I convert the dtb?

Share this post


Link to post
Share on other sites
9 minutes ago, olivluca said:

OK, I tried Armbian_5.44_S9xxx_Ubuntu_bionic_3.14.29_icewm_20180729.img.xz and it boots fine. Now, back to my original question: how do I convert the dtb?

It's incorrect question. You can't convert DT. You must rewrite it, read what is it, and how hw describe in device tree.

Share this post


Link to post
Share on other sites
4 minutes ago, talraash said:

It's incorrect question. You can't convert DT. You must rewrite it, read what is it, and how hw describe in device tree.

 

Ok, so where do I find a crash course on how to rewrite the dts based on the information contained in the old one? (if that makes sense)

Share this post


Link to post
Share on other sites

@balbes150 Unfortunately, I've got the same issue with the version 4.19.6 20181205....
No ethernet, still 169.254.6.1 in use after boot. I can now change the IP, and under "Connection Information" the new IP is shown, but still without connection to my router. After reboot, the IP goes back to 169.254.6.1....

Share this post


Link to post
Share on other sites
On 11/28/2018 at 10:06 PM, balbes150 said:

Update ver 5.67 20181128

Update kernel 4.19.2

 

Have updated to

Armbian_5.67_Aml-s9xxx_Ubuntu_bionic_default_4.19.2_desktop_20181203

 

This works great on my Mecool KM8 s912 octacore 1gb ram.

 

Ethernet 100mbs is working great.

 

Zram is working great.

 

Have run it for 20 minutes totally stable.

 

Thanks Babe's.

Share this post


Link to post
Share on other sites
15 hours ago, olivluca said:

Ok, so where do I find a crash course on how to rewrite the dts based on the information contained in the old one? (if that makes sense) 

Google , Yandex etc

 

 

Share this post


Link to post
Share on other sites

Armbian_5.67_Aml-s9xxx_Ubuntu_bionic_default_4.19.6_desktop_20181205 on BM8 Pro s912 octacore 2gb ram

Ethernet working at 1Gb. Everything pretty zippy and stable so far.

Seems to be the fastest among the s9xxx boxes I've got.

Share this post


Link to post
Share on other sites
14 hours ago, amirul said:

Armbian_5.67_Aml-s9xxx_Ubuntu_bionic_default_4.19.6_desktop_20181205 on BM8 Pro s912 octacore 2gb ram

Ethernet working at 1Gb. Everything pretty zippy and stable so far.

Seems to be the fastest among the s9xxx boxes I've got.

Sounds good! Which .dtb file do you use?

Share this post


Link to post
Share on other sites
On 12/5/2018 at 3:51 PM, balbes150 said:

Update the image with the kernel 4.19.6 20181205. Fixed a bug in the v4l2m2m module

 

For me the 4.19.6-versions(installed the 1205 now on emmc) work much(10-15%) faster than those with 4.19.2/4.20-next versions. Everything is really responsive and works well on x96mini(ethernet connection + usb sound, but I didn't test internal av for weeks) .  Thanks for your work! 

 

Sorry, but I know just some basics about ffplay usage. What do like to test/discover?!

 

P.S.: By the way it seems that start up of login screen appears around 20-30 seconds faster if I move the mouse around while boot messages run through and the black screen is shown..

Share this post


Link to post
Share on other sites
On 12/7/2018 at 12:00 AM, amirul said:

Armbian_5.67_Aml-s9xxx_Ubuntu_bionic_default_4.19.6_desktop_20181205 on BM8 Pro s912 octacore 2gb ram

Ethernet working at 1Gb. Everything pretty zippy and stable so far.

Seems to be the fastest among the s9xxx boxes I've got.

Seems that I ran out of memory watching a movie online on firefox. Have to get me one of those boxes with 3Gb ram then

 

Update: turns out eth still had intermittent issues too. Going back to 4.18 kernel

A fix? https://patchwork.kernel.org/patch/10712159

 

Share this post


Link to post
Share on other sites

Hi there,I got a new tv box beelink GT1 mini with s905x2, When can you support this chip?

i have extracted the dtb file of Android, how can I make the dtb file available for the current linux image?

 

 

Share this post


Link to post
Share on other sites
On 12/8/2018 at 3:14 AM, Turgus said:

Sorry, but I know just some basics about ffplay usage. What do like to test/discover?!

You need to take the latest image version 20181207. install the package ffmpeg_4.0.4 (from the same directory on the website where the images are). Need to check (choose correct options) run ffplay for video playback decoders "*_v4l2m2m".

Share this post


Link to post
Share on other sites

hi ,

did someone has been able to use a arduino r3 connected to a usb port ?

it's using a ch340 usb to serial converter connected to a mxq stb with s912 amlogic chipset and 4.18.0-aml-s9xxx kernel

 

All other function i need are working fine 

 

i think i need to compile a new driver  , but there is no /lib/modules/4.18.0-aml-s9xxx/build directory

 

how do you do guys when you want to compile a new driver ?

 

i can't install linux header by apt-get neither armbian-config

E: Unable to locate package linux-headers-4.18.0-aml-s9xxx
E: Couldn't find any package by glob 'linux-headers-4.18.0-aml-s9xxx'
E: Couldn't find any package by regex 'linux-headers-4.18.0-aml-s9xxx'

 

thanks for the amazing job you have done
 

 

 

 

 

 

 

Share this post


Link to post
Share on other sites
15 hours ago, balbes150 said:

You need to take the latest image version 20181207. install the package ffmpeg_4.0.4 (from the same directory on the website where the images are). Need to check (choose correct options) run ffplay for video playback decoders "*_v4l2m2m".

Hi, where is that website?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
19 19