Armbian for Amlogic S9xxx kernel 5.x


Recommended Posts

Armbian is a community driven open source project. Do you like to contribute your code?

18 hours ago, chalesY said:

Hi 

my tvbox is mgv2000 , gxlx_p261_1g

when I'm try to use /root/install.sh to install system into internal emmc, I get a lot of errors. I found mmc* file is not appear at /dev/ ,but sometimes them appeared, but still have I/O error in dmesg .

Did anyone have the same problem or know how to solve it?

 

dmesg-mmc.txt

 

u need reduce ur emmc speed in dtb file,  i got same errors in my s905w box. in pure kernel speed is 2000000, in balbes150 it reduced to 1000000, but i reduce it to 500000 and installed armbian to emmc successfully.

Link to post
Share on other sites
4 hours ago, B1oHazard said:

u need reduce ur emmc speed in dtb file,  i got same errors in my s905w box. in pure kernel speed is 2000000, in balbes150 it reduced to 1000000, but i reduce it to 500000 and installed armbian to emmc successfully.

Thanks a lot!

I change it into 50000000. Now ,I can install armbian into emmc successfully.

Link to post
Share on other sites
On 12/21/2018 at 10:03 PM, B1oHazard said:

u need reduce ur emmc speed in dtb file,  i got same errors in my s905w box. in pure kernel speed is 2000000, in balbes150 it reduced to 1000000, but i reduce it to 500000 and installed armbian to emmc successfully.

Hi, I have 20 x96 mini 2/16. I noticed that into the box with Sk Hynix Nand I can't install to emmc and I have some problems (I/O...). I think this could fix. How can I change this value? Or can you share your .dtb file? thank you!

Link to post
Share on other sites
4 hours ago, Edoardo Coen said:

Hi, I have 20 x96 mini 2/16. I noticed that into the box with Sk Hynix Nand I can't install to emmc and I have some problems (I/O...). I think this could fix. How can I change this value? Or can you share your .dtb file? thank you!

u can send me in pm ur dtb from working build and i can modify it for u

Link to post
Share on other sites

First of all thanks to Balbes150 for all your hard work.

I have Armbian_5.67_Aml-s9xxx_Debian_stretch_default_4.19.6_desktop_20181207.img working well on x96 mini.

I used Linux Mint to set it up, I unxz in terminal then right click img & write to usb then with GParted grow partition to 16gb (the size of my USB stick).

On x96 mini power on with reset button pushed (inside audio port) hold for bout 10 seconds then let go, it boots Armbian.

After reboot I had disk errors which I fixed on linux mint with "resize2fs /dev/sdb2" with sdb2 being my device, now all working well.

The x96 mini has s905w soc, now I also have x96 max which has s905x2.

I tried install same way as mini but it gives error that signature verification failed.

Is there an image that works on x96 max or will there be in the future as this would be a great box to run Armbian, it has 4gb ram & 64gb storage, would love to get this working.

Link to post
Share on other sites
On 12/19/2018 at 3:38 PM, hhalibo said:

 

Hi Shen

 

I have N1 and also from China. Here's the solution for N1 bluetooth & network-fix(kernel 4.18)

 

https://www.right.com.cn/forum/thread-353806-1-1.html

 

N1 dtb file

 

https://github.com/yangxuan8282/phicomm-n1/releases/download/dtb/meson-gxl-s905d-phicomm-n1.dtb

 

BT,with my experience,the Armbian 5.44 kernel 3.14-20180729(use balbes150's original dtb) works very well with phicomm-N1

 

Cheers

Thank You. I am also a member of Right.com.cn; N1 device is very popular here. It is much better than Pi 3.

Link to post
Share on other sites
10 hours ago, mocsadek68 said:

but after the install, the system doesn't operate. The next picture can be seen:

 

https://drive.google.com/file/d/1PPU8q5kft2Io_8StWjMVFIwLYSn9rAbz/view?usp=sharing

Ok I looked at picture.

 

With Babes s905 / s912 Armbian images you need to use a .dtb file so it knows how to boot.

 

My guess is you did not edit the .dtb file name.

 

In the boot directory from memory is a ?????.ini file.

 

Open it with a txt editor and cut out the name of the dtb that is there and cut and paste in the one you want the box to boot with.

 

After finding a dtb file that works it will boot.

Link to post
Share on other sites
2 minutes ago, Lucas Saraiva Azevedo said:

Are you sure that will work with this cpu? What about the kernel?

These are the very latest kernel. Babes has bee very active lately getting his s9xx Armbian working on many boards.

 

Why not do 500 mb download and try.

 

I prefer the Ubuntu desktop version.

Link to post
Share on other sites

Does eMMC booting work on latest versions ? I tried Armbian_5.67_Aml-s9xxx_Ubuntu_bionic_default_4.19.7_desktop_20181228 on my Sunvell T95X and while sd boot works flawlessly, when installing to nand using  /root/install.sh script it finished installing successfully, but after i reboot the device, it does not boot (stuck at amlogic logo). Am i doing something wrong here ?

 

Prior to installing armbian i reflashed the device with stock firmware and activated multiboot using aml_autoscript zip.

Link to post
Share on other sites
9 hours ago, hojnikb said:

Funny enough, when i have sd card installed (with Armbian) it boots fine and i can see and edit emmc partitions

I have a Mecool KM8 s912 1GB ram. I tried to copy to emmc but it did not work. I used Armbian config tool and the tool said it had written to the internal Mecool emmc successfully but when I rebooted it was as if the Mecoll had reformatted and reinstalled the old emmc partitions?

Link to post
Share on other sites
Guest
This topic is now closed to further replies.