Jump to content

X96 MAX (S905X2) with Armbian-ubuntu


Recommended Posts

just in case someone else runs into this problem too: i had the same error - looks like some checksum or magic number is now different than the one used for the .zip file in /boot of the images usually selected in the android update app ... luckily the old toothpick method still works fine: turn off the box, put the sd card with the armbian image into the sd card slot, but a toothpick (nothing metallic) into the audio out and hit the switch inside (be careful, it should be possible to feel when you click it), keep it pressed while you plug in the box power, keep it like this until the initial sceen logo gets black again and then release the toothpick - afterwards it should boot into armbian normally ...


best wishes - hexdump

Link to comment
Share on other sites

Hello all,

Can someone help me?
I tried to install latest image from @balbes150 to X96Max (S905X2)


My procedure and error is (I am using Windows 10):

  1. Download image from above link and extract using 7z to .img file
  2. Use Etcher to write image to MicroSD Card
  3. Plug in card to TVBox
  4. Open "Update" app on TVBox, select manual update

After this step, the system is restarted with error

E: footer is wrong

E: Signature verification failed

E: error: 21

Please tell me if you have any idea to resolve this issue.
Thank in advance

Link to comment
Share on other sites

On 8/10/2019 at 2:39 PM, qstaq said:

Is that the 5.91 images from balbes150 unofficial test yandisk repo? If so then yes it is missing the bcmdhd module. You will have to clone balbes s905 kernel repo from github and build the module and / or kernel

Can you please let me know where I can find the instructions to build the module?



Link to comment
Share on other sites

Hi, I have a few 905X2 boxes intended to be used as a mini server. They have 4GB memory and 32GB emmc. I want to load Linux on it and use them to run our network monitoring programs. I used to be software engineer working but haven't done much in recent years. I think maybe some experts could post the steps to compile and load Armbian images onto its emmc? Better, help to walk me through the process. I am willing (and by happy) to shed couple of hundred for the help. My main requirements are following: 


1. Need to have a Ubuntu or any version running with Kernel higher than 4.9 where we can turn on TCP congestion BBR algorithm. I think a recompile of Kernel is required so I suppose I can recompile Armbian and choose to rebuild kernel (choose options to set BBR on).

2. Need to compile and package a few of our own applications (I know how to cross compile those but want some instruction how to package them into the Armbian image)

3. Need to turn on hardware watchdog feature so in case the box has any problem, it can restart itself and hopefully get back to normal.


Appreciate any help or suggestions!

Link to comment
Share on other sites

Hey ive been trying to install the Armbian_5.98_Aml-g12_Ubuntu_bionic_dev_5.4.0-rc4_desktop_20191025.img.xz image on my x96 max via the update app however it doesnt seem to work. Is it a problem that im having the XT MOD custom atv from freaktab installed? Do i need to revert the x96 max back to its stock image to install the debian image via the android tv update app ?

Link to comment
Share on other sites


i reverted the x96 max back to stock image, now when i boot with the armbian sdcard it seems to load armian until it says
"Ubuntu Bionic with Armbian Linux tty1"
"aml login:"

but i can not enter any input with the usb keyboard i attached... what am i doind wrong? (sorry total noob at work here)

edit: i got i to work, i failed to enter the correct dbt file in the ini

Link to comment
Share on other sites

I have an A95x max, use S905X2 too, 64G ROM, 4G RAM.

I use firmware "Armbian_5.99_Aml-g12_Ubuntu_bionic_dev_5.4.0-rc6_20191110.img" and config "meson-g12a-x96-max.dtb", It seems to work well in USB drive.

But after I run “install.sh” to install to my internal flash. the tvbox has probability  bricked when i write more filesystem.

I use reset button to recovery the boot config. It can boot. I check the file, and found some files are changed.

I think armbian partition may overlaps with the uboot's config position.

I modify file “install.sh”  form:

parted -s "${DEV_EMMC}" mkpart primary fat32 700M 828M
parted -s "${DEV_EMMC}" mkpart primary ext4 829M 100%


parted -s "${DEV_EMMC}" mkpart primary fat32 3072M 3200M
parted -s "${DEV_EMMC}" mkpart primary ext4 3201M 100%

and reinstall to internal flash, it works fine.


I wan't to know the accurate offset for uboot config.

I went to the official Android system to check the partition and got the results:

major minor  #blocks  name

 252        0     512000 zram0
 179        0   61071360 mmcblk0
 179        1       4096 mmcblk0p1
 179        2      65536 mmcblk0p2
 179        3    1146880 mmcblk0p3
 179        4       8192 mmcblk0p4
 179        5       8192 mmcblk0p5
 179        6      24576 mmcblk0p6
 179        7       8192 mmcblk0p7
 179        8       8192 mmcblk0p8
 179        9       8192 mmcblk0p9
 179       10      16384 mmcblk0p10
 179       11      16384 mmcblk0p11
 179       12      16384 mmcblk0p12
 179       13      32768 mmcblk0p13
 179       14     262144 mmcblk0p14
 179       15     262144 mmcblk0p15
 179       16    1900544 mmcblk0p16
 179       17   57126912 mmcblk0p17
 179       96       4096 mmcblk0rpmb
 179       64       4096 mmcblk0boot1
 179       32       4096 mmcblk0boot0

But I can't understand it.


Edited by q741451
Link to comment
Share on other sites

11 minutes ago, boxmeister said:

apparently the ubuntu distribution this is based on is no longer maintained?

You will need to be more specific in your question.  What ubuntu distribution are you referring to?  When you say ubuntu do you mean armbian?  When you say "this" what exactly are you referring to?

Link to comment
Share on other sites

i got things mixed up sorry, i was refering to an image that i used wich i got from freaktab.com ( Armbian_5.98_Aml-g12_Ubuntu_bionic_dev_5.4.0-rc4_desktop_20191025.img.xz  )
apparently its not longer supported anymore (e.g. i cant apt-get update anymore)... are there any alternative images that i could try that are still supported?



Link to comment
Share on other sites

8 hours ago, boxmeister said:

an image that i used wich i got from freaktab.com ( Armbian_5.98_Aml-g12_Ubuntu_bionic_dev_5.4.0-rc4_desktop_20191025.img.xz  )

Current builds for armbian on android tv boxes can be found along with current instructions for installing them in the first post of the following forum thread: 


Link to comment
Share on other sites

First BIG THANK YOU to all of you for support. Now I have started armbian on my X96 MAX. Lan is working, maybe video work with VESA driver, audio is not working. Now I have successful updated Debian GNU/Linux bullseye. Firefox-esr not started before apt remove gcc-9 && apt install gcc-10. I see only two active cpu cores.

Link to comment
Share on other sites

All working now. My steps:

1. Download from this link: https://yadi.sk/d/pHxaRAs-tZiei/20.02/20200205 Armbian_20.02.0-rc1.038_Aml-s9xxx_bullseye_current_5.5.0-rc6_desktop_20200205.img.xz

2. Image size after extraction is 5000MB - do not extract it. If you using PC for burning image on USB drive or micro sd card, please use this program USBimager from here: https://gitlab.com/bztsrc/usbimager

3. Boot on X96 MAX. Insert prepared with image USB drive or memory card. From Android select UPDATE...  from applications. Select file From your /Boot/...zip on the bottom. Then press Update.

4. X96 Max rebooted and you are booting Linux. Follow steps for login: user root, password 1234. Change root password. Create new user.

5. Graphical interface - no sound, only two cores. Be happy - keep reading!

6. Touch with mouse Application in top left corner and select Terminal Emulator. Go to /root with this command: "sudo su -" (without quotes). Enter your user password. In this directory you have two files. One of them install this armbian on internal memory and delete your android. Other file is named g12_sound.sh and after execution you have working sound card (I use it from HDMI port).

7. If you install armbian to internal ssd on your X96 MAX follow instructions and reboot after completed execution of copy process. In terminal use command halt and detach installation device for boot from internal ssd drive.

8. Unplug and plug power cable. Remote is not working. Linux is booting. Login as root and edit file /boot/uEnv.txt. Replace row FDT=/dtb/amlogic/meson-g12b-odroid-n2.dtb with FDT=/dtb/amlogic/meson-g12a-x96-max.dtb

9. Save file and reboot. You have four working cores. Bluetooth is working. Firefox is not work now. Open Terminal. "sudo su -", enter your password, insert lan cable. Set network settings. After that use command apt update && apt upgrade && apt remove gcc-9 && apt install gcc-10

10. Firefox is working

11. Enjoy

Link to comment
Share on other sites

On 9/6/2020 at 6:46 AM, sgrayban said:

Has anyone gotten their X96 Max+ with the S905X3 chip and Armbian installed and working? If so could you please post what info you did if you remember?


X96 Max Plus s905x3 4G  DTB fix for network and sound.




Tested on Armbian 20.05.01 20200408.


Link to comment
Share on other sites

On 9/28/2020 at 1:06 PM, ForzaSGE said:

Do you also have a link where I can download the correct armbian OS file for the x96 Max plus? I do not see it. 

Works on all Armbian image for RK + AML + AW armbian images , Tv boxes (aarch64 ARMv8)

Link to comment
Share on other sites

On 9/29/2020 at 8:44 PM, ForzaSGE said:

Hi @Gausus,

thanks for your reply but I dont get it. Sorry. I am a newbie. ;) 

is this one correct?


maybe you can link the correct one ? Thanks. 


Download her , ignore don't support S905x3 (x96 max plus).




Read instructions

Burn img to sdcard , use BalenaEtcher

Copy my downloaded DTB file  to  \dtb\amlogic

Rename u-boot-s905x2-s922  to u-boot.ext

Edit \extlinux\extlinux.conf

# aml s9xxx
FDT /dtb/amlogic/X.yourfile.Y.dtb


Boot X96 max +


Link to comment
Share on other sites

  • Werner locked this topic
This topic is now closed to further replies.
  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines