9 9
vlna

H2: Sunvell R69 Android TV Box (AliExpress)

Recommended Posts

1 hour ago, tasmatto said:

sorry, but I did not quite understand if there is a version of armbian working on this box. is there a lite version so use it to download torrents and nas?

 

It is possible to build one, minimal Debian or Ubuntu to be used for such purpose (use parameter EXPERT="yes" when building) and it should work. There are no premade images because we don't officially support this hardware.

Share this post


Link to post
Share on other sites
9 hours ago, tasmatto said:

sorry, but I did not quite understand if there is a version of armbian working on this box. is there a lite version so use it to download torrents and nas?

I have images for this board, next week I try to find and share with you. 

Share this post


Link to post
Share on other sites
On 8/12/2017 at 7:21 AM, Igor said:


Wifi on this device is done by XR819, module name is xradio, like on Orangepi Zero. Changing link to right board config might help /boot/script.bin -> bin/orangepione.bin to bin/orangepizero.bin


Performance of this chip is bad, so don't expect too much.

 

I just buy this one from 17€ in gearbest When arrive i just like to install armbian if possible share the images please!

Share this post


Link to post
Share on other sites

Looks like that there is a new board version of this TV Box and unfortunately the Armbian images existing for R69 didn´t work for me.

 

I have tested the images from Google Drive: Armbian 5.59 and 5.46 without success, the same for RetroOrangePi R69 image.

I already change SD-Card and power supply, but since this setup works for old R69/PCB version (I have both) I believe that the problem is related with boot process (uboot, fex config, kernel, etc) or other hardware configuration. 

 

To understand better the problem I disassembly the device and connect the UART port. From the UART shell I can get some information:

- Check Android ROM existing on board have and have  U-Boot 2014.07 (May 04 2018 - 09:38:22) and kernel version 4.4.55

- Check the processor info using cat /proc/cpuinfo and confirm that is a Allwinner H2 processor.

 

 

When I try to boot using the SD-Card and Armbian image only only few information is displayed on shell:

U-Boot SPL 2018.05-armbian (Aug 20 2018 - 12:41:20 +0000)
DRAM: 0 MiB
### ERROR ### Please RESET the board ###

 

If I insert the SD-Card after android boot the sd-card is recognized, so don´t look and hardware problem on sd-card or power supply. 

Anyone could give a direction how to get Armbian images working on this new PCB board?

 

Photos of new board and complete boot logs on link bellow. New PCB version is 2.0 from 2018-04-08

https://www.dropbox.com/sh/z0dosazsfkfsifn/AAA_uYLTipqKTRX_e0MYNxDRa?dl=0

 

Share this post


Link to post
Share on other sites
On 10/5/2018 at 7:08 PM, lucastriches said:

Looks like that there is a new board version of this TV Box and unfortunately the Armbian images existing for R69 didn´t work for me.

 

When I try to boot using the SD-Card and Armbian image only only few information is displayed on shell:

U-Boot SPL 2018.05-armbian (Aug 20 2018 - 12:41:20 +0000)
DRAM: 0 MiB
### ERROR ### Please RESET the board ###

 

Photos of new board and complete boot logs on link bellow. New PCB version is 2.0 from 2018-04-08

https://www.dropbox.com/sh/z0dosazsfkfsifn/AAA_uYLTipqKTRX_e0MYNxDRa?dl=0

 

Thanks for your report and test.

This new board revision has NAND and probably a different memory chip arangement (hence DRAM: 0MiB). Since Uboot is part of the armbian image, it is board-specific. So needs different / changed uboot for this board.

Can you check https://discourse.coreelec.org/t/extracting-dtb-file-from-a-running-android-os/1218/2 to get the dtb file? Can help see what is memory configuration.

But overall, the performance of R69 is really bad due to the heat issue. I am currently well impressed with AMlogic :).

Share this post


Link to post
Share on other sites
On 2/6/2018 at 8:04 PM, guidol said:

I did try many boots (I know it could hang) with a 8GB and a 16GB SanDisk Card.

 

Is pretty old ... but this week I give a second chance to my Sunvell R69 and with new kernel from here 

 

On 2/6/2018 at 11:52 AM, Allwonder said:

Armbian images for R69 on Google Drive.

 

 and never boot on Sandisk microSD card ... but works really perfect with Toshiba Exceria 16GB white color https://www.toshiba-memory.com/es/products/toshiba-microsd-cards-exceria-m302/

So @guidol maybe trying a different brand or micrSD cards works.

Share this post


Link to post
Share on other sites

I got Sunvell R69 form China yesterday with 1+8Gb configuration and blue PCB version is 2.0.

After disassmbling I interesting whats interface(not soldering) on back side with SD card slot  and USB.If I understand it's not soldering CSI connector for camera? Right?

Share this post


Link to post
Share on other sites
On 10/5/2018 at 1:08 PM, lucastriches said:

Looks like that there is a new board version of this TV Box and unfortunately the Armbian images existing for R69 didn´t work for me.

 

I have tested the images from Google Drive: Armbian 5.59 and 5.46 without success, the same for RetroOrangePi R69 image.

I already change SD-Card and power supply, but since this setup works for old R69/PCB version (I have both) I believe that the problem is related with boot process (uboot, fex config, kernel, etc) or other hardware configuration. 

 

To understand better the problem I disassembly the device and connect the UART port. From the UART shell I can get some information:

- Check Android ROM existing on board have and have  U-Boot 2014.07 (May 04 2018 - 09:38:22) and kernel version 4.4.55

- Check the processor info using cat /proc/cpuinfo and confirm that is a Allwinner H2 processor.

 

 

When I try to boot using the SD-Card and Armbian image only only few information is displayed on shell:

U-Boot SPL 2018.05-armbian (Aug 20 2018 - 12:41:20 +0000)
DRAM: 0 MiB
### ERROR ### Please RESET the board ###

 

If I insert the SD-Card after android boot the sd-card is recognized, so don´t look and hardware problem on sd-card or power supply. 

Anyone could give a direction how to get Armbian images working on this new PCB board?

 

Photos of new board and complete boot logs on link bellow. New PCB version is 2.0 from 2018-04-08

https://www.dropbox.com/sh/z0dosazsfkfsifn/AAA_uYLTipqKTRX_e0MYNxDRa?dl=0

 

 

Well, I have been working on trying to get the new Sunvell (interestingly it is still labeled R69 but not marketed as such) ( it is actually an H3 with 2GB of memory and 16Gb NAND) working... already wishing I hadn't purchased it.

 

First off, NAND sux ass and has nearly no support outside of proprietary drivers for Android, so don't think much will be happening with it.

 

Secondly, while I can see it will boot from SDcard, the U-boot fails much like you have shown.  Which I assume means that there is something lacking in the fex that needs toggled, or even worse I have been wondering if they burnt the secure fuse on this so nothing unsigned can be booted.  The latter is what I am leaning towards, but have no way yet to tell.

 

Has anyone gotten Armbian yet booting on this new version of the board?

 

Also posted over in 

a bit earlier which looks to be a post specifically on the board.

 

Cheers!

 

Share this post


Link to post
Share on other sites
10 hours ago, TheLinuxBug said:

I have tested the images from Google Drive

Did you read my post about microSD card ... my Sunvell is the old model, but only boot with some microSD and do nothing with others. With Samsung I can boot directly but if I boot to Android and reboot, the Sunvell goes to Armbian in microSD.

Share this post


Link to post
Share on other sites
4 hours ago, manuti said:

Did you read my post about microSD card ... my Sunvell is the old model, but only boot with some microSD and do nothing with others. With Samsung I can boot directly but if I boot to Android and reboot, the Sunvell goes to Armbian in microSD.

 

You must have some weird SDcards, cause on the old R69 I had no problem booting at anytime from and SDcard.  And I did a lot of booting while I was testing H3Droid.  So it seems maybe you need to stay away from those no-name brand SDcards.

 

This however has no effect on the new box.  I have been testing and am yet to get anything to actually boot.  I did notice in the other thread someone mentioned the OPi0+2 uboot seemed to partially load, so may test that later.

 

Cheers!

Share this post


Link to post
Share on other sites

Just FYI - linux-4.19.20-sunxi breaks on this board (the first, initial revision), renders it unable to boot.

 

I upgraded the kernel version and then it wouldn't boot anymore. Wasn't able to recover it via normal means, either (probably doing something wrong myself).

 

Last version that works for me is 4.14.81-sunxi

Share this post


Link to post
Share on other sites
42 minutes ago, Znuff said:

Just FYI - linux-4.19.20-sunxi breaks on this board (the first, initial revision), renders it unable to boot.

I upgraded the kernel version and then it wouldn't boot anymore. Wasn't able to recover it via normal means, either (probably doing something wrong myself).

booted from MicroSD or did you install to eMMC?

Share this post


Link to post
Share on other sites

As much I can remember, I had the same issue : trying to *upgrade* kernel failed but fresh install succeded.

Share this post


Link to post
Share on other sites

I have a Sunvell R69 clone on the Sunvell R69 firmware.
Everything works except the wifi/bt module. On my box there is a wifi Ampak AP6212.
How can I run the AP6212 on Sunvell R69 firmware?

Share this post


Link to post
Share on other sites

i've tried to compile default, next, dev branches — no go, default does not compiles, dev branch and next are not booting, getting random freezes and/or kernel panics. at the same time, i cannot build image with older(4.14) kernel, i've tried to change build variables(KERNELBRANCH => 'tag:v4.14.81' ) so they point to last working tag, but kernel not compiles:

*** buffer overflow detected ***: scripts/basic/fixdep terminated
scripts/Makefile.host:114: recipe for target 'scripts/kconfig/conf.o' failed
Makefile:478: recipe for target 'sunvell_r69_defconfig' failed
sed: can't read .config: No such file or directory

 

any ideas?

Share this post


Link to post
Share on other sites

hello guys,

 

i have buy on aliexpress a sunvell r69 1gb ram/8gb nand and can´t run armbian on it = blackscreen no display screen with armbian on sdcard, android works.

 

i have check it and the box has lpddr2 ram... not ddr3 is it possible to run armbian on it?

 

best regards fredy

IMG_20190827_193151.jpg

Share this post


Link to post
Share on other sites
On 10/11/2019 at 10:19 PM, Liontek1985 said:

hello guys,

 

i have buy on aliexpress a sunvell r69 1gb ram/8gb nand and can´t run armbian on it = blackscreen no display screen with armbian on sdcard, android works.

 

i have check it and the box has lpddr2 ram... not ddr3 is it possible to run armbian on it?

 

best regards fredy

IMG_20190827_193151.jpg

Dear you,

I have the same board.

I tried many image files from armbian but failed.

https://www.armbian.com/beelinkx2/

https://www.armbian.com/orange-pi-one/

Can you install linux images successfully on this android tv box r69?

Can you tell me about the way to install that, please?

Thank you so much!

Share this post


Link to post
Share on other sites

Below is step by step which I did:

Step 1:

Download images .img from link:

https://www.armbian.com/beelinkx2/

https://www.armbian.com/orange-pi-one/

using the same chipset.

Step 2:

Use 'Etcher' tool to write .img to the sdcard.

https://www.balena.io/etcher/

Step 3:

Insert sdcard to the board android box tv r69, Allwinner sun8iw7p1, ram 1GB.

Step 4:

Power on and get log result from uart debug on board.

Error is:

"DRAM: 0 MiB
### ERROR ### Please RESET the board ###"

Share this post


Link to post
Share on other sites

Use H3Droid (h3droid.com) and install Armbian from H3resc menu.  We provide the correct fex/uboot for the old h2+ 1Gb ram version in the H3resc uboot/fex selector.

 

Cheers!

Share this post


Link to post
Share on other sites
Just now, TheLinuxBug said:

Use H3Droid (h3droid.com) and install Armbian from H3resc menu.  We provide the correct fex/uboot for the old h2+ 1Gb ram version in the H3resc uboot/fex selector.

 

Cheers!

Dear TheLinuxBug,

I want ask you clearly. Can you, please?

Below is some thing which i need install, isn't it?

https://h3droid.com/download

Step 1:

Download h3droid_installer-1.3.5.tar.

Step 2:

Extract the tar archive (tar -xf filename.tar) in a folder with enough space to hold the contents (~450MB)

Step 3:

Update 00_conf file to set OUTDEV variable. It should contain either device or plain file path (ex: OUTDEV=/dev/mmcblkX or OUTDEV=/dev/sdX or OUTDEV=/some/path/to/somefile.img)

Step 4:

Copy your PUBLIC SSH key(s) to the install folder (ex: cp /root/.ssh/mykey.pub ./) (Optional, but required to have root access via SSH)

Step 5:

Execute 10_init_new_card.sh to write image to your SDCard or somefile.img (in case of a file, you can use it later with dd/etcher/winimager to write to real device)

Step 6:

Note: run only 10.. script, other files are meant to be called from it in order. (for example 20.. prepares partitions.dat used in 30..)

h3odroid.PNG

Share this post


Link to post
Share on other sites

Unfortunately this not the right place to discuss these issues.  However, I would suggest you actually read the website instead of just randomly doing things.

 

If you would have read, you would have use the H3ii image and used etcher or similar to write it to an SDcard instead of using the full installation package.

 

If you read the site we have documentation for H3ii and H3resc on the site which you can use for a better understanding of those tools

 

Cheers!

Share this post


Link to post
Share on other sites
9 hours ago, congtm said:

Dear you,

I have the same board.

I tried many image files from armbian but failed.

https://www.armbian.com/beelinkx2/

https://www.armbian.com/orange-pi-one/

Can you install linux images successfully on this android tv box r69?

Can you tell me about the way to install that, please?

Thank you so much!

 

Hey @congtm - Try this armbian-build (Kernel 4.19.80): https://drive.google.com/open?id=1yoe5gkaeufAJQK2Z7hljda46VuHPdnvZ

 

Cheers!

Share this post


Link to post
Share on other sites

log_r69_default.txt

8 hours ago, raschid said:

 

Hey @congtm - Try this armbian-build (Kernel 4.19.80): https://drive.google.com/open?id=1yoe5gkaeufAJQK2Z7hljda46VuHPdnvZ

 

Cheers!

Dear raschid,

Did you try that image on your android box tv r69 , Allwinner sun8iw7p1, ram 1GB, NAND 8GB (dolphin-fvd-p1)?

Because I got below error on my board.

I'm tried:

- sandisk sd card class 4 , 8GB.

- sandisk sd card extreme pro class 10, 16GB.

- samsung evo plus class 10, 32GB.

Burn tool: Etcher or use dd command.

"U-Boot SPL 2019.04-armbian (Oct 23 2019 - 21:32:04 +0200)
DRAM: 0 MiB
### ERROR ### Please RESET the board ###"

Below is log booting default on my board, not use sdcard on board.

Can you check it, please?

log_r69_default.txt

Share this post


Link to post
Share on other sites
9 hours ago, TheLinuxBug said:

Unfortunately this not the right place to discuss these issues.  However, I would suggest you actually read the website instead of just randomly doing things.

 

If you would have read, you would have use the H3ii image and used etcher or similar to write it to an SDcard instead of using the full installation package.

 

If you read the site we have documentation for H3ii and H3resc on the site which you can use for a better understanding of those tools

 

Cheers!

Dear you,

I have just tried h3droid_installer.img.xz.

Use tool 'Etcher' or use dd command to burn image to my sdcard.

My sdcard which I tried all.

- sandisk sd card class 4 , 8GB.

- sandisk sd card extreme pro class 10, 16GB.

- samsung evo plus class 10, 32GB.

My OS is ubuntu 18.04 LTS.

But, I have the same error.

U-Boot SPL 2017.07-00494-g19d1f1a2f3-dirty (May 30 2019 - 18:01:48)
DRAM: 0 MiB
### ERROR ### Please RESET the board ###

Can you check it to help me, please?
Below is log booting default on my board, not use sdcard on board.

 

log_r69_default.txt

Share this post


Link to post
Share on other sites
4 hours ago, congtm said:

Dear raschid,

Did you try that image on your android box tv r69 , Allwinner sun8iw7p1, ram 1GB, NAND 8GB (dolphin-fvd-p1)?

Because I got below error on my board.

This image is currently running on exactly this box (android TV-box R69). I used Etcher to burn the image to a Class 10 SAN-Disk card. Insert card and boot.

There seem to be different versions of this box around - maybe yours is different from mine ...

 

Cheers!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
9 9